StarCraft® II

Certain Computer Configurations Slow to Start

Community Manager
Posts: 1,155
For some time now, we've been working to solve issues where players with certain hardware configurations load into the start of a game several seconds after their opponent has started.

Several fixes have been made to address this. Some will be introduced very soon in a small patch to Wings of Liberty, and some will come with Heart of the Swarm. When Heart of the Swarm launches, there will be a consolidation of code, so players who don't upgrade to the expansion will still get all fixes.

We already have multiple fixes for this issue in the Heart of the Swarm beta, so any reports of the problem having disappeared or still occurring in the beta would be greatly appreciated.

It's a multi-faceted problem. We've seen it caused by GPU drivers, slow hard drives, and even background programs affecting performance. The fixes we've implemented have solved it for a number of specific hardware configurations, but there may be causes that we've not yet found.

Feel free to discuss the subject here, and thank you for your feedback.
Edited by Kaivax on 1/11/2013 7:29 PM PST
Reply Quote
Posts: 644
So if im reading this correctly,

The issue is solved currently in hots

The issue will be solved in a future patch wol

you are looking for people who still have problems with the issue in hots?
Reply Quote
Posts: 13
Thank you. Been playing with a 13 second start delay for months on NA. (Radeon GPU). Seriously demoralizing great to see a fix even though it did take long
Reply Quote
Posts: 4
YUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSS
Reply Quote
Posts: 26
THis is good. thx blizz. the only thing mising from that update was removing Fungal. %) JK (not really)
Reply Quote
Posts: 2
nice, i was noticing that in several ocations
Reply Quote
Posts: 26
Smurf, i saw u on sunday, u did good at the Lan, sry bout ur loss against pyre, i think
Reply Quote
Posts: 1,235
having the issue while running intel q6600, (4g)ddr2, radeon 4890, with cheap
sorta slow HD's on winxp32-sp3 mobo is a p5q-DX
my video drivers are recently updated.

before 1.5.4 I had roughly 9 seconds start lag, confirmed via replay.
I still have this same lag roughly, HOWEVER.... at this time the loading
screen for the match behaves differently, the loading bars for each player
line up roughly with the progress of the main loadbar bottom of the screen.
when the loading bars are done the match starts soon after.

previous to 1.5.4 one bar would lag behind the main loading bar at
the bottom of the screen, and when all were finally well completed (5 or 6 seconds)
the mouse cursor would change to the races cursor before i could see the
screen, then another few seconds wait till the screen popped.

the loading DOES appear to happen faster, buy my relative delay is still
about 9 in game seconds on fastest speed.
Reply Quote
Posts: 13
Hi, the delay is still there... despite the patch 1.5.4

I have a 15inch macbook pro (mid-2009) with Geforce 9400m 260 mo

Nom du modèle: MacBook Pro
Identifiant du modèle: MacBookPro5,4
Nom du processeur: Intel Core 2 Duo
Vitesse du processeur: 2,53 GHz
Nombre de processeurs: 1
Nombre total de cœurs: 2
Cache de niveau 2: 3 Mo
Mémoire: 8 Go
Vitesse du bus: 1,07 GHz
Version de la ROM de démarrage: MBP53.00AC.B03
Version SMC (système): 1.49f2

I played a custom game against the computer and the game began at 9s
Reply Quote
Posts: 4
I've noticed this issue with multiple Macbook Pros, 2012 and 2010 editions. I can't speak for the 2010, but the 2012 edition still has the issue, with slightly different loading screens, much like as mentioned by Agnosis.
Reply Quote
Posts: 12
Why not get all the players into the game. Then do the 5.4.3.2.1 Start - That way its insured all the players are present and ready before they can start..

Or they can select an "I'm ready box" to start the count..
Reply Quote
Posts: 30
Macbook player here... I am still getting a ~10 second delay at the start of each game. Perhaps it is because I don't have OS X 10.8?
Reply Quote
Posts: 9
W7 X64 ultimate, with a crossfire of 7970 and a 3930K. Absolutely no difference before and after the patch. I still start between 7 and 14 seconds... And this lasted for months now, while everything was perfectly fine at launch....

If there is anything I can do to help you nail down the issue, please let me know, this is just insane to have such a disadvantage compared to other people.

Thanks and good luck going to the bottom of this.
Reply Quote
Community Manager
Posts: 1,155
Thanks for the feedback. Please keep it coming!
Reply Quote
Posts: 91
With the recent 1.5.4 patch that fixes delay start in wol has improved the start alot in a sense. I can see the first 15 seconds of game now but the lag that comes after loading screen prevents any clicking to move scvs to mine until around 10 seconds. Great job though, I use to only pop in 15 seconds in. Now I am in the game for those seconds but can not do anything really.
Reply Quote
Posts: 3,082
Why not start the game paused and give every player a "ready button", and a short 5 second timer to start the game once every one presses ready.
Reply Quote
Posts: 37
As a "noobbookpro" user of mac's myself, I've found that I get into the game around the 7-15second mark having my econ slightly delayed. I'm thrilled that blizzard took some time to address that as an issue.
Reply Quote
Posts: 33
I'v noticed if my processor is overclocked 4.4-4.7ghz sometimes the game will freeze for about 20 seconds at beginning of match and 5-10 seconds during the match and sometimes even crashes and generates a memory error (probably due to low voltage) but if its 4.3ghz or below then its fine
Reply Quote
Posts: 11
Wow, at least the game worked before even though I started every game 5s late. Now it lags like hell. Great, thanks. Way to test on your Macs.
Reply Quote
Posts: 11
Even watching replays lags hardcore. Well so much for making Masters this season. Great.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]