My Starcraft 2 will not open.

(Locked)

Posts: 51
I can not get starcraft 2 to work at all. It was fine a while ago, but now, whenever I try to open up SC2, it says opening/updating launcher, then just does nothing. It just closes no error no nothing. I already tried uninstalling everything starcraft 2 related and doing a clean reinstall, didn't work. I have a CD, tried that, didn't work. I even just deleted everything related to starcraft on my hard drive, and got the installer from blizzard, and it will not open. The same thing is happening with WoW and D3.
What could be causing this and how can I fix it?
Posts: 4
Same problem for me as well.

Tried deleting C:\ProgramData\Blizzard Entertainment\
but didn't work.

Tried reinstalling. Tried to download the 1.5 migration but there aren't any available anymore.
Edited by BaKaOne on 1/24/2013 8:44 AM PST
Support Forum Agent
Posts: 35,315
Everen

Try this:

1. Make sure that Windows is set to show hidden files.

Here's how to do that: http://windows.microsoft.com/en-US/windows-vista/Show-hidden-files

2. Navigate to the C:\ProgramData folder and delete the Battle.net folder.
3. Navigate to the SCII folder and delete the "Updates" folder.
4. Launch SCII.

Let me know what happens.
______________________________________________________
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
Posts: 32
I did this and the Launcher Updater opens with a progress bar and says Updating Blizzard Launcher, then closes and nothing happens.
Support Forum Agent
Posts: 31,088
Halldor, there are a number of things you can try. Please let us know how it goes.
________________________________________________
Monday - Friday, 8 am - 5 pm PST

'Look at flesh. See only potential. Strands, sequences, twisting, separating, joining. See how it could be better. Eat flesh, splinter bone. Inside me, can touch it. Weave it. Spin it... Make it great.'

Rate me! https://www.surveymonkey.com/s/Velnrak
Posts: 1
same problem for me to but it is not even launching
Posts: 1,157
Hey Sasha,

Since this thread is a little over a year old, I believe it would be better to create your own thread about this issue and try to give as much details about it as possible.

The only thing I can suggest at the moment is to try booting your computer into selective startup mode, and see if that makes a difference. Just to rule out another program interfering with the game.

Selective Startup
https://us.battle.net/support/en/article/shutting-down-background-applications
Edited by Deanx on 7/10/2014 8:28 AM PDT
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]