StarCraft® II

Game Client Version Mismatch Error Message

Posts: 240
Same as ShadowPROXY.
Posts: 6
Uhmm, When launching SCII Wings of Liberty. On your Launcher window it says "Downloading data for an upcoming patch"

I wonder if this will fix the issue.
Posts: 22
its been 4 days
Posts: 10
Looks like i am not the only one having the Your account has no game accounts that can be used in this region. Are you using the correct client? issue
Posts: 2
Im having the same issue here. i also get it in the WOL though i able to get past that but not in HOTS sadly
Posts: 1
Same problem. Both SCII-1 and SCII-2 don't work , but WOL is able to log in.
Hope that can fix this problem quickly!
Edited by EndlessChaos on 2/9/2013 8:17 PM PST
Posts: 2
I still cant log in for WoL or Hots client. I get a Region Mismatch. what should i do ?
Posts: 5
MrHobbers#923
Posts: 2
Lucridius#1429
Posts: 2
I can log into WoL now, cant seem to play a quick match as there are no modes or races to choose from.

Cant get pass the log in page for HOTS
Posts: 1
i just tried to start playing the beta today and i have the same problem with the region.
Posts: 2
Same here saying have no accounts for this region. I pre-ordered the collector's edition a couple days ago. Sucks I can't even log in to play. =(
Posts: 1
I have the same problem as many. No accounts for this region. Bought the game a couple of days ago and can't play. Don't want to wait for the release.
Posts: 4
Same issue here:
"Your account has no game accounts that can be used in this region. Are you using the correct client"

Doesn't matter if I choose SC-I or SC-II. I didn't have a previous install of SC2 on this computer so it was a clean install.
Posts: 1,105
I am getting the "Your account has no game accounts that can be used in this region" error message on both SC-1 and SC-II login.

This is bumming me out :(
Posts: 2
I am also getting the "Your account has no game accounts that can be used in this region" error message on both SC-1 and SC-II login. The beta is listed under my game accounts. I just wan't to be able to log in and play.

I can't post to the beta forum either.
Posts: 22
I am also getting the "Your account has no game accounts that can be used in this region" error message on both SC-1 and SC-II login.

Much help, would be awsome.
Posts: 2
I am getting the same region error with both SC-I and SC-II. When is this going to be fixed...?
Posts: 7
same here
This topic has reached its post limit. You may no longer post or reply to posts for this topic.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]