StarCraft® II

Game Client Version Mismatch Error Message


That's what I was thinking, but I could log in and play just fine until the patch, like some other people are describing. Maybe I just got really lucky and got a few free beta days.


If you were in and playing I have no clue. I haven't been able to play anyways because of the Mac client but now that it is fixed I was shown to be flagged today. Might have to wait and see.

01/25/2013 08:51 PMPosted by Zamka
We are probably all not flagged.


http://oi45.tinypic.com/ejv1gz.jpg

That very bottom part means you are flagged for Beta testing.
Edited by DuoVandal on 1/25/2013 8:54 PM PST
Alright, well I'm glad they're working on it. I seriously thought it was something on my end for the longest time and then I check the forums and see there's five pages worth of people having the same problem.
I am flagged for both scII-1 and scII-2 beta as well as SCII-1 standard editions (heart of the swarm).
01/25/2013 08:39 PMPosted by DuoVandal
My account still shows WoL PTR. Can't post in the beta forums either...


You aren't flagged then, if account doesn't show Heart of the Swarm with SCII-1 (or SCII-2) with beta under it then you aren't flagged.

Hopefully they will refund my money for now so I can put it towards crysis 3.


Refund because you couldn't play a beta for a few hours? Not likely. Beta isn't 100% guaranteed to work all the time.


Its not up to them. Its called false advertising. It say "Yes, beta access to all those who pre purchase HotS" Thats the only reason I pre purchased. They don't live up to what they said, then I dispute charge on my bank account and force my refund.

I am willing to give them the benefit of the doubt, which is why I haven't done so already. But if not fixed by Monday Im out till release.
I have the same error as all...
01/25/2013 09:21 PMPosted by Endless
Its not up to them. Its called false advertising.


That's the same ignorant statement all the other people would post when they couldn't get into the Mists beta due to some error or what not. It's not false advertising, it's a beta. It's not guaranteed to work all the time and if you specifically bought the game just to get the beta then you were buying it for the wrong reasons and have no real say in it as the beta is just an addition, not a promise.

Take your self entitled opinions to somewhere else as people here are waiting on a solution to an actual issue.
I love starcraft regardless. It sucks not being able to get on the beta, but this is exactly what betas are for. Would you rather this happen two weeks into release... no. So be glad that this issue can be addressed before the final release.
Community Manager
It appears that this issue will require further investigation. Should any additional information become available, updates will be posted within this thread. Thank you all once again for remaining patient as we look into this issue.
Its not up to them. Its called false advertising. It say "Yes, beta access to all those who pre purchase HotS" Thats the only reason I pre purchased. They don't live up to what they said, then I dispute charge on my bank account and force my refund.

I am willing to give them the benefit of the doubt, which is why I haven't done so already. But if not fixed by Monday Im out till release.


Oh man....just...oh man
I'm sorry you have the money to spend on pre ordering something. Because that's just such an ignorant statement that I can't even deal with it. It's actually because of americans (I assume) like you that make it so easy for non americans to make so much damn money in your country.
01/25/2013 09:34 PMPosted by Aldrexus
It appears that this issue will require further investigation. Should any additional information become available, updates will be posted within this thread. Thank you all once again for remaining patient as we look into this issue.


Very good, I will continue to try from time to time but will keep a close eye on this thread.
Seriously, you think you would have this fixed by now. Why is the beta patch not only stopping us from playing beta... but it is also stopping us from playing WoL? How bad did you butcher battle.net...
Thank you for all the info. I'm having this exact problem. I preordered in December and the beta worked for the past 3 weeks, but It never really showed up officially or let me post in the forums. I really hope to go back to testing my fast burrow roach rush!
Yesterday I opened a ticket fot this problem that I'm also experiencing. The error is "Invalid login", the one many others here are experiencing. Here's the screenshot:
http://imgur.com/EAaXqFP

But the support told me that they don't support beta. Which is OK, so I tried to play WoL. Again I could not log in and I still cannot log in since yesterday. The error is "Login error" and it is also a mismatching region error. Here's the screenshot:
http://imgur.com/u9BsyON

So, again I asked the guy on the ticket support what to do (because this was WoL which is supported, unlike HotS beta) and he basically gave me the FO wall of text - to check internet connection, to check if drivers are OK, etc.

As that was going nowhere, I tried with the chat. Guy there made more effort to understand what I was complaining about and we tried a few things and I even pointed him to some of the threads here on the forum. He was really trying but couldn't fix this. The last advice he could gave me was to re-install the game.

There's no way in hell I'm re-installing this two games! What is it - 16GB or something? Who will pay for the bandwidth? Who will guarantee that it will fix the problem?

I got access to beta through pre-purchase and in return now I cannot even play WoL?

This obviously has got nothing to do with the clients on my machine. I'm in Europe and I have US accounts for both games, so this is definitely related to the global gameplay changes. Game is obviously insisting of hooking me up with the EU servers based solemnly on my location, regardless the clients I have.

I wouldn't mind if this was done during the patching, not after it, as I now cannot play either game. What I'm left with now is to simply sit and wait for the final version of global play to kick in, even if it is in March perhaps, to fix this situation and allow me to log in to WoL and HotS.
Not good, man, not good.
01/25/2013 10:47 PMPosted by NegativeFX
The error is "Invalid login", the one many others here are experiencing.


There is nothing you can do on your end except wait.

01/25/2013 10:47 PMPosted by NegativeFX
I'm left with now is to simply sit and wait for the final version of global play to kick in, even if it is in March perhaps, to fix this situation and allow me to log in to WoL and HotS.


Aldrexus has been keeping us informed since we've notified him of the situation. It won't be long I highly doubt it would take to March to fix.
Yesterday I opened a ticket fot this problem that I'm also experiencing. The error is "Invalid login", the one many others here are experiencing. Here's the screenshot:
http://imgur.com/EAaXqFP

But the support told me that they don't support beta. Which is OK, so I tried to play WoL. Again I could not log in and I still cannot log in since yesterday. The error is "Login error" and it is also a mismatching region error. Here's the screenshot:
http://imgur.com/u9BsyON

So, again I asked the guy on the ticket support what to do (because this was WoL which is supported, unlike HotS beta) and he basically gave me the FO wall of text - to check internet connection, to check if drivers are OK, etc.

As that was going nowhere, I tried with the chat. Guy there made more effort to understand what I was complaining about and we tried a few things and I even pointed him to some of the threads here on the forum. He was really trying but couldn't fix this. The last advice he could gave me was to re-install the game.

There's no way in hell I'm re-installing this two games! What is it - 16GB or something? Who will pay for the bandwidth? Who will guarantee that it will fix the problem?

I got access to beta through pre-purchase and in return now I cannot even play WoL?

This obviously has got nothing to do with the clients on my machine. I'm in Europe and I have US accounts for both games, so this is definitely related to the global gameplay changes. Game is obviously insisting of hooking me up with the EU servers based solemnly on my location, regardless the clients I have.

I wouldn't mind if this was done during the patching, not after it, as I now cannot play either game. What I'm left with now is to simply sit and wait for the final version of global play to kick in, even if it is in March perhaps, to fix this situation and allow me to log in to WoL and HotS.
Not good, man, not good.


Same thing happened with customer support here, most just told me basically that the "beta" isn't a part of their job description, and advised me to visit the hots forum, which I do not have access to for some reason, and merely pushed me into a wall, where there is both nothing I can do, nor ask for another's help in this matter. However I luckily am not having problems with WoL as you are too, so good luck mate! I am pretty sure that many people are experiencing this problem because blizzard ignored the first problem which was the lack of access to the HoTS forum and made a patch around it which put them in an even bigger hole. You used to be able to choose which game/account to log into a forum with and as long as you had the cd key, you could post even with a different game's account, now there is no option of changing games/accounts while all are bound to 1 email. And during login they only ask you for the email and password, thus forcing the Wings of Liberty Log In even in HoTS. The solution is most likely very simple, the problem has not been looked at deeply, and assumptions have been made, primarily on the players' negligence, however just because statistics are against the average American, does not mean that we're all retarded!
Aldrexus has been keeping us informed since we've notified him of the situation. It won't be long I highly doubt it would take to March to fix.[/quote]

So you too expect them to take less than a month? That is fairly probable.
01/25/2013 11:02 PMPosted by Zamka
So you too expect them to take less than a month? That is fairly probable.


The issue just came up today and they were notified of it 6 hours ago.
Edited by DuoVandal on 1/25/2013 11:17 PM PST
01/25/2013 11:16 PMPosted by DuoVandal
So you too expect them to take less than a month? That is fairly probable.


The issue just came up today and they were notified of it 6 hours ago.


Haha. indeed.
01/25/2013 09:26 PMPosted by DuoVandal
Its not up to them. Its called false advertising.


That's the same ignorant statement all the other people would post when they couldn't get into the Mists beta due to some error or what not. It's not false advertising, it's a beta. It's not guaranteed to work all the time and if you specifically bought the game just to get the beta then you were buying it for the wrong reasons and have no real say in it as the beta is just an addition, not a promise.

Take your self entitled opinions to somewhere else as people here are waiting on a solution to an actual issue.


Welcome to the internet. I was not saying if the beta doesn't work Ill get a refund, I was saying if I dont get in att all due to no invite.

Sorry fanboy but blizzard aint perfect. If they dont want people buying just for that reason then why are they saying "Buy the pre order and get beta access" huh? Don't use it as a marketing strategy, then get pissy just because I expect what they promised.
This topic has reached its post limit. You may no longer post or reply to posts for this topic.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]