StarCraft® II

Can't play quickmatch, can't submit a ticket

The button to submit a ticket is greyed out and a little red circle with a line on it appears when I move the cursor over it, so I cant submit a ticket to support.

At the same time, If I try to play a ladder game on NA or any quick match game the screen doesn't show the options, the whole quickmatch tab is blank except fot the titles. I have read the "change your DNS to google suggestion, it doesn't work. Blizzard need to fix this, the issue is on their end, my ISP and all of the ISP's in Japan australia etc did not simultaneously make changes to their DNS settings, Blizzards DNS server is not resolving correctly: us.depot.battle.net is resolving to IP address 68.232.45.253 when it should be resolving to 12.120.152.128

Let me log a ticket, fix this issue, dont play dumb and blame all of the regions ISP's, I payed for the game, you chose to lock me into battlenet with no LAN option to play with my friends, so when battlenet bugs out, fix it, dont blame my ISP and everyone elses.
Edited by Fakuna on 1/29/2013 4:08 PM PST
Reply Quote
As I am unable to log a ticket with that option being greyed out I would appreciate a response here asap.
Reply Quote
http://us.battle.net/sc2/en/forum/topic/7708411977
Reply Quote
Tried the suggestions in that thread, they do not work for me, and I am pretty sick of having to make changes to my PC which could upset future installs, the only fix i haven't tried is modifying the host file because that will cause me issues if blizzard ever change their DNS again, and i will have no way of knowing if it is a blizzard problem or the changes I made, if i even remember what changes i made.

The fact that editing the host file resolves the issue shows that blizzard could fix this issue if they chose to, as the issue is that us.depot.battle.net is resolving to IP address 68.232.45.253 when it should be resolving to 12.120.152.128. Instead of addressing this, they keep suggesting we all override our computer settings and use a different DNS (which doesn't help) and blaming all of the regions ISP's.

Blizzard, as I stated, I can not post a support ticket, you have greyed out that option for sea users like me for many months, can you please respond to this thread as it is the only method I have of communicating with you. It would be nice if you told us why you have removed the option for us to submit support tickets.
Edited by Fakuna on 1/29/2013 4:08 PM PST
Reply Quote
Support Forum Agent
01/27/2013 05:35 PMPosted by Fakuna
Blizzards DNS server


01/29/2013 04:05 PMPosted by Fakuna
The fact that editing the host file resolves the issue shows that blizzard could fix this issue if they chose to, as the issue is that us.depot.battle.net is resolving to IP address 68.232.45.253 when it should be resolving to 12.120.152.128. Instead of addressing this, they keep suggesting we all override our computer settings and use a different DNS (which doesn't help) and blaming all of the regions ISP's.

Fakuna, did it help to change your hosts file?

Please keep in mind that we do not provide DNS service. This is typically handled by an ISP. Your computer gets DNS information when it gets an IP address, and this is usually provided by your ISP. A quick Google search about how DNS works will bear this out.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Pelinti
Reply Quote
yes but so far blizz has blamed our ISPs the problem is the isp blizz uses not every isp in the sea region. I will not edit the host file as it is a core system file and would result in me having a setting that overrides any future address change blizz pushed out potentially permanently breaking my game if blizz made such a change in the future, I would have no way of knowing my host file was causing the issue, and neither would blizz. Are you honestly suggesting I make this change as a fix along with all of sea instead of fixing it with your isp?
Edited by Fakuna on 1/29/2013 8:17 PM PST
Reply Quote
Support Forum Agent
01/29/2013 08:15 PMPosted by Fakuna
. I will not edit the host file as it is a core system file

You can add an entry into the hosts file, and if it doesn't help, you can delete the line, or comment it out.

Our ISP it not pushing out incorrect DNS information, as every region but the SEA region is connecting fine.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Pelinti
Reply Quote
01/30/2013 08:44 AMPosted by Velnrak
Our ISP it not pushing out incorrect DNS information, as every region but the SEA region is connecting fine.


That doesn't mean your ISP is not pushing out incorrect information, that means it is pushing out correct information to some regions and incorrect to SEA.

Have you been reading the thread you mentioned?

Have blizzard acknowledged this and are they following up with the faulty DNS provider and owner of battlenet DNS services? Or are you expecting us to do the work on Blizzards behalf?

If you run "dig us.depot.battle.net" with iiNet's DNS server you get this:us.depot.battle.net. 300 IN CNAME wpc.758c.att-acdn.net.wpc.758c.att-acdn.net. 2652 IN CNAME gs1.wpc.edgecastcdn.net.gs1.wpc.edgecastcdn.net. 3563 IN A 68.232.45.253

With Google's DNS:us.depot.battle.net. 99 IN CNAME wpc.758c.att-acdn.net.wpc.758c.att-acdn.net. 6433 IN CNAME wpc.758c.na.att-acdn.net.wpc.758c.na.att-acdn.net. 5924 IN CNAME site-rrc--grp-ldr--gc1.wpc.nossl.ms.ap.att-acdn.net.site-rrc--grp-ldr--gc1.wpc.nossl.ms.ap.att-acdn.net. 380 IN CNAME site-rrc--grp-ldr--gc1.wpc.nossl.ms.na.att-acdn.net.site-rrc--grp-ldr--gc1.wpc.nossl.ms.na.att-acdn.net. 26 IN A 12.120.152.128

Apparently wpc.758c.att-acdn.net belongs to Akamai and it is giving out a different IP address to Google than it is to iiNet (and presumably other ISPs in SEA).


Shouldn't blizzard be contacting Akamai? and getting this fixed directly? Do you really think it is reasonable to require us to edit our windows system files to play the game? Or even force us to use google DNS which has quite a few known issues for mac users etc. Can we expect a direct effort from Blizzard to resolve this or is it going to be left 100% to us?
Edited by Fakuna on 1/30/2013 3:36 PM PST
Reply Quote
This really needs to be patched in to fix.. there is nothing wrong with ISP over here in Australia.. and your post even states its happening all throughout SEA.. so we aren't connecting fine...

With the new game coming.. I really hope this gets fixed before then.
Reply Quote


With the new game coming


I will help you understand.
Blizzard does not care about this game anymore. The new cash cow is coming... They need to get that going before this game. If you were on the beta and saying " I cannot access this game " if you were on the beta and saying " I need help doing this " then you will get help for the issue.

As we saw they got a new patch on the beta. They got some issues fixed yet again. But as for us.. all we are going to get from blizzard is " DILLIGAF "
Edited by Tanker on 1/30/2013 7:43 PM PST
Reply Quote
I also got a greyed out button when trying to submit a ticket. Then I realised that the web page was just poorly designed* and I wasn't following the steps properly. This is what I did to get it to work:
1. Make sure you're logged in to us.battle.net. Check the top of this page and log in if you're not already.
2. Go to https://us.battle.net/support/en/ticket/submit
3. Where it says "Select a game or product", select Starcraft II.
4. Click on "Choose from a list of pre-defined topics"
5. Under "Topic", select "I have a technical issue".
6. Under "Topic Details", select "I cannot connect to the game".
7. Ignore the list of articles that appears.
8. The "Submit a ticket" button should now be blue, so click it.
9. Now you should see the real "Submit a ticket" page. You can fill in the details of your problem here and submit the ticket.

Apologies if you've already done this and the button is still greyed out! In that case, it could be a browser bug. Try clearing your browser cache and cookies and try again, or try a different browser.

* I say the page is poorly designed because (a) it doesn't tell you why the button is greyed out and (b) you can't see all the information you need to fill out until you select each option one at a time. It would be better if it didn't show the submit button until the end of the process, or if it instead showed you all the fields at the start and said they were all required files.
Reply Quote
Thanks Nobody, yes that convoluted method works, I was finally able to submit a ticket, the blizzard support guys tow the line that there is no issue on their end, although now we know from the sticky thread that this was not the case, but we had to do all the research for them before they would even investigate.

Unfortunately, that is how blizzard works at the moment, blame the user until the user finds the problem and the fix for them, put in a minimal effort at the end. Looks like it's still not fixed for many users even now, will check my own when i get home.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]