StarCraft® II

I apologize

Posts: 74
I apologize for posting numerous times but I just wanted to show Blizzard staff some issues.

http://us.battle.net/sc2/en/forum/topic/7764666412

Please just take a brief read at the post I put.

I posted that about an hour ago and a Blizzard Staff replied. But the solution still did not work.
I just wanted to show what my account looks like.

http://i.imgur.com/ivywCgk.jpg

As you can see, I do not get Starcraft II Heart of the Swarm [SCII-1] Betaor Starcraft II Heart of the Swarm [SCII-2] Beta

I bought this digitally so my WoL is overlapped by my HoTS. But that does not explain no beta. I would like to see if it is an error or was on purpose.
I apologize again for posting a lot and links. I hope that link does not count as inappropriate.
Thank you.
Reply Quote
Support Forum Agent
Posts: 28,890
PriME

I just took another look, and your account is not coming up as being flagged for beta on my end either. Unfortunately, there is nothing that we can do on the Tech Support Forums about this issue. You will want to contact an account representative so that they can look into this for you.

You can contact them by opening a Support Ticket. To do so just follow this link: https://us.battle.net/support/en/ticket/submit
______________________________________________________
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
Reply Quote
Posts: 74
I just submitted a ticket and a reply came. It says the same as your answer. Do you have any way I can contact the representative? Thank you.
Reply Quote
Support Forum Agent
Posts: 28,890
PriME

Try replying to the ticket for more information. If they still can't assist, I may need to have a specialist take a look, but they wont be back until Monday.
______________________________________________________
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
Reply Quote
Posts: 74
This is what they replied with.
http://i.imgur.com/Tvkbsje.jpg
Do you think you can call a specialist?
Edited by PriME on 1/27/2013 3:35 PM PST
Reply Quote
Posts: 74
I got into the beta client and it worked! but i cannot post on the forums.... help?
Reply Quote
Support Forum Agent
Posts: 28,890
DOxHybrid

I'm glad to see that you finally got into the beta. As far as posting in the forums go, you may need to clear your web browser's cache and cookies. If that doesn't help, try using a different browser.
______________________________________________________
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
Reply Quote
Posts: 74
Niether of those options worked :/
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]