I just downloaded the HoTS Beta and now I am unable to run the editor without getting the "game client version mismatch error". I can play both HoTS Beta and WoL, but I cannot log on to the editor. Not sure if anyone else has this problem. Please comment if you guys have any sort of suggestions. Also, I should mention I am running Starcraft on a mac running OSX 10.8.2

Thank you guys

I was able to use the editor with no problems before the HoTS beta
Edited by Kelby on 1/31/2013 4:19 PM PST