StarCraft® II

Rewards are currently unavailable+no conten

Posts: 73
Guys, I haven't play SC2 for a long time and I recently decided to play again, but strangely I can't change my portrait, cause when i click on profile then rewards then portraits the game just say Error, Rewards are currently unavailable.

Another problem is that I can't play anything other than campaign. I click on quick match I can only select the difficulty and nothing else. I click on Custom Games or V.S. A.I. it just says No content found.

Can anyone else provide me a fix? I tried reinstalling the game and I still has this problem.
Reply Quote
Posts: 1
Me too.
Reply Quote
Posts: 73
Can someone please provide a fix?
Reply Quote
Posts: 49
Same here, Am has the same problem as you guys.
although mine does not say "Error, Rewards are currently unavailable."
its just shows nothing.
By the way, my Sea account works fine.
Reply Quote
Posts: 73
The reason I prefer to be in NA is because the population in SEA is pretty limited, it is kinda hard for me to play with someone on the equal level of strength. I'll try SEA in a moment.
Reply Quote
Posts: 49
Try this changing your dns
https://developers.google.com/speed/public-dns/docs/using#setup
for some reason the only one that worked for me was this one->For IPv4: 8.8.8.8
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]