Posts: 7
Hello I got a BETA key for HOTS today at EB GAMES in Canada. The Beta key was accepted and is now showing in my Games List on I have downloaded and updated the HOTS Client for Mac and everything works fine until I go to log in. It makes me select either SCII-1 or SCII-2 and says for both that the wrong client is being used. I checked and I made sure it was the US Client I installed.

Others on the forums seem to have the same problem but I could not find a fix. I was hoping you could help as I can still log into StarCraft Wings of Liberty with no issues.

I am really looking forward to Beta Testing HOTS ASAP. Look forward to hearing back from you. Thank you Blizzard.
Reply Quote
Posts: 8
I've got the same problem :( was hoping to find the solution on the forums.

Edit: Here is a bigger thread about this issue, Blizzard is still trying to figure out what the problem is.
Edited by Fry on 2/8/2013 3:44 PM PST
Reply Quote
Support Forum Agent
Posts: 14,784
As Fry mentioned, this is being looked into. You'll want to post in the Beta forums, as Mac Technical Support is not able to assist with beta issues. Plus they are able to post updates faster, as they are in the know about all beta issues.
Reply Quote
Posts: 20
I have the same problem but can't post in the HOTS beta forum thread. It says I don't have clearance for the forum since I am not in the Beta (which I am).
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)