StarCraft® II

Starcraft Go Boom

Posts: 9
Last night, after finishing a game, the application exited. Started the application again, played another game, and it locked my Mac hard. Booted today, started watching a replay from last night and it locked again about 10 minutes into the replay. Started the application again after letting the patch finish downloading and the application locked hard again while connecting to other players. Every time I have launched the application, it locks up my Mac.

iMac 3.4 GHz i7 with 4GB RAM OS X 10.7.5 with fully updated software.
Reply Quote
Support Forum Agent
Posts: 14,784
Have you tried to run a repair from the launcher prior to playing to see if it helps?
Reply Quote
Posts: 9
Ran the repair tonight. Fired up the application. Played a game and it died in the middle of the game. Which was a pretty big bummer because it was an epic Silver League game.
Reply Quote
Posts: 9
This only started happening after the HoTS patch started downloading. It is now finished downloading. The computer continues to lock while playing.
Reply Quote
Posts: 9
Tonight was worse. Started the application and it locked up the computer within 30 seconds of login. I was just checking out who was online. Did not start a game or anything.
Reply Quote
Posts: 9
New data:

Started the application again. Started a game and the screen look like it locked. I noticed a weird sound coming from my second monitor. So I unplugged it from the iMac. I could hear that the game was still running. I hit Command-TAB and it successfully left the application to the desktop. Selected the application on the dock and I was back in the game and everything was working.

I am guessing it has something to do with the second monitor. Will investigate further tomorrow.
Reply Quote
Support Forum Agent
Posts: 14,784
Was SC2 being displayed on the external display?

Sorry for the late follow-up. I was out sick last few days :(
Reply Quote
Posts: 9
No, the game was displayed on the primary display. I have played many games without issue since disconnecting the secondary monitor. This only started happening after the update.

I hope you are feeling better now!
Edited by AlmostCool on 2/22/2013 4:38 PM PST
Reply Quote
Support Forum Agent
Posts: 14,784
If it is the secondary display, can you try this to see if it helps in anyway?

    1. Click on Finder
    2. Select Go from the system menu bar
    3. Click on Go to Folder
    4. Type in the following:
    ~/Library/Preferences5. Delete com.blizzard.starcraft2.plist
    6. Play StarCraft II
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]