StarCraft® II

The 2.04 Patch Raises Minimum Specs

(Locked)

Support Forum Agent
Although we've managed to greatly increase StarCraft II's graphical presentation without much change to the system requirements, please note that there will be a slight increase to the system requirements when patch 2.04 goes live.

You can compare the original Wings of Liberty requirements to the new 2.04 (currently listed as Heart of the Swarm) requirements on the above support article. Thanks!
Edited by Kaltonis on 2/16/2013 7:27 PM PST
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]