StarCraft® II

StarCraft II Launcher Inoperable

(Locked)

Posts: 39
Up until now I have...

  • Removed everything Blizzard related from my Mac.
  • Created a new Admin account on said Mac.
  • Downloaded StarCraft Ii Setup file from Battle.net
  • I installed it, it took about 4 minutes. Says game is completely up to date.
  • I am well aware that's not possible on a 30Mbps connection.
  • I also noticed that the Library > Application Support > Blizzard folder, remains empty.

    When I launch the launcher, it says 'Game is up to date", I click play and get a crash. The error report is here: http://pastebin.com/U4ppGJLF

    Here are my Mac details

    Model Name: iMac
    Model Identifier: iMac12,1
    Processor Name: Intel Core i5
    Processor Speed: 2.5 GHz
    Number of Processors: 1
    Total Number of Cores: 4
    L2 Cache (per Core): 256 KB
    L3 Cache: 6 MB
    Memory: 8 GB
    Boot ROM Version: IM121.0047.B1F
    SMC Version (system): 1.71f22

    AMD Radeon HD 6750M:

    Chipset Model: AMD Radeon HD 6750M
    Type: GPU
    Bus: PCIe
    PCIe Lane Width: x16
    VRAM (Total): 512 MB
    Vendor: ATI (0x1002)
    Device ID: 0x6741
    Revision ID: 0x0000
    ROM Revision: 113-C2950H-170
    EFI Driver Version: 01.00.544
    Displays:
    iMac:
    Display Type: LCD
    Resolution: 1920 x 1080
    Pixel Depth: 32-Bit Color (ARGB8888)
    Main Display: Yes
    Mirror: Off
    Online: Yes
    Built-In: Yes
    Connection Type: DisplayPort

    System Software Overview:

    System Version: OS X 10.8.2 (12C60)
    Kernel Version: Darwin 12.2.0
    Boot Volume: Mac Solid State
    Boot Mode: Normal
    Computer Name: Ryan’s iMac
    User Name: Soudelier Ryan (gaming)
    Secure Virtual Memory: Enabled
    Time since boot: 22 minutes
    Posts: 39
    UPDATE

    I ran the repair tool. That seemed to work. But the launcher still does not give access to the game.

    For half a second I could see "Downloading data for an upcoming patch" or something to that effect flash, and then it says "Game is up to date". I click Play and got a crash.

    That crash is here: http://pastebin.com/K2ARQXe4
    Support Forum Agent
    Posts: 14,784
    Hey Soudelier,

    I updated your original post. I'm locking this thread so we can have only one post about this issue. This makes it easier to track the issue. Thanks!

    http://us.battle.net/sc2/en/forum/topic/8088619468
    This topic is locked.

    Please report any Code of Conduct violations, including:

    Threats of violence. We take these seriously and will alert the proper authorities.

    Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

    Harassing or discriminatory language. This will not be tolerated.

    Forums Code of Conduct

    Report Post # written by

    Reason
    Explain (256 characters max)

    Reported!

    [Close]