StarCraft® II

Display is going wrong

Posts: 7
Okay, so I had to update from 10.6.8, I am now using mountain lion on a macbook pro.

I have been using a 4:3 monitor prior to this, now my mac will allow me to display in a widescreen resolution on the 4:3 monitor. I open SC2 and it still keeps the widescreen setting but the game is stretched. I aligned all of the display settings, and even tried displaying the computer in 4:3 like usual, but starcraft is still forcing a 16:9 ratio, even when I choose the resolution that is 4:3. And even when these two ratios/resolutions match up perfectly, starcraft still displays stretched, and will not display properly.. any ideas?
Reply Quote
Support Forum Agent
Posts: 14,781
Can you post your system specs?

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)

Also, what resolutions options are being displayed for you?
Reply Quote
Posts: 7
Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro4,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.5 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache: 6 MB
Memory: 2 GB
Bus Speed: 800 MHz
Boot ROM Version: MBP41.00C1.B03
SMC Version (system): 1.27f3
Hardware UUID: DA652FB8-ED51-5523-9F55-C4ABCB7D9BEA
Sudden Motion Sensor:
State: Enabled

NVIDIA GeForce 8600M GT:

Chipset Model: GeForce 8600M GT
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0407
Revision ID: 0x00a1
ROM Revision: 3212
Displays:
Color LCD:
Display Type: LCD
Resolution: 1440 x 900
Pixel Depth: 32-Bit Color (ARGB8888)
Mirror: On
Mirror Status: Hardware Mirror
Online: Yes
Built-In: Yes
L2046NV:
Resolution: 1152 x 864 @ 75 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: 0
Main Display: Yes
Mirror: On
Mirror Status: Master Mirror
Online: Yes
Rotation: Supported

System Software Overview:

System Version: OS X 10.8.2 (12C60)
Kernel Version: Darwin 12.2.0
Boot Volume:
Boot Mode: Normal
Computer Name:
User Name:
Secure Virtual Memory: Enabled
Time since boot: 18 minutes

In the game I am able to choose-

1024x768
1072x804
1118x872
1162x872
1206x904
1246x934
1286x964
1326x994
1364x1024
1400x1050

And from display settings in the system preferences- (for the L2046NV monitor)

800x600
832x624
1024x768
1152x864
1280x768
1280x960
1280x1024
1344x1008
1400x1050
Reply Quote
Posts: 7
I will note I would like to use the 1400x1050 widescreen display on my 4:3 monitor, and have starcraft retain widescreen.
Reply Quote
Support Forum Agent
Posts: 14,781
Are you using the external display as a secondary display, or putting the MBP in clamshell mode and using the external display as the primary display? This will help me see what is going on.

Here is what I am thinking is happening. This may change depending on what you say.

So, it should be using the native resolution/ratio on the MacBook Pro itself. For that MacBook Pro:

Native Resolution: 1440x900
Ratio: 16:10

What you want it to do is to have a different aspect ratio.
Reply Quote
Posts: 7
I am using the monitor as my primary, not as a dual display.

so the 4:3 monitor is displaying 1400x1050
Reply Quote
Posts: 7
got an answer?
Reply Quote
Support Forum Agent
Posts: 14,781
Sorry, just came back from my weekend.

This might be because SC2 isn't detecting the ratio aspect correctly due to the adapter used.

Try this terminal workaround to see if it changes the detection of the resolution:

    1. Make sure StarCraft II is closed.
    2. Open Terminal (/Applications/Utilities)
    3. Copy/Paste the following command:
    defaults write com.blizzard.starcraft2 DesktopModeIsDefault 14. Press Return. (There should be no output if done correctly)
    5. Exit Terminal.
Reply Quote
Posts: 7
no worries!

Awesome, I will give it a try when i get the chance!
Reply Quote
Posts: 228
Sorry to intrude, but I kind of just want to satisfy my confused curiosity: How could you view a widescreen resolution on a 4:3 display without stretching? By letterboxing it and only using 1/4 of the vertical space?

Also, something maybe helpful: Have you checked your system's display settings with the display connected? If I understand, what you want to do is mirror your laptop's widescreen display to the external 4:3 display.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]