StarCraft® II

Low fps with powerful computer. HOTS expac.

(Locked)

So I just loaded up the WoL campaign mission "All In", you know the one where 5 million zerg attack you all at the same time... no lag issues present. But playing matches online or offline (or at least what SHOULD be offline), is just unplayable. I can't even multitask let alone micro, guess I wasted my money on a game that's only good for the campaign.
I just bought this game and am having this issue, this is bull!@#$ and I'm going to get my money back, didn't pay 60 %^-*ing dollars so i could lag down to 0fps after 15min in multiplayer games. I didn't buy this POS game to play a crappy campaign story. !@#$ you bliz, D3 sucked %^-, I should have known better than to think this game wasn't a *!@#show.
Anyway, here is the only proof you're gonna get, on extreme setting: http://i.imgur.com/WzWUG8Y.jpg

Happens in all modes on every single map I've tried.


What did your system memory utilization look like at the point you took those screenshots?

It's possible some of you are encountering a memory bottleneck instead of a processor utilization bottleneck. (Unlikely for those people with 8GB or more of system RAM or 4GB or more of VRAM, of course)
Edited by Migz on 4/7/2013 8:55 PM PDT
The lag happened once or twice in the past with WoL. Fixed few weeks or months later. Hopefully this is gonna be fixed ASAP.

For a RTS, who cares of all extra effects during the fights n battles, no time to watch those details, the essential things about these RTS games should not rely on GPU perf., ffs!!!

Please Blizzard, think about that and also, test your game/patch on several conventional configurations before launching it! Not everyone can afford a top Gaming PC to play your game!
Edited by BattleAngel on 4/7/2013 9:05 PM PDT


Seriously, try reading the thread next time.

The problem is that the newer versions of SC2 don't even use the hardware available properly on some systems. 40% CPU usage and 15-30% GPU while having the same low FPS on lowest settings as extreme during late game, on systems that can run Crysis 3 on high and Bioshock Infinite maxed at 60+ FPS in 1080p.


I tried reading the thread.. until I got through 20 versions of "#$%& Blizzard, because HotS doesn't run as well as WoL did <whaa, whaa>".

Do you have a screenshot showing your video settings, CPU/GPU usage during gameplay?

Because, what you describe did not occur during the BETA.

Also,

Do you have videos which show the FPS drop you're talking about?

What maps do you notice this on?

Does it happen during Arcade games?

Does it happen during replays?

Does it happen when you play offline?

Does it happen when you play against only AI opponents?

Does it happen when you play against only human opponents?

Does it happen more or less often in 4v4 vs. 1v1 matches?


Seems like you are the lucky one don't experience what most of people here lives, me included?!^ Wonder what config you have and settings you are using ;-)
Edited by BattleAngel on 4/7/2013 9:13 PM PDT
I should call a specialist or someone who can help me, because remote diagnosis won't work and they told me all solutions. It could be a problem with win 8 but I doubt it. Seriously, they should seek the causes of their problems among themselves rather than try hard mode to find problems at my system. Maybe some drivers are f!cked up and doesn't like starcraft. Whatever..

I hope new drivers or a later patch will fix this, no matter if its their intention or simply luck.


Win 8, not sure for I'm running Win 7 with merely same issues with my GTX 570 SC, upgraded from GTX 550 Ti thinking something would change and make any difference. ;-)
Win 8, not sure for I'm running Win 7 with merely same issues with my GTX 570 SC, upgraded from GTX 550 Ti thinking something would change and make any difference. ;-)


Yea, like i said before its definitely no windows 8 problem. And win 7 and 8 is more or less the same.
yea have this problem on windows 7 64x, i wonder if its some kind of issue with the new cloud-like app there using for bnet., does any one know if theres a background application that they use for it? maybe avg or firewalls are blocking it because its not named with starcraft or something along the line of that
Same is happening to me. The game is kinda freezing and stuttering on regular period, happens about 5 minutes into the game or so.
Wish this thread would get some kind of recognition from a Blue.
Bump
weekly sympathy post
Seems like you are the lucky one don't experience what most of people here lives, me included?!^ Wonder what config you have and settings you are using ;-)


Actually, as I later wrote, it turns out I do experience something (might not be the same) like what you all do. But, because I'm able to still run at 60+ FPS, I hadn't noticed it.

Something has changed since the BETA which causes this, because during the BETA, this was not reported.
In addition to the FPS drops, I'm getting a lot of stalls per minute as well. I played a 3v3 a few days ago and for some reason it ran better then a 2v2ai. Maybe one of those once in a blue moon kind of deals?

Lmfao, this is so pathetic it's actually funny. 274 posts with mine making 275 and not a single Blizzard response. What's even funnier is a GameSpot post I read on facebook about Blizzard never releasing Ghost. The highest liked comment was someone who said something like "Who cares, Blizzard isn't exactly a trusting company right now." So true lol.

Still waiting Blizzard. *ZzzzZzZzz*

*Edit: 275, damn Migz :P*
Edited by SKiNDATA on 4/9/2013 8:56 AM PDT
04/09/2013 08:54 AMPosted by Migz
Seems like you are the lucky one don't experience what most of people here lives, me included?!^ Wonder what config you have and settings you are using ;-)


Actually, as I later wrote, it turns out I do experience something (might not be the same) like what you all do. But, because I'm able to still run at 60+ FPS, I hadn't noticed it.

Something has changed since the BETA which causes this, because during the BETA, this was not reported.


Please stop talking for talking about your BETA, we are now far beyond that now!
04/09/2013 08:54 AMPosted by Migz
Seems like you are the lucky one don't experience what most of people here lives, me included?!^ Wonder what config you have and settings you are using ;-)


Actually, as I later wrote, it turns out I do experience something (might not be the same) like what you all do. But, because I'm able to still run at 60+ FPS, I hadn't noticed it.

Something has changed since the BETA which causes this, because during the BETA, this was not reported.


it was the same for me during the beta.

its been the same since patch 1.5.
exasperated bump. haven't picked up the game since I beat it almost a month ago
Dear blizzard, I am one of your biggest fans. I have played your games since blackthorn and my first computer game i ever had was Warcraft. I have waited for decades for you games and have done my part to help your company. I have bought Starcraft 1 4 different times. BUT now you have failed me. I waited forever for Diablo 3 only to play a free mmo named path of exile witch has filled the void from your failure. I waited forever for warcraft 3 and we all know about that piece of !@#$. And finally i have waited foreverto play starcraft 2 spent 1300 on a computer to make sure i could play it any game for the next 5 years. then spent 100 on the game and expansion witch should have all been 1 god damn game and ......... I CANT EVEN PLAY IT. if you guys don't even reply to us after I have spent weeks trying to figure this out, you can go %^-* yourselves and i will make damn sure you loose every bit of energy and money I PUT IN TO YOU.
04/09/2013 06:19 PMPosted by Jacob
I waited forever for warcraft 3 and we all know about that piece of !@#$.


Are you !@#$ing high?

That game was amazing.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]