StarCraft® II

Low fps with powerful computer. HOTS expac.

(Locked)

Had to chime in here too. I would get lots of FPS for WoL, but now, it's 15 FPS for the HUB in Campaign HoTS. Ingame, it's tops 60 at zooming in with no units, 30, with any. Multiplayer is 40 tops.
Just a note before I start on this... If you don't know anything about how Video Cards or How Rendering Models work, don't complain about FPS...

If you read the Patch Notes, they upgraded the Engine... So, yes MINIMUM System Requirements are higher, but that doesn't mean that ULTRA System Requirements stay the same... It's scaled. So ULTRA Prior to v2 requires less processing then ULTRA now. (and it requires A LOT more)

So, for those with your awesome video cards you keep listing.. Read your Video Card Specifications. Just running over some of those I only see 256-bit and 192-bit. Your card isn't all that. (but I paid blah blah dollar signs everywhere). Doesn't matter. I have a computer with an old GTX 210 (384-bit) and it runs SCII better than my Gaming PC (400+FPS). I get 300FPS IF I'm lucky on my 550 Ti Fermi. (Rendering in 1920p). You're Core Clock, Shader Clock, and Gigabytes of Memory mean NOTHING without that bit rate and anything below 384-bit will not run ULTRA Settings for any RTS of this caliber, especially with the Cinematic Engine they designed.

Multiplayer.. Players.... You shouldn't be playing on ULTRA anyways. Gaming online pretty much requires you to play on Medium, due to the fact that rendering in full 1920p monitors is not only stressful enough, you're trying to make it look "prettier" than it needs to be. Pushing graphics to the max causes lag between the Graphics, Processor and (for Online) the Ethernet / WiFi. So, playing on Ultra in Multiplayer is NOT recommended due to unResponsiveness from Controls because Graphics and Physics are getting Priority. Then enabling I/O Priority while on ULTRA causes huge Video Lag cause your APM shot up to 200+. You can't have it all. Pros all play their systems set to Medium). Medium and Ultra have very few differences, if you want certain aspects of the IN-GAME Graphics (like glowy minerals/gas), set everything to Medium and Tweak from there. 99% of the time, setting the Shaders to High will help a lot of the FPS issues.

Single Player, I can RECOMMEND what to set to get ULTRA-like Graphics to smooth out the Gameplay and in-Game Cinema, but I'm sure its more about OCD than what it looks like. I spent about 3 hours playing with the New Engine's Shaders, Lighting and Shadows and have a VERY Good Compromise. The only thing I couldn't get to run Smoothly was Indirect Shadows. I know this is the best part of the Cinematic sequences, but this is why Blizzard had half the Sequences recorded and played via Video Files. Plus, Indirect Shadows don't affect Gameplay (99% sure), because its not used in the Game Engine, but rather the Cinematic Engine.

Drac's Ultra-Like Settings for Cinematic + In-Game Shinyness... of DOOOOOOOOOOM!!!:

Texture Quality : Ultra

Shaders : High
Lighting : High*
Shadows : High*
Terrain : High*
Reflections : On
Effects : High*

Post-Processing : Medium
Physics : Medium
Models : High
Unit Portraits : 3D
Movies : High
Indirect Shadows : Disabled

Anti-Aliasing : OFF

* You can put these to ULTRA and it will only impacts slightly. (550 Ti Fermi goes from 90+FPS to 60+FPS).

Note: Test settings by Starting a conversation with a Character preMission Screen to test FPS rate. The changes don't take affect immediately so starting a sequence helps update everything. You don't need anything over 60 FPS. Remember, don't crank it passed these settings too much, remember you have 600-4000 Units per game to deal with as well.

If you have to have ULTRA, upgrade your Video Card to a 384-bit Card. http://www.newegg.com/Product/Product.aspx?Item=N82E16814130898.

Don't blame Blizzard for raising the bar, some of us welcome a Company will to push Graphics to the Extreme for Cinematic Sequences.
Obviously you know your stuff so I'm not even gonna try to say anything in regards to that but come on man I could play WoL on Ultra no fps issues and now I get 15 fps on medium settings in campaign? Thats lame.
Campaign Mode has different Models. The "Evolved Units" have a higher polygon count to show the evolutionary difference between the units. (Such as Zlings with the Raptor Wings). Then have 2x per Food Count and ZvZ Missions the count and stress get astronomical.

I know how you feel though... Played ULTRA on WoL and Med/High in HotS. Actually, I'm kind of curious what the Default Direct X Level Starcraft II Heart of the Swarm executes in. When I played Far Cry 3 in DX11 I got about 40+. In DX9 I got around 200-300+.
If you have an Nvidia card, go into the Nvidia control panel, 3D settings, set Anti-Aliasing to application controlled and let set it to Off in the game.

I literally doubled my framerate, and at 1920x1080, you won't even notice it's off.

I suspect it's an Nvidia default setting, because I don't remember turning it on. Regardless, kill AA, get lots of FPS.
Yes it is an issue though. I undderstand the increase yet a system designed to run the game well and even having a higher bit rate card I see no performance difference between low or ultra, performance on hots is uniformly bad not just a poor computer the only game i am haveing poor performance with at all by the way so it jsut seems odd that the performance standards changed that much. The other problem is blizzard says they didn't change them hardly at all and that the issue is on our end totaly which can't be the case. Also I know shouldn't be playing Multi with on ultra but have to use low or it won't even work at all tht is not acceptable I payed ofr the games with a promise of certain performance standards that I am well above and yet it does not function on a key component then. i should not have to have a 3000 dollar plus computer to play this game with the quality level it is.
i7 2600K OCd to 4.4Mhz, 8GB RAM, and an EVGA Superclocked GTX 580 CLASSIFIED (3GB VRAM) brings me to ~12 FPS on Extreme.

However, my computer destroys games like Tomb Raider, Dishonored, Black Ops II, etc on maximum settings..
@Tekt

I have pretty much identical hardware, except I'm using a GTX 570. I was at 15fps earlier, and after killing AA I'm at 37fps in the areas between missions. So I'm guessing it'll put me up to around 55fps in mission.
How do I go to the Nvidia panel?
How do I go to the Nvidia panel?
Make sure that you have an Nivida card 1st. Then in your system tray (bottom right corner) you should have an Nvidia icon you can click on that will get you into said application.
Starcraft II runs in DX9 make sure to take the time to update drivers for all devices. Also disconnect anything that isn't in use as resources allocated to other items can effect gaming performance :)

Also you should post your Direct X dialog well so its easier for the techs to see common issues. If you are on a mac and posted into this topic regarding the issue mac tech support forums should be more suited to trouble shoot your problem.
Okay, here is what I am looking at:

Antialiasing-FXAA Off
Antialiasing-Gamma correction On
Antialiasing-Mode Application controlled
Antialiasing-Setting Application controlled
Antialiasing-Transparency Off

Which on of these do I need to change and how do I do it in game?
If you have an Nvidia card, go into the Nvidia control panel, 3D settings, set Anti-Aliasing to application controlled and let set it to Off in the game.

I literally doubled my framerate, and at 1920x1080, you won't even notice it's off.

I suspect it's an Nvidia default setting, because I don't remember turning it on. Regardless, kill AA, get lots of FPS.


+10 for this post.

Once I did this I was able to set my shader to High and everything else was maxed out and running smooth @ 30 FPS. Thanks for the heads up as this was very helpful.
Okay, here is what I am looking at:

Antialiasing-FXAA Off
Antialiasing-Gamma correction On
Antialiasing-Mode Application controlled
Antialiasing-Setting Application controlled
Antialiasing-Transparency Off

Which on of these do I need to change and how do I do it in game?


What I did was...

I clicked on the Global setting, selected the Antialiasing-Mode Application Controlled. It looks like you already have it set that way.

That's all I needed. I was then able to set my Shader at high and everything else was maxed out and running smooth. I have a 660Ti with the beta 314.14 drivers.
Edited by Nobueno on 3/14/2013 11:45 PM PDT

If you have to have ULTRA, upgrade your Video Card to a 384-bit Card. http://www.newegg.com/Product/Product.aspx?Item=N82E16814130898.

dam, that card is out of stock. How do I buy it?

If you have to have ULTRA, upgrade your Video Card to a 384-bit Card. http://www.newegg.com/Product/Product.aspx?Item=N82E16814130898.

dam, that card is out of stock. How do I buy it?

http://www.amazon.com/EVGA-SuperClocked-Signature-Dual-Link-06G-P4-2793-KR/dp/B00BL8BX9C/ref=sr_1_cc_1?s=aps&ie=UTF8&qid=1363330855&sr=1-1-catcorr&keywords=EVGA+06G-P4-2793-KR+GeForce+GTX+TITAN

Only 2 left in stock, hurry up! It's only $1,200! LOL!
03/14/2013 12:09 PMPosted by Nobueno


I tried to look in turning shadows off etc. I guess this is different? I'm not home now but if there is a shadders bar I'll turn that down and see if that helps. (though I should be able to run it without worrying, but I dont really care about stuff like shadding).


Yes, Shadows are 2 slots below Shaders, they are different. I agree with you 100% that you shouldn't have to turn it down, but for some reason it's causing a lot of issues. I spent about an hour yesterday trying to figure out why I was dropping to 10 fps and the shaders were the issue. There isn't a bar per say, it's a box called Shaders right above Lighting that allows you to select low/medium/high/ultra. I had to turn mine to medium and everything else was maxed out without issue running stable at 40 fps.

Just let me know tonight if this helps you like it did for me.


I feel like this helped a lot. I was able to play the campaign no issues even when my army was maxed out. was between 60-30 FPS the entire time and 30 was only when I was maxed out army in combat but I barely noticed. Game ran great. thanks.
If you have an Nvidia card, go into the Nvidia control panel, 3D settings, set Anti-Aliasing to application controlled and let set it to Off in the game.

I literally doubled my framerate, and at 1920x1080, you won't even notice it's off.

I suspect it's an Nvidia default setting, because I don't remember turning it on. Regardless, kill AA, get lots of FPS.


+10 for this post.

Once I did this I was able to set my shader to High and everything else was maxed out and running smooth @ 30 FPS. Thanks for the heads up as this was very helpful.


interesting, I'll try this tonight. thanks!
I missed this thread so its not just me I just created a new thread about this topic as well, but the problem didn't start untill I was at the "Reborn" cinematic in the campaign THEN I experienced terrible FPS drops and it continues even in Liberty cinematics
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]