StarCraft® II

Low fps with powerful computer. HOTS expac.

(Locked)

I hope so. I'm not holding my breath though
same here i am very disappoint with blizzard way of handling this issue, all of us should request refunds until this game is properly fixed.. i cannot believe blizzard has dropped the ball on another release as large as this one.. please fix this blizzard i waited years and years to find out what happens to Sarah kerrigan please fix... :'(
Bump, still waiting for you to acknowledge this issue Blizzard.
Edited by Wamp on 3/22/2013 3:19 AM PDT
even on lowest settings with my GTX 680 and 2700k, it goes below 60fps when there is large amount of units, aka close to max even on 2v2. this never happened on WOL on first stages of the beta, i monitored the GPU and CPU usage, and cpu usage is very very low(uses only 2 cores, 15-30% total of those two)
even on lowest settings with my GTX 680 and 2700k, it goes below 60fps when there is large amount of units, aka close to max even on 2v2. this never happened on WOL on first stages of the beta, i monitored the GPU and CPU usage, and cpu usage is very very low(uses only 2 cores, 15-30% total of those two)


Even though my system specs are not as good as yours, I'm getting the same kind've useage with weird FPS drops. Where I could play on High/Ultra with Vsync on in WoL, I can bearly play on Low with consistant FPS in HotS.
Edited by SuicideKing on 3/22/2013 12:26 PM PDT
we all need to make uprising for this, such bad performance for a game that need all the cpu power...
having the same issues too
on hots same setup I am getting 10-15fps

on liberty I was getting 60-75fps
similar battles
Anyone having problems viewing the cinematics at a LOW fps? It seems I can not even finish viewing the hole thing because the sound is way ahead
Guys, if you have any GPU Virtualization software on your computer that came with your motherboard (Like Virtu MVP), try turning that off.

I used to have terrible, terrible framing even on medium, but the moment I turned off Virtu MVP the game started working like a dream even on ultra! =)

EDIT: This also seems to fix the problem people have with SC2 not starting after hitting Play on the launcher.
Edited by Grimpillmage on 3/23/2013 8:19 AM PDT
English for the less computer savvy please :)
So, bump. Have tried lots of things so far and some work a little but still the performance impact from WOL to now has dropped by well over 60%. I can't even try to play multiplayer because the lag is so bad it is now impossible and single player is really difficult. Low CPU and GPU usuage there is no way I should be getting such bad performace for the quality of this game. Blizzard I was excited with this game was alte to the party and then the patches and HOTS update ruined performace and now I wish I had never bought it and I even told several friends who were thinking of purchasing to at this time at least not waste their money. you need to fix this or it is going to cost you money.

I love your game it is so weird that you guys are just ignoring this issue. So here are my specs as well.

AMD FX 6300
AMd 7850 2gb
16GB RAM
I know processor is not the absolute top best but it is still only at 30% usage tops during a game and I have zero performace problems with anything else I throw at it and only in HOTS or WOl since the 2.04 patch.
Edited by Spectre on 3/23/2013 12:50 PM PDT
Bump. Its not our drivers Blizzard. Stop ignoring the issue.
same issue here. since heart of swarm expansion. :(
Just watched my FPS crawl to 0 again forcing me to restart my computer.
Still being ignored..
Keeping this on the first page. Its not going to go away if you ignore it blizzard.
Can't believe how awesome this game did run prior to 1.5.x, this was a turning point which got even worse with 2.0.x and HOTS. It's so !@#$ing obvious, yet Blizzard simply does not care. They make it run worse with every patch.
I have same problem too. My PC can handle extreme but now in HOTS I get FPS drops even on Low graphics.
come on blizz this game has been out for almost a month no reason to not address this no reason i should i be 100+fps in WoL then when HoTs patch came out i get 40fps and dips to 5-10.

Amd 1090t 3.2ghz
Amd 7970 3gb ram
8gb ram
windows 7 64bit

btw i was getting the 100 fps on my old graphics card which was a 6870.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]