StarCraft® II

Low fps with powerful computer. HOTS expac.

(Locked)

Posts: 8,049
Nvidia users: Have you tried to clean install your graphics drivers (Reinstall your current or the newest set go to advanced and then pick perform a clean installation.) The reason I am asking is that I just went from a core2quad q8300 to an i7 2600 (hand me downs are great) with my 660ti and went from 40-50fps ultra to 120-150 fps ultra.
Posts: 15
Bump again.

6 pages in this thread alone & no blue reply on this issue.. really? This is what you call customer service?
Posts: 66
Tried everything in regards to my card and driver battyone.

I've fought through laggy FPS the singleplayer campaign to beat it, but I cannot express how much more enjoyable it would be if I could play it like my computer wasn't in the stone age....which it isn't
Posts: 8,049
Tried everything in regards to my card and driver battyone.

I've fought through laggy FPS the singleplayer campaign to beat it, but I cannot express how much more enjoyable it would be if I could play it like my computer wasn't in the stone age....which it isn't


It's just so weird I went from 20-30 FPS ultra with my Core2 Quad q8300 to 120+FPS with my i7 and the latest nvidia drivers on a 660ti (EVGA) I figured it was worth a shot to reset everything to default via a clean install since I just reformatted my box and installed everything fresh last night.
Edited by Battyone on 3/27/2013 7:02 AM PDT
Posts: 22
Blizzard this is really becoming a joke, i suspect not only IF and WHEN you eventually comment on this issue that at the same time you explain to us WHY no reply have been given sooner 6+ threads later..whoever your employing to monitor these threads for such issues really could do with a swift kick up the A** n learn how to do there job efficiently !
Posts: 1,341
Nvidia users: Have you tried to clean install your graphics drivers (Reinstall your current or the newest set go to advanced and then pick perform a clean installation.) The reason I am asking is that I just went from a core2quad q8300 to an i7 2600 (hand me downs are great) with my 660ti and went from 40-50fps ultra to 120-150 fps ultra.


I did this, it boosted my FPS that's for sure.

Apperantly there was a new driver that came out 2 days ago, I don't know if that has anything to do with it or if it was the clean install, but FPS did improve more for me :3

I feel like it's on Blizzards side now to optimize. I'm content with Medium settings at 60 fps, but I'd love to play on higher settings like I should be able to at least.
Posts: 6
I tried a clean reinstall of the drivers. My fps improved from 2-4 to around 15.. Still, very unplayable. Sigh... Thanks for the advice though, it was worth a try.
Posts: 220
lol how many pages do we need to get some kind of response on the issue at hand.
Posts: 22
the guy whos job this is must be either dead or on holiday ... id only accept one of those as an excuse for this delay though
Posts: 10
*clears throat, taps watch* Sometime this year would be nice Blizzard
Posts: 816
+1
Posts: 2
Bump . 2102 quad core i7 imac slows down to 2FPS in midlate game multiplayer. It's totally unplayable. All fixes were tried.
Posts: 6
Has anyone found a solution yet? Or are we all sitting here NOT playing - waiting for Blizzard to at least acknowledge the problem?
My game is completely unplayable with the current fps drop.
Posts: 66
Every now and then someone will say they have done something that works. But every fix I have tried on this 6 page thread hasn't done squat for me.

I fought through the low FPS to beat the game because I love the story. More of a chore than an enjoyment though and I have shelved the game until Blizzard does something about this. knowing blizzard, I might as well trade the game in now.
Edited by Cason on 3/28/2013 7:47 PM PDT
Posts: 22
i have tried playing it numerous time but seems to just be dropping more n more, few days ago it was 15-19FPS and now last night it dropped to 9-12FPS totally unplayable and whats more i just got message saying my status is locked and not allowing me to join match-ups r custom games, basically its one thing after the other , and a Fu*%ing joke that NOTHING IS BEING DONE, totally SH*T company all in all
Posts: 22
just wondering but can anyone change the title of this thread to something more ALARMING, maybe that will get there attention, even though Stevey Wonder wouldnt miss 6 threads regardless of the title we all know Blizzard have to be spoon fed every now n then ...
Posts: 66
Don't think changing the thread title will do any good. Blizzard just has to decide if it cares about their customers at this point. I'm sure they have seen this, but either they are too embarrassed to admit something is wrong on THEIR END, or they just don't care.
Posts: 13
Same problem here.

Specs:
HIS Radeon HD 7770 Dual CrossFireX
I5 3570k 3.4 ghz
8GB ram

Getting 20-40 fps decrease compared to wol.
Posts: 66
Bump. The problem is not going to go away if you ignore it blizzard.
Posts: 34
they banned me for 7 days trying to inform people of this issue...

my specs are i5 3570k 4.3 ghz
gtx 670 oc
corsair veng 8gb

my computer should rip sc2 hots a new $#@hole on ultra but lags at 20 fps..

BLIZZARD IS IGNORING US
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]