Battle.net keeps on d/c

Posts: 9
For some reason, my game keeps on disconnecting and re-connecting to battle.net when I'm playing SP. It is getting annoying. Is there a solution?
Reply Quote
Support Forum Agent
Posts: 14,784
Are you disconnecting like you get booted to the login screen or what misc errors you see?

In most cases when this happens, optimizing your connection can help.
Reply Quote
Posts: 9
No, I don't get booted to the login screen or anything, I can just keep on playing and it tells me achievements are disabled then suddenly Battle.net will re-connect and disconnect again. It happens like every 5 minutes during gameplay, sometimes even in the login screen, or even in more shorter intervals.
Reply Quote
Posts: 199
Hey I can attest to what razorwing is saying. I'll start a game and I keep getting disconnected within a few minutes of starting. I keep disconnecting and re-connecting constantly and I eventually drop. This has only happened since I upgraded to hots. need help, can't play!!
Reply Quote
Posts: 9
So it's been like 3 days, I've reset my router, still happening. Any help would be nice because I'm not getting the achievements that I should be getting which is a pain.
Reply Quote
Support Forum Agent
Posts: 14,784
Are you able to do a trace when these issues happen?

Also, do you see any notifications about "resource stalls"?
Reply Quote
Posts: 9
How exactly do you want me to do it? Do you want me to play the game till I get the disconnect then trace? and no, nothing on 'resource stalls'. Battle.net just disconnects, and reconnects randomly and it tells me achievements are disabled at this time.
Reply Quote
Posts: 7
i have the same exact problem as mention by above . i m running on MAC Osx . Every 5-10 minutes my game will attempt to reconnect when disconnected . I cannot play any arcade game now because this will make other people angry for lagging or what so ever . Any solution ?
Reply Quote
Posts: 9
So I went and played some multiplayer. It says I'm d/c from Battle net but I'm actually not. It's so weird. I was playing NOD and it'd still give me the achievement disabled problem, but I never get disconnected from the actual game.
Reply Quote
Posts: 9
So this is still happening.. any updates?
Reply Quote
Posts: 9
this has started to happen to me about an hour ago. Before it was fine (even while updated to HoTS). I can browse the internet just fine, and i have TW cable.
Edited by rupee on 4/11/2013 1:13 AM PDT
Reply Quote
Posts: 1
I am experiencing the exact same problem as you are Razorwing. I'm not sure what's going on but it's extremely frustrating. I'm not sure if it's my internet connection or not because I don't experience any problems with browsing the web. Every 45 seconds-2 minutes I get a "Reconnecting to Server" message. My game suddenly stops when this happens and will continue to run slow after the connection is restored. Playing the game has become excessively frustrating because I am trying to unlock achievements as well but I cannot because the connection keeps dropping. If anyone at all has a potential solution to this problem, it would be much appreciated.
Reply Quote
Posts: 23
Yup I am also experiencing the same issue - did a google search and ended up here on this thread - what's going on??!! Never had an issue until lately - nothings changed at my end.
Reply Quote
Posts: 1
Blizzard please find a resolution to this issue there are a few of us loyal gamers who have purchased your products out of trust and respect for the company. Shame on you for giving us a product with fault and not responding to our request. I still love ya for making sc2
Edited by DoctorLuxatR on 5/18/2013 6:24 AM PDT
Reply Quote
Posts: 1
having the same problem here.... wth is going on with battlenet
Reply Quote
Posts: 1
The same problem just happened with me. My boyfriend and I have been playing SCII Wings version co-op vs ai games for a couple weeks now with no problem. But all of the sudden, it kicked me off of battle net and kept saying that the server wasn't connected. We tried logging out, logging back in and re-trying the game but it kept happening. This has never happened until today. I'm using 10.6.8 on Mac, which I know I get the "you need to upgrade" every time I log-in, but I'm not sure how that would be kicking me off of battle net? Any help is appreciated.
Reply Quote
Posts: 23
Any updates?? The sound of silence is deafening :( I've tried optimizing my internet, released and renewed the ip address and flush the dns...any other ideas to try out? It would be greatly appreciated!
Reply Quote
Posts: 12
Just returned to StarCraft after about 18 months and this has been happening for the last two days. It's really quite frustrating especially as I'm having to learn builds, tactics etc. again and these constant notifications are distracting. Is there any solution (I have closed all other programs and have tried on the North American servers and the South East Asia servers, it happens in single player and multiplayer).
Edited by PrivateJoker on 7/3/2013 12:04 AM PDT
Reply Quote
Posts: 1
Having the same problem for the last few days, get disconnected when playing any multiplayer game whats the solution?
Reply Quote
Posts: 2
I have also been having theese problems quite alot for the last couple of days. I guess pretty much since the last patch. please find a fix for this since it's extremely annoying
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]