StarCraft® II

Can't disable OS keyboard shotcuts

In options menu -> controls, there is a checkbox to disable OS keyboard shotcuts, but it doesn't work at all after checking it.

Pressing F10 key is still mute, but not menu.
Reply Quote
Your problem isn't actually within SC2. The checkbox to disable OS keyboard shortcuts has nothing to do with the function keys, its to do with keyboard combinations like Command+M which toggles SC2 in/out of fullscreen mode. You can disable this if you don't want to accidentally trigger one of those commands while playing.

As you have it at the moment, the function keys are performing their functions and not registering as f(number) keys, you can temporarily switch them to f(number) keys by holding down "fn". To invert this setting, and have them default to f(number) and use the "fn" key to access mute, volume change etc. go into System Preferences -> Keyboard and check the box that says "Use all F1. F2, etc. keys as standard function keys."

Problem solved.
Reply Quote
03/16/2013 07:15 PMPosted by SicutDominus
The checkbox to disable OS keyboard shortcuts has nothing to do with the function keys, its to do with keyboard combinations like Command+M which toggles SC2 in/out of fullscreen mode.

Sorry, but this is wrong. It has everything to do with function keys—if you have F10 set to toggle Mission Control or Dashboard or something. But he's right about the rest: you're not using your F10 as F10, but as the little icon on the same key.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]