Can't change to Surround Sound Setting

Posts: 3
When I go to the sound options menu in the settings, there is a drop down menu on the right column, under Speaker Setup. It is set to Stereo, and faded out. When I put my cursor over it, it says:

Speaker Setup:
Windows only permits changing the speaker setup using the Sound Control Panel. This is the setup currently selected by the Control Panel."

I use Astro headphones with the Mixamp 5.8. I have it plugged to the optical jack at the back of the motherboard.

Thanks in advance. :D
Reply Quote
Posts: 53
I am getting same problem I have tactic 3d sigmas and could run 7.1 no problem and no its grayed out and says the same thing.
Reply Quote
Posts: 1,386
Yep, that's the problem I have come here to ask about.

They patched the option out as a 'workaround' for some other problem.

I want it back because I had mine set to Dolby Prologic (and there is NO way of doing this in the Windows Control Panel!)
Reply Quote
Posts: 10
+1 Have an Astro a50 and Cannot get it to do surround sound for SC2
Reply Quote
- Technical Support
Posts: 8,488
I had a similar problem and just made the changes under "Sound" in my control panel (Windows7).

I selected the default device, clicked configure, and (for me) set it from Stereo to 5.1 surround.

Back in game, it changed from Stereo to 5.1.

That didnt work for you guys?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]