StarCraft® II

'Waiting for Server' 'Surrender'

Posts: 2
I'm encountering the same problem as everyone else, but I found that alt-tabbing out of sc2 and then back in actually causes the match to reconnect and resume. Any idea why this is?
Reply Quote
Posts: 432
Hello,

I am having a similar issue, but the circumstances of my disconnects seem very different then the other posters in this thread. I noticed that Blizz would like my trace route to the Blizzard servers, but I do not know how to do that. I will post my issue details (etc), when I get back home.

Can someone please advise?

Thanks
Reply Quote
Posts: 1
same for me...
Reply Quote
Posts: 432
Hey all,

So, this seems like a network issue of sorts we'd like to narrow down. I saw that another user mentioned that VPN fixes the issue, but only temporarily. This may mean something along the path from the the regular network is bad. Does this happen when you play in another region?

Can you provide the following?

    1. Your Internet Service Provider
    2. Your City/State
    3. Type of Internet (cable, DSL, etc)
    4. A [url="https://us.battle.net/support/article/496?utm_source=internal-support_forums&utm_medium=posting&utm_campaign=BlizzardCS&utm_content=050613"]traceroute[/url] to the StarCraft II server you are playing on.
    5. What region you are playing in for SC2.


1. Comcast
2. Toms River/NJ
3. Cable

4. (12.129.202.154)

1 10.0.1.1 (10.0.1.1) 0.358 ms 0.279 ms 0.263 ms
2 24.0.32.1 (24.0.32.1) 35.741 ms 20.358 ms 13.660 ms
3 te-9-2-ur01.xxxxxxx.xx.panjde.comcast.net (68.85.77.5) 10.469 ms 9.485 ms 9.264 ms
4 xe-6-1-2-0-ar03.xxxxxxx.xx.panjde.comcast.net (68.85.35.193) 11.142 ms 12.341 ms 11.229 ms
5 ae-2-0-ar03.xxxxxxx.xx.panjde.comcast.net (68.85.62.225) 12.788 ms
so-14-1-0-0-ar03.xxxxxxx.xx.panjde.comcast.net (68.85.62.245) 16.130 ms
ae-2-0-ar03.xxxxxxx.xx.panjde.comcast.net (68.85.62.225) 23.910 ms
6 pos-3-10-0-0-cr01.xxxxxxx.xx.ibone.comcast.net (68.86.92.217) 18.928 ms 21.097 ms
pos-3-8-0-0-cr01.xxxxxxx.xx.ibone.comcast.net (68.86.95.177) 20.686 ms
7 pos-0-0-0-0-pe01.111eighthave.ny.ibone.comcast.net (68.86.87.122) 17.776 ms 16.981 ms 17.313 ms
8 192.205.37.33 (192.205.37.33) 17.003 ms
192.205.37.41 (192.205.37.41) 19.927 ms
192.205.37.33 (192.205.37.33) 18.798 ms
9 cr2.wswdc.ip.att.net (12.122.134.186) 87.037 ms
cr1.n54ny.ip.att.net (12.122.131.86) 87.368 ms
cr2.wswdc.ip.att.net (12.122.134.186) 88.113 ms
10 cr1.cgcil.ip.att.net (12.122.18.21) 84.829 ms
cr2.cgcil.ip.att.net (12.122.1.2) 86.480 ms 89.447 ms
11 cr1.cgcil.ip.att.net (12.122.2.53) 86.813 ms 86.747 ms 84.482 ms
12 cr1.slkut.ip.att.net (12.122.30.25) 88.489 ms
cr2.dvmco.ip.att.net (12.122.31.85) 84.815 ms 85.364 ms
13 cr1.slkut.ip.att.net (12.122.30.25) 84.695 ms 83.789 ms
cr2.la2ca.ip.att.net (12.122.30.30) 87.483 ms
14 gar29.la2ca.ip.att.net (12.122.129.241) 85.121 ms 93.842 ms
cr2.la2ca.ip.att.net (12.122.30.30) 87.031 ms
15 gar29.la2ca.ip.att.net (12.122.129.241) 85.123 ms 83.707 ms
12-122-254-238.attens.net (12.122.254.238) 85.748 ms
16 206.16.68.46 (206.16.68.46) 84.199 ms
mdf001c7613r0002.lax1.attens.net (206.16.68.54) 86.215 ms
12.122.251.190 (12.122.251.190) 86.002 ms
17 mdf001c7613r0003-gig-12-1.lax1.attens.net (12.129.193.254) 100.938 ms
mdf001c7613r0002.lax1.attens.net (206.16.68.54) 85.943 ms
206.16.68.46 (206.16.68.46) 83.976 ms
18 * * *
19 * * *
20 * *

••••••

4. (63.240.104.93)

1 10.0.1.1 (10.0.1.1) 0.382 ms 0.374 ms 0.262 ms
2 24.0.32.1 (24.0.32.1) 52.824 ms 21.250 ms 22.384 ms
3 te-9-2-ur01.xxxxxxxxx.xx.panjde.comcast.net (68.85.77.5) 8.662 ms 10.853 ms 9.324 ms
4 xe-6-1-3-0-ar03.xxxxxxxxx.xx.panjde.comcast.net (68.85.35.197) 9.981 ms 11.165 ms 11.936 ms
5 so-14-1-0-0-ar03.xxxxxxxxx.xx.panjde.comcast.net (68.85.62.245) 16.422 ms
ae-2-0-ar03.xxxxxxxxx.xx.panjde.comcast.net (68.85.62.225) 12.762 ms
so-14-1-0-0-ar03.xxxxxxxxx.xx.panjde.comcast.net (68.85.62.245) 16.590 ms
6 pos-3-5-0-0-cr01.ashburn.va.ibone.comcast.net (68.86.94.97) 17.220 ms
pos-1-2-0-0-cr01.newyork.ny.ibone.comcast.net (68.86.91.237) 19.288 ms
pos-3-5-0-0-cr01.ashburn.va.ibone.comcast.net (68.86.94.97) 21.249 ms
7 pos-1-0-0-0-pe01.111eighthave.ny.ibone.comcast.net (68.86.86.42) 16.702 ms
pos-0-3-0-0-pe01.ashburn.va.ibone.comcast.net (68.86.86.142) 17.215 ms
pos-1-0-0-0-pe01.111eighthave.ny.ibone.comcast.net (68.86.86.42) 17.837 ms
8 192.205.37.33 (192.205.37.33) 21.529 ms 23.967 ms 18.287 ms
9 cr1.wswdc.ip.att.net (12.122.113.42) 24.100 ms 23.733 ms
cr1.n54ny.ip.att.net (12.122.131.86) 26.285 ms
10 cr1.phlpa.ip.att.net (12.122.5.242) 26.880 ms 24.778 ms
cr2.phlpa.ip.att.net (12.122.4.53) 24.737 ms
11 12.122.107.13 (12.122.107.13) 21.455 ms 21.228 ms
gar1.pitpa.ip.att.net (12.122.107.85) 88.687 ms
12 12-122-254-242.attens.net (12.122.254.242) 28.596 ms
12.122.251.2 (12.122.251.2) 25.227 ms
12-122-254-242.attens.net (12.122.254.242) 28.205 ms
13 mdf001c7613r0004-gig-12-1.nyc3.attens.net (63.240.65.14) 26.434 ms
mdf001c7613r0003-gig-10-1.nyc3.attens.net (63.240.65.10) 35.813 ms
mdf001c7613r0004-gig-12-1.nyc3.attens.net (63.240.65.14) 25.537 ms
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 *

5. American Servers

I normally play against AI opponents only. My drop outs occur at the very end of the matches, just after the final AI surrenders and before I get to the score screen. Basically I get to the screen that says "Victory" with the options to view the score. The game drops out immediatley and I have a surrender option. After waiting to see if I can get back in, the game eventually brings me to the "Defeated" screen saying I lost the match. This happens quite often, in about 50% of my games.
Reply Quote
Posts: 3
????????
Reply Quote
Posts: 20
I'm getting really impatient. I'm thankful that I can at least play offline, but this issue bothers be beyond belief. I'm going to sweden soon, maybe i can play there...
Reply Quote
Posts: 432
I take it that there are no updates on this?
Edited by Kraxe on 6/2/2013 6:02 PM PDT
Reply Quote
Posts: 1
Pretty funny this all started with HotS, oh well... Maybe I should just wait half a year then hope some major patch has it fixed, clearly unplayable now.
Reply Quote
Support Forum Agent
Posts: 14,784
We're still taking a look at this, and I've repinged several teams about this to get tractions on this. I apologize about the delay in this and I know it is a bit frustrating.

We still are a bit puzzled that on VPN it works somewhat but not regular connections. I'll keep poking until we get more info. Last time this was reported awhile back, it turned out to be a firewall issue, but that does not seem to be the case now.
Reply Quote
Posts: 5
That was a poor cheat by the a.i. ... 96minutes in a 7v1 FFA against 7 a.i. (very easy) without a pause or glitch, then after the last a.i. surrendered, on the Victory page, I got the "waiting for server", "you have been dropped", "Defeat!".

(Then when I try to log in to this forum, my account has been locked for suspicious activity.?!?!?!?!?!)

DSL connection -- this was "custom game" because "training" and "match" have Never worked

Los Angeles
Reply Quote
Posts: 5
The campaign in Heart of the Swarm was fun and when I finished it, I was able to play as Zerg better than I ever had before. Collecting achievements seemed like a good way to keep improving my play. The disconnect bug steals achievements and is pretty much the opposite of fun.

I'm glad this forum is here. I can watch for this bug to be fixed. Until then, there's not much point in trying to play the game. (Fixes and workarounds do happen, the disappearing cursor was solved, for instance.)

ps - the weekend's 25% bonus in points was pretty cool, thanks!
Reply Quote
Posts: 432
We're still taking a look at this, and I've repinged several teams about this to get tractions on this. I apologize about the delay in this and I know it is a bit frustrating.

We still are a bit puzzled that on VPN it works somewhat but not regular connections. I'll keep poking until we get more info. Last time this was reported awhile back, it turned out to be a firewall issue, but that does not seem to be the case now.


Thanks for the update. TBH I am a little gun shy (no pun intended) of starting new games as it is pretty frustrating for it to come up as a loss. I suppose I should keep trying at it to see if it keeps repeating?
Reply Quote
Posts: 20
So I came to sweden and tried to play some starcraft last night. The first 10~ games worked perfectly. Now I try to play this morning and after about another 5 games, I have been dropped from two games. Clearly the issue is subjected to my computer.
I operate a MacBook Pro from november 2011, I run 10.7.5.
Reply Quote
Posts: 20
To add to what i said before
It is working in sweden without issues. I was just too far away from the router. So, back to the issue. It is not my computer, it could be my router in China or my subscriber. Sadly, I'll have to wait till i get back to provide more information.
Reply Quote
Posts: 1
I'm having the same issue. This seems really unfair to me, please fix the problem,
Reply Quote
Posts: 10
this just started happening to me the other day. on my mac and my pc. is this still an issue or is it just me? i just wanna play starcraft.
Reply Quote
Posts: 8
Its always at the end of a game for me. You win a really tough game, and it says, "waiting for server". I think it's a hack. It happens every time it's a one on 4 at the end of a game.
Reply Quote
Posts: 2
I am having the exact same issue... Sometimes it happens before the game loads, sometimes it happens right at the beginning of the game and sometimes it happens somewhere around 4-5 mins if lucky... Ever since this latest patch I've had nothing but issues. I am hoping for the problem to be resolved soon please.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]