StarCraft® II

Will not load Matchmaking

HOTS will not load the matchmaking menus. I can load the training missions, but the "vs AI", "unranked" and "ranked" menus will not load. I click on them, and then I get the spinning progress wheel. Forever.

I played the entire campaign, no problem, and I played matchmaking during the beta (except for when the beta didn't work on macs).

Help? I didn't see this issue in any other posts.

Running SC2 on OSX 10.7.5, on an older Mac Pro. 2 x 2.66 Dual-Core Xeon, 10GB ram, ATI Radeon X1900 XT.
Reply Quote
I'm having nearly the same problem on an OSX 10.8.3. Only campaign works, NOTHING else will, just stuck on the infinite circling loading icon.

I've tried reseting router. Doing what I could to refresh DNS through terminal, and reinstalling, as well as attempting to play on a different computer user.

Kind of disappointed actually, I've never purchased a Blizzard game that simply DOES NOT work.
Edited by Spinecloud on 3/28/2013 2:30 PM PDT
Reply Quote
**This problem is either on Blizzards player account setting or from the downloader client because I have now tried MATCHMAKING on another computer and the SAME problem persists.
Edited by Spinecloud on 3/28/2013 6:57 PM PDT
Reply Quote
And I'll add that it now takes a very long time to exit the program. Like 1-2 minutes of a black screen to quit the program.
Reply Quote
Yep I'm well aware of that part too. All in all, it feels like this game is like a lemon car at the moment. Pretty surprised.
Reply Quote
Same problem for me
Reply Quote
HOTS has a pile of enormous problems right now that aren't allowing players to access like 80% of the game evidently. And no one can fix it, so until we get a new patch or hotfix, we simply can't play the game we paid for, unfortunately.
Reply Quote
Amazingly, after trying every possible solution, a google DNS workaround thing actually worked, and was pretty easy to set up. Just....."google"...how to use GOOGLE DNS and it may work for you. Silly that this is necessary but I'm happy to be at least playing.
Reply Quote
worked for me thankx spinecloud
Reply Quote
Holy crap. I was about to try all this google DNS stuff when I realized that I had both my ethernet and wifi connected. I turned off wifi, and blamo! matchmaking. Still seems dumb to me, but, if this helps anybody out there, god bless, and glhf.
Reply Quote
-
Edited by Spinecloud on 3/30/2013 6:28 PM PDT
Reply Quote
Yeah I ended up having problems too. So I did the google dns thing, and that worked. But it only worked with IPv4, not IPv6. And I did a bunch of other things, like clearing out all the caches and what not. I followed this guy's lead:
http://us.battle.net/sc2/en/forum/topic/8414741864
Reply Quote
Big thanks to Spinecloud for the DNS suggestion - it worked for me as well. This was so hard to track down - glad I found this thread.
Reply Quote
I'm glad this is helping.
Edited by Spinecloud on 3/30/2013 6:27 PM PDT
Reply Quote
Google DNS worked for me. Thanks for the tip!!!
Reply Quote
Came here to say that I am still having this issue after 3 days of troubleshooting.

I was playing WoL with friends for the past 2 weeks and decided to upgrade after having such a good time playing sc2 again. Needless to say, I have regretted spending $40 to break my sc2 client.

Current issues:

  • profile picture and account information not appearing. Only the blue loading circle
  • all matchmaking menus do not appear. Blue loading circle only
  • after waiting long enough, i get the "clientside dns cache" error message
  • after deleting the blizzard caches in the "shared" folder, sc2 tells me i have i cannot connect to bnet at the login screen. (this issue has repeated itself exactly on 3 separate occasions, and eventually resolves itself until i go and delete this folder again)


Solutions already attempted:

  • deleting Blizzard cache folders
  • flushing my DNS cache
  • upgrading my operating system from Snow Leopard to Mountain Lion
  • switching to google dns
  • deleting all of my replays


I'm running the game on a Macbook Pro from 2010 from SEA (Bangkok). I experience these problems on every server.

I would really like some official word on this. I would rather not have to re-install everything because others have reported that this has no effect.

I wasted my whole 3 day weekend trying to sort this out. On top of that, I'm very angry that I spent money to make this happen. Such a treat.
Reply Quote
Forgot to add, I have turned of all of my network filters and firewalls

Also, uninstalled sc2 and re-installed with the client from battle.net. Same exact problems. This is really irritating.
Reply Quote
I have the same problem. Tried flushing DNS cache, deleting sc2 cache, switching off everything at the plug so my modem resets, checking if firewall is blocking anything which it isn't and now I am going to uninstall my anti-virus. This problem seemed to start after Windows updates so maybe that blocked something.
Reply Quote
I am also having this problem. I haven't been playing on this computer for a while so I just went though the update process. The game works fine on my other computers, including Windows on the same machine. Unfortunately for the OS X partition it on this machine the loading circle just seems to hang forever and I am never presented with the menu.

My internet seems to be working fine, domain names are resolving, and both WoW and D3 seems to work without any issues. Please help so I can get to playing some matches.
Reply Quote
Support Forum Agent
Hi Zena, here's the steps for flushing the DNS. Please try that out and update the thread if you continue to experience the issue. Thank you!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]