StarCraft® II

Will not load Matchmaking

Araxom, I'm getting a Page Not Found error with that link.
Reply Quote
Support Forum Agent
Here's how to flush the DNS cache, zenasprime.

________________________________________________
Rate me! https://www.surveymonkey.com/s/Velnrak
Reply Quote
This did not solve the problem for me. My matchmaking for both ranked and unranked still hangs with the spinning circle. >:(
Reply Quote
hi i am having this same issue; I Am not that tech savvy and don't wish to dive into command prompts are there any other solutions? I think blizzard should fix the issue , will there be a patch? i love star craft and blizzard and just want to play the game i have now spent nearly 70 dollars on.
Reply Quote
Araxom please help?
Reply Quote
do u understand why this issue is occuring
Reply Quote
Came here to say that I am still having this issue after 3 days of troubleshooting.

I was playing WoL with friends for the past 2 weeks and decided to upgrade after having such a good time playing sc2 again. Needless to say, I have regretted spending $40 to break my sc2 client.

Current issues:

  • profile picture and account information not appearing. Only the blue loading circle
  • all matchmaking menus do not appear. Blue loading circle only
  • after waiting long enough, i get the "clientside dns cache" error message
  • after deleting the blizzard caches in the "shared" folder, sc2 tells me i have i cannot connect to bnet at the login screen. (this issue has repeated itself exactly on 3 separate occasions, and eventually resolves itself until i go and delete this folder again)


Solutions already attempted:

  • deleting Blizzard cache folders
  • flushing my DNS cache
  • upgrading my operating system from Snow Leopard to Mountain Lion
  • switching to google dns
  • deleting all of my replays


I'm running the game on a Macbook Pro from 2010 from SEA (Bangkok). I experience these problems on every server.

I would really like some official word on this. I would rather not have to re-install everything because others have reported that this has no effect.

I wasted my whole 3 day weekend trying to sort this out. On top of that, I'm very angry that I spent money to make this happen. Such a treat.


I have this Exact! problem! Simple question...do you have a content filter on your computer? Like something that filters web pages based on content? Like parental controls? I am trying to see if my content filter is giving me problems.
Reply Quote
I just wanted to mention google DNS fixed everything for me, and everything is working great now.
Reply Quote
thanks, flush DNS works, now i can finally load my custom games and arcade!
Reply Quote
worst patch ever guys
Reply Quote
MVP - Technical Support
*deleted*
Edited by KillerofGods on 7/19/2014 4:28 PM PDT
Reply Quote
I also have the spinning wheel of doom. And it is a year after these were posted. I am running off my client and for some odd reason blizzard has still yet to fix their issues with it. I have been a loyal customer to blizzard having everything dating back to the ORIGINAL warcraft. But this failure is a bit much as I put in the time and effort to actually upgrade my entire system to be able to run it. needless to say I did need a gaming computer but besides that. making a game that cannot even run on a computer is mildly insane.
Reply Quote
08/01/2013 01:21 PMPosted by Araxom
Hi Zena, here's the steps for [url="https://us.battle.net/support/en/article/ip-release-renew-and-flush-dns-mac"]flushing the DNS[/url]. Please try that out and update the thread if you continue to experience the issue. Thank you!


I am experiencing this issue too. I just downloaded it today, and when I try to go to anything it just has a spinning circle.
I followed your dns flush thing, didn't work, also tried switching to google dns, and it didn't work. I've reset my routers, modems, computer, and it still doesn't work. Any help??
Reply Quote
Same problem here for last 4 days after a 4 day reinstall attempt :(. cleared the shared/flushed DNS reset Network/ reinstalled Bnet app too and still can't do anything but play campaign(no achievements at all) and even then i occasionally get blocked loading/starting campaigns with "download in progress" in game. when i exit the campaign area and launch again a little bit later (anywhere from 10-60 seconds later) it will let me load again but keeps happening. also have no profile info or anything that is NOT campaign. really annoying to come back to try and earn some more achieves to find the entire game is basically broken.

Edit: i hope that blues do exist on this side too? apparently this is an old problem that is back again or blizzard never fixed it on their end like they needed to?

Edit2: DL'ed a Bnet app update today and apparently that fixed it. able to see my old stats achieves and unlocks and all again!
Edited by SnowShadow on 8/8/2014 9:41 AM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]