StarCraft® II

Installed but Required Files Missing?

Posts: 61
Ok so I finally got the game installed after hours of downloading, but now I've come to another issue. The game won't even start up. The launcher isn't downloading anything new and just says Play. So I click Play and I just get an error message saying that there are required files missing. How does this happen after I just downloaded the entire thing? This is the error report I get. Shouldn't the game automatically download the missing files? How can I fix this? I also ran the installer again to make sure there weren't any files that I might be missing but it just said Play as well.

Process: SC2 [4271]
Path: /Applications/StarCraft II/*/SC2.app/Contents/MacOS/SC2
Identifier: com.blizzard.starcraft2
Version: 2.0.7 [25293] (25293)
Code Type: X86 (Native)
Parent Process: launchd [130]
User ID: 501

Date/Time: 2013-04-09 20:17:56.303 +0430
OS Version: Mac OS X 10.8.3 (12D78)
Report Version: 10

Interval Since Last Report: 187609 sec
Crashes Since Last Report: 10
Per-App Interval Since Last Report: 472 sec
Per-App Crashes Since Last Report: 3
Anonymous UUID: 50228563-048E-9FFB-C909-DAB99092E57A

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/../../../../../Support/Cg/3.0/Cg
Referenced from: /Applications/StarCraft II/*/SC2.app/Contents/MacOS/SC2
Reason: image not found

Binary Images:
0x1000 - 0x22ffffb +com.blizzard.starcraft2 (2.0.7 [25293] - 25293) <AB036567-90E4-32DD-B6A0-C2FB77B3F133> /Applications/StarCraft II/*/SC2.app/Contents/MacOS/SC2
0x8fee1000 - 0x8ff13e57 dyld (210.2.3) <23DBDBB1-1D21-342C-AC2A-0E55F27E6A1F> /usr/lib/dyld
0x904c8000 - 0x904c8fff com.apple.Carbon (154 - 155) <C0A26E7B-28F1-3C7E-879E-A3CF3ED5111C> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
0x90914000 - 0x90bd4ff3 com.apple.security (7.0 - 55179.11) <165A3105-9ADF-329B-93FC-3C8EFAEDDD13> /System/Library/Frameworks/Security.framework/Versions/A/Security
0x929c7000 - 0x92a2fff7 com.apple.framework.IOKit (2.0.1 - 755.22.5) <F9A70D23-1108-3616-9DE3-6C5730CA7AB2> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x93d61000 - 0x93d61fff com.apple.Cocoa (6.7 - 19) <01AA482A-677A-31CA-9EC9-05C57FDDE427> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
0x95f4a000 - 0x95f58fff com.apple.opengl (1.8.7 - 1.8.7) <0631EC1D-833B-39D2-A907-A9F7617E5504> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL

Model: MacBookPro10,1, BootROM MBP101.00EE.B02, 4 processors, Intel Core i7, 2.7 GHz, 16 GB, SMC 2.3f35
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In, 512 MB
Graphics: NVIDIA GeForce GT 650M, NVIDIA GeForce GT 650M, PCIe, 1024 MB
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D5434314753364D465238432D50422020
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D5434314753364D465238432D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xEF), Broadcom BCM43xx 1.0 (5.106.98.100.16)
Bluetooth: Version 4.1.3f3 11349, 2 service, 18 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SD512E, 500.28 GB
USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1a100000 / 2
USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8510, 0x1a110000 / 3
USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1d100000 / 2
USB Device: hub_device, 0x0424 (SMSC), 0x2512, 0x1d180000 / 3
USB Device: BRCM20702 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x1d181000 / 5
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8286, 0x1d181300 / 6
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0262, 0x1d182000 / 4
Edited by LoneSoldier on 4/9/2013 9:09 AM PDT
Reply Quote
Support Forum Agent
Posts: 14,784
I think you resolved this already in a different thread. Is this issue still happening?
Reply Quote
Posts: 19
Having the same issue and i cant find a solution...

Process: SC2 [334]
Path: /Applications/StarCraft II/*/SC2.app/Contents/MacOS/SC2
Identifier: com.blizzard.starcraft2
Version: 2.0.11 [26825] (26825)
Code Type: X86 (Native)
Parent Process: launchd [154]
User ID: 501

Date/Time: 2013-10-06 16:39:30.024 -0400
OS Version: Mac OS X 10.8.5 (12F45)
Report Version: 10

Interval Since Last Report: 18379 sec
Crashes Since Last Report: 2
Per-App Crashes Since Last Report: 1
Anonymous UUID: 80DF9397-D2CA-3FDC-1A7B-A58AB3E8DC0F

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/../../../../../Support/libicudata.44.0.dylib
Referenced from: /Applications/StarCraft II/*/SC2.app/Contents/MacOS/SC2
Reason: image not found

Binary Images:
0x1000 - 0x2417fef +com.blizzard.starcraft2 (2.0.11 [26825] - 26825) <B9BF2B35-8A7C-39C2-AC80-CAB8DCCA6C87> /Applications/StarCraft II/*/SC2.app/Contents/MacOS/SC2
0x659b000 - 0x6abbfe7 +Cg (0) /Applications/StarCraft II/*/Cg
0x8fef4000 - 0x8ff26e57 dyld (210.2.3) <23DBDBB1-1D21-342C-AC2A-0E55F27E6A1F> /usr/lib/dyld
0x9000f000 - 0x9000ffff com.apple.Cocoa (6.7 - 19) <01AA482A-677A-31CA-9EC9-05C57FDDE427> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
0x9217c000 - 0x921e4ff7 com.apple.framework.IOKit (2.0.1 - 755.42.1) <230C6EEC-A926-3720-82DB-25D0FAAEF962> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x94d1a000 - 0x94d1afff com.apple.Carbon (154 - 155) <C0A26E7B-28F1-3C7E-879E-A3CF3ED5111C> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
0x96061000 - 0x960abff7 com.apple.framework.CoreWLAN (3.4 - 340.18) <A874C0A7-9CE0-3434-A38D-7EE61AD35DD7> /System/Library/Frameworks/CoreWLAN.framework/Versions/A/CoreWLAN
0x9843a000 - 0x98448fff com.apple.opengl (1.8.10 - 1.8.10) <385E048A-FFB2-348A-8F80-572C2494A776> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
0x99bb9000 - 0x99e79ff3 com.apple.security (7.0 - 55179.13) <000FD8E9-D070-326A-B386-51314360FD5C> /System/Library/Frameworks/Security.framework/Versions/A/Security
0xbabb0000 - 0xbabb3ff7 +com.razer.apm.client (1.06 - 1.06) <8B058886-90A0-8730-A564-BA428D6ECFA7> /Applications/StarCraft II/*/RzAPMClient.framework/Versions/A/RzAPMClient

Model: iMac13,2, BootROM IM131.010A.B04, 4 processors, Intel Core i7, 3.4 GHz, 16 GB, SMC 2.11f14
Graphics: NVIDIA GeForce GTX 680MX, NVIDIA GeForce GTX 680MX, PCIe, 2048 MB
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D5434314753364D465238432D50422020
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D5434314753364D465238432D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xF4), Broadcom BCM43xx 1.0 (5.106.98.100.17)
Bluetooth: Version 4.1.7f2 12718, 3 service, 21 devices, 3 incoming serial ports
Network Service: Ethernet, Ethernet, en0
PCI Card: Apple 57761-B0, sppci_ethernet, Thunderbolt@17,0,0
PCI Card: pci11c1,5901, sppci_ieee1394openhci, Thunderbolt@18,0,0
PCI Card: pci12d8,400e, sppci_usbopenhost, Thunderbolt@13,0,0
PCI Card: pci12d8,400e, sppci_usbopenhost, Thunderbolt@13,0,1
PCI Card: pci12d8,400f, USB Enhanced Host Controller, Thunderbolt@13,0,2
Serial ATA Device: APPLE HDD ST1000DM003, 1 TB
USB Device: Razer DeathAdder, 0x1532, 0x0016, 0x14400000 / 1
USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1a100000 / 2
USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8511, 0x1a110000 / 3
USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1d100000 / 2
USB Device: hub_device, 0x0424 (SMSC), 0x2412, 0x1d180000 / 3
USB Device: BRCM20702 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x1d181000 / 4
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x828b, 0x1d181300 / 6
USB Device: hub_device, apple_vendor_id, 0x9127, 0x40100000 / 2
USB Device: MacBook Air SuperDrive, apple_vendor_id, 0x1500, 0x40120000 / 8
USB Device: Logitech Camera, 0x046d (Logitech Inc.), 0x081d, 0x40110000 / 7
USB Device: Bose USB Audio, 0x05a7 (Bose Corporation), 0x1020, 0x40130000 / 6
USB Device: Display Audio, apple_vendor_id, 0x1107, 0x40140000 / 5
USB Device: FaceTime HD Camera (Display), apple_vendor_id, 0x1112, 0x40150000 / 4
USB Device: Apple Thunderbolt Display, apple_vendor_id, 0x9227, 0x40170000 / 3

Never mind found another thread where also found a solution...
Edited by QuakMafia on 10/6/2013 2:25 PM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]