StarCraft® II

2 year old bug, replay issues.

Posts: 64
This bug has been reported many times over the years, since it's first discovery.
(link expired)
Yep. Replays. They STILL freeze every 9th second. No matter what speed you play it at, when the in game timer says 0:09, 0:19, 0:29, 0:39, 0:49, 0:59, 1:09, etc so on so forth. It freezes for about 5 to 10 seconds.

So why hasn't this been fixed? No one's gonna watch replays if the replay watcher is so broken it causes it to almost freeze long enough for Windows to notice it apphang and pull up that message you see in the screenshot.

I have reinstalled the game and the error not be fixed, I have even installed the game on a brand new computer freshly bought and the error still happen. (I didn't buy a new computer to fix the issue, that'd be crazy. Just my old laptop died is all so I had to get a new one.)

If you like, I can fraps the issue and post it on youtube so everyone can see the issue that's been in Starcraft 2 since the near beginning? I remember when the game first came out and I could watch replays just fine for a long long time. I used to watch them to figure out what the enemy did so I could improve upon and not lose again. Now it's so bad it takes triple time to watch a replay at max speed. Watching at 8x speed is like watching it at Faster speed without freezes. Kinda makes it pointless adding replays to the game in the first place if they have become so unbearably unusable. :/

-----------------------------------------------------------------------------------------
http://us.battle.net/sc2/en/forum/topic/1921989362 by TheSwineFlew
http://us.battle.net/sc2/en/forum/topic/627974818 by Geemsean
http://us.battle.net/sc2/en/forum/topic/7200064712 by MinDseT with another confirm by Fenix
http://us.battle.net/sc2/en/forum/topic/145754820 by neSix with another confirm by jChuck, Zepp and Synergy
Do I need to find every post you have ignored Blizz Support Staff? Why isn't this in the known bugs post in this forum? Why isn't this addressed anywhere? Why can none of you tell us "This is a complex issue and we aren't quite sure how to fix it right now but we are aware of this bug."? Or "Duh to the nature of this bug, we don't find it important enough to fix."? You should be telling people that you DO know about the bug, and are either working to fix it or aren't going to bother. Don't leave it as a total mystery as if it's not important enough to add to the known bugs list.
Edited by VasVadum on 4/29/2013 2:52 AM PDT
Reply Quote
Posts: 64
I have got my dxdiag info out as some members of the community suggested I do so.
https://dl.dropbox.com/u/30270697/txt/DxDiag.txt
I have been told by one player that he also has a G74Sx, and doesn't have my issue. Though the G74Sx can come with several different configurations, so it could still be limited to a specific type of hardware. Please, I need help fixing this issue once and for all, and don't tell me to reinstall. I've already tried about a year ago when I bought my new PC.
Reply Quote
Posts: 13
yeah i let him know that his chip set drivers were out of date along with his video card drivers. but up dating them didn't help his case. Nesix swears its the audio driver but it looks like his is up to date. it could be a issue with his brand of hard drive looking at teamliquid they seem to have a replay viewer that a couple of them are using. not a bad idea if no one helps but someone should help i wold hope.
Reply Quote
Posts: 64
It's Blizzard's job to fix the game to work with the current technology. If it doesn't work on my brand of hard drive, then many people are screwed. I use Western Digital. The error was on both a 2.5" 5400 RPM and now on a 2.5" 7200 RPM except the freezes are worse. I don't think it's a hard drive issue unless Blizzard made the replays require vast amounts of hard drive speeds only capable in desktop supermax ultra drives or SSDs.

The audio drivers are completely different between the 2 PCs I have/had too. Can't be the issue unless it's broken with both drivers.

This is a technical support forum, where's the tech support? Blizz doesn't do tech support on their own product?
Reply Quote
Posts: 64
Still waiting Blizzard, come on. You refuse to give me supports via tickets and now you're refusing to give me game support here too?
Reply Quote
Posts: 256
I received an answer from Tech Support about this. They said it was a known issue with NVidia cards, and that they are working to fix it by next patch.
Reply Quote
Posts: 64
I received an answer from Tech Support about this. They said it was a known issue with NVidia cards, and that they are working to fix it by next patch.


HAH, by the next patch. You mean it's taken them years to fix this? What's to say they really are going to fix it?

So anyone in the world who has an nVidia card of any kind has this issue? Because this has been an issue on 2 separate computers both with 2 different nvidias.
Reply Quote
Posts: 64
For all who want to see the bug in action:
http://www.youtube.com/watch?v=Fb9wnb92t7U

Please tell me your graphics card model if you also have this issue.
Reply Quote
Posts: 96
For all who want to see the bug in action:
http://www.youtube.com/watch?v=Fb9wnb92t7U

Please tell me your graphics card model if you also have this issue.


Well, maybe I'm an odd end, but i'm not having the bug at 9 seconds, and I had to tune up the speed to 4x to actually see a slight (20ms maybe) stuttering every now and then, but it might be due to the high load of speeding up the game so much in ultra (high can do fine until 8x).

My specs are as follow:

Laptop model: Samsung 500P4C
Processor: Core i3-2370
Graphics card: Nvidia GEforce GT630M
RAM: 16GB
OS: Win7 Ultimate x64

I have a regular HDD (SSDs are insanely expensive right now). Hope it helps getting the bug fixed somehow; I agree with you, it's impossible to enjoy your replays like that
Reply Quote
Posts: 64
If your issue does not look like the one in the video I uploaded, it's not the same issue. Upon further examination of the video, I noticed that it is in fact freezing every 10th second. Just a millisecond or 2 before the in game timer switches to the next number up. So in fact it's freezing on every 10th second but it looks like every 9th second.

Someone once tried to tell me this has to do with hard drives, but that's not even possible. It's a file less than 20KB in size, the entire thing could fit in the memory of a computer in 1995. I doubt the hard drive at 7200 RPM or even SSDs are incapable of loading a 20KB file into memory.

Others tell me it's related to the graphics card, which I can't figure out how due to the fact that I can play the game laglessly, join multiplayer games, all on maximum graphics, and this freeze issue happens even on lowest graphics in replay mode only.
Reply Quote
Posts: 4
I received an answer from Tech Support about this. They said it was a known issue with NVidia cards, and that they are working to fix it by next patch.


Im having the same problem, but i have an ATI Radeon 5800 series and not an nvidea graphic card. And yes for me it freezes at every 9th second with an time interval of 10 seconds.
Reply Quote
Posts: 1
I have the problem too. I remember early days of sc2 replays were working fine.
After one patch they started to lag like he said every 9th or tenth second.
I had an Ati card and now Nvidia happening with both.
Im googling for this problem since 2years from time to time and have tried out all bug fixes I found, none worked.
It obviously must be a problem with the HD since sc2 writes a timestamp thingy every 10 sec on your hd and thats exactly when it lags.
Really an annoying issue and I would like to get a fix for this too.
Cant be that hard...especially since it worked fine when sc2 came out.
Reply Quote
Posts: 873
I have been experiencing the same problem. I never had this problem before but when I updated to HOTS, it started to occur. It is very annoying and makes replay almost unwatchable.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]