StarCraft® II

Problemas de linguagem após o último Patch

Minha versão é a NA, consegui sim.
Responder Citar
Operando perfeitamente, thanks ;)
Responder Citar
AEEEEEEEEE!
Deu certoooo!
Tava baixando de novo o cliente de instalaçao em ingles!
Muito obrigado!
Responder Citar
Support Forum Agent
Olá a todos,

Se a região que estava no Variables.txt não for uma destas três:

  • ptBR
  • enUS
  • esMX

  • ...então a região do StarCraft II instalado não pertence à região das Américas, e terá de ser reinstalado completamente na região certa (América Latina ou América do Norte, dependendo da licença na conta Battle.net), pois nesse caso, todo o cliente tem de ser alterado, não só o Variables.txt.

    Isto pode não ser um problema se seu StarCraft II é Europeu.
    Editado por Joaoc em 01/08/2012 10:54 BRT
    Responder Citar
    Olá a todos,

    Se a região que estava no Variables.txt não for uma destas três:

    ptBR
    enUS
    esMX

    ...então a região do StarCraft II instalado não pertence à região das Américas, e terá de ser reinstalado completamente na região certa (América Latina ou América do Norte, dependendo da licença na conta Battle.net), pois nesse caso, todo o cliente tem de ser alterado, não só o Variables.txt.

    Isto pode não ser um problema se seu StarCraft II é Europeu.


    Depois de baixar o patch eu entrei no SC2, mas estava em inglês (meu SC2, a principio, é ptBR) e, quando eu tentava conectar pedia pra baixar um pack de línguas (ou seja, o problema que todo mundo tava tendo).

    Então, abri o 'Variables.txt' e estava como enGB. Editei para ptBR.
    Só que agora quando eu tento entrar no jogo, antes de ele começar a carregar, aparece o seguinte erro (mostrado na imagem que eu fiz o upload):
    http://imageshack.us/photo/my-images/51/errosc2.png/

    Observação importante: Eu tenho uma conta ilimitada ptBR, mas também tenho uma conta Starter Edition no europeu em inglês, porém, só tenho o jogo em português instalado, entretanto, dentro da minha pasta de contas (Documentos/Starcrat II/Accounts/77164465/***) tem as duas duas contas (tem duas pastas, no caso, uma pra cada conta).

    Queria uma explicação mais detalhada sobre o possível problema e se, esse, tem alguma relação com minha conta Starter Edition no servidor Europeu.
    E, por favor, minha internet é lenta pra demônio (300 KB), então, se tiver algum jeito de resolver isso além de baixando o jogo todo, me diga (caso contrário, há uma boa chance de eu não baixar nada e ficar sem o jogo)! Nem que seja disponibilizando um pack de linguagens ou sei lá o que.

    -- // --

    EDIT: O que parece que aconteceu, foi que o jogo "se confundiu" e baixou o patch 1.5 em inglês, apesar de meu jogo estar totalmente em português. Me corrija se eu estiver errado.
    Editado por LeeGall em 01/08/2012 11:57 BRT
    Responder Citar
    o meu tbm estava assim eu segui os passos e deu certo
    Responder Citar
    Hahahahaha! Já consegui entrar no jogo!
    Mas tá acontecendo uma coisa louca aqui no meu SC2! Não tá dando pra entrar pelo executável do jogo, só pelo editor de mapas! lol

    Será então, que o meu problema tem a ver com meu executável estar danificado ou sei lá o que? Mas, pra rodar o jogo, o editor não usa o executável? Ah! Ajuda aí, quero saber o que está acontecendo!

    --//--

    EDIT: Será que isso pode causar algum problema para atualizações futuras? Será que não tem um jeito de eu reparar isso? Ou será que é possível alguém me fornecer uma cópia do .exe do SC2 (e será que seria seguro fazer isso?)?
    Editado por LeeGall em 01/08/2012 12:23 BRT
    Responder Citar
    Support Forum Agent
    Oi LeeGall,

    Estou suspeitando que de alguma forma, mesmo depois de alterar o Variables.txt, a instalação sendo executada ainda é a starter edition da europa.
    Verifique se existem duas instalações em seu sistema, e verifique também qual delas você está tentando executar.
    Pode fazer isso verificando as propriedades do atalho do jogo.

    Antes de cada tentativa, verifique e salve o conteúdo do Variables.txt.

    Obrigado.
    Responder Citar
    Na realidade quando eu digo o executável, eu quero dizer o arquivo em si não o atalho na área de trabalho. De qualquer maneira, eu olhei o arquivo da área de trabalho e ele está direcionado pro mesmo arquivo .exe da pasta do SC2 (o que eu tava tentando abrir, no caso).
    Esse erro é muito estranho, pois como que está funcionando rodar o SC2 pelo editor (eu abro o editor e boto testar mapa, aí eu posso jogar o SC2 normal) mas não pelo executável?

    Enfim, eu realmente tenho apenas um SC2 (um cliente), isso eu posso afirmar, mas realmente não duvido que o jogo esteja tentando rodar por algum executável errado. Bem, até sair a solução vou continuar jogando pelo editor...
    Responder Citar
    Se seu único StarCraft II era Inglês, então é provável que você não esteja experienciando este problema, pois o Variables.txt está correto.

    2. Você tem vários StarCraft II em sua Battle.net (exemplo: América Latina e América do Norte):

    Verifique que seu Variables.txt tem a língua igual aquela que você deseja jogar, ou seja, altere as linhas para enUS antes de iniciar a versão em Inglês para conetar no StarCraft II Inglês, ou ptBR antes de iniciar a versão em Português. Cada vez que quiser jogar noutra língua, verifique que seu Variables.txt está com a língua desejada, como nos 2 exemplos acima.

    Depois da alteração, salve o arquivo Variables.txt e tente conetar. Deverá funcionar. ;)

    Note que esta solução é temporária, e que uma próxima atualização deverá tornar estes passos desnecessários. Se o último patch é mais recente do que o 1.5.0.22612, por favor ignore estas instruções.

    ISSO É UMA VERGONHA COMO QUE A BLIZZARD ME DA UM MOLE DESSE VCS NÃO TESTA ESSES PACTH ANTES NÃO??????

    QUE DISSER QUE AGORA TEMOS QUE FICA MUDANDO ARQUIVOS PRA JOGAR SC2?
    Responder Citar
    Support Forum Agent
    É importante para a Blizzard conseguir analisar o maior número de respostas possível dadas por nossos jogadores. Em resposta a violações da regra 10 do fórum neste tópico, e no âmbito de reduzir comentários contra produtivos à análise do problema e que reduzem a nossa capacidade de detetar a informação útil e indespensável que entre eles se encontra, poderemos estar apagando qualquer resposta não técnica neste tópico.

    Obrigado pela compreensão.
    Responder Citar
    Support Forum Agent
    Oi LeeGall,

    Quando você tinha a Starter Edition e comprou a verão completa, o que aconteceu com a instalação da Starter Edition da europa? Você tomou algum passo extra, como desinstalar a Starter Edition, ou instalar a versão completa por cima?

    Obrigado.
    Responder Citar
    Sim, desinstalei a versão Européia mas, como eu disse, ainda há a pasta que guarda as informações da conta Starter Edition (saves, replay etc). Ou seja, eu desinstalei a versão Européia, mas optei por manter os dados (saves etc e, principalmente, mapas) durante o processo de desinstalação. Acredito que essa seja a causa principal do problema.
    Mas, como eu disse, pelo menos eu ainda posso jogar executando o jogo pelo editor.

    Aqui tem uma imagem pra tu entenderes melhor o que eu quero dizer sobre as pastas dos saves:
    http://imageshack.us/photo/my-images/821/sc2error2.png/

    --//--

    EDIT: Oi :-)
    Editado por LeeGall em 01/08/2012 16:52 BRT
    Responder Citar
    Entao, fiz a atualizacao do patch 1.5 do Starcraft para MAC OS X Lion 10.7.2 e depois de concluida ele me dava uma mensagem de erro, e pede para eu reinstalar o jogo, mas ja fiz isso duas vezes e continuo com o mesmo problema, gostaria de uma solucao...
    Ps: ja postei e ninguem resolveu nada
    Muito Obrigado
    Abraço a todos voces !!
    Responder Citar
    O Problema do meu é que fica dando que não tem espaço no Hd, mais tem mais 25 giga sobrando eu tento varias vezes mais não deu certo. Ja apageui e instalei de novo msm assim continua dando o msm erro ... Oque eu faço Joaoc ????
    Responder Citar
    Sera que até Sexta esta tudo normal?????
    Responder Citar
    Olá,

    Tinha o SC2 instalado em Português no meu MacOs 10.7 Lion. Após o patch 1.5.0, o jogo ficou em inglês. Acessei minhas contas no Battlenet, e tenho 2: uma de starter edition que usei para testar o jogo (e não uso já há muito tempo, nem lembrava dela) configurada em Inglês/NA , e a outra (que usava regularmente) em Português/LA. Além destas contas, existe o link para o download do patch 1.5.0 beta em inglês.

    Agora só consigo logar com a conta em inglês antiga.Não achei no meu Mac o arquivo variables (a pasta citada em outros posts não existe, e também não acho no spotlight).

    Alguma sugestão? Se eu baixar o novo cliente em português, ele será atualizado para inglês novamente?

    Como consigo excluir/desabilitar a conta antiga?

    Grato
    Editado por RyM em 01/08/2012 20:04 BRT
    Responder Citar
    O meu tava em ingles da inglaterra, mudei para ptBR e continua a mesma coisa. Continua aparecendo a mesma mensagem.
    Responder Citar
    depois de atualizar ontem eu entrei no jogo só pra ver as mudanças na UI e achei bem legal.
    Hoje fui tentar entrar e e deu esse problema.

    meu SC é o BR. Uma vez instalei o inglês e fiquei decepcionado ao descobrir que não me era permitido aproveitar o jogo na língua que eu quisesse, dai eu baixei o jogo denovo em PTBR e reinstalei.

    Fui na variables.txt e JÁ estava em ptBR... não tenho o que fazer...
    Responder Citar
    Mudei conforme o procedimento, e não funcionou. Não aceita que eu salve o arquivo modificado
    Responder Citar

    Por favor, relate qualquer violação do Código de Conduta, incluindo:

    Ameaças de violência. Nós levamos isso a sério e alertaremos as autoridades apropriadas.

    Mensagens contendo informações pessoais de jogadores. Incluindo endereço físico ou de e-mail, número de telefone, fotos e/ou vídeos inapropriados.

    Assédio ou linguagem preconceituosa. Isso não será tolerado.

    Código de Conduta dos Fóruns

    Relatar mensagem # escrita por

    Motivo
    Explique (no máximo 256 caracteres)
    Enviar Cancelar

    Reportado!

    [Fechar]