Stormstrike debuff bugged.

This may just be a tooltip error, but when I hit stormstrike and debuff an enemy with the 25% nature damage crit debuff, the 8% extra crit from the stormstrike glyph is not properly reflected.

Sometimes the debuff says 33% crit, and sometimes it says 25% crit.

This is confusing as I can't tell if the glyph is bugged and not always properly applying the 8% crit increase, or if the tooltip itself is bugged.


Also, the glyph states an 8% increase to stormstrike debuff DAMAGE, when it's crit strike %, not damage being boosted.

Anybody know if this is a bug or a tooltip error? And what the deal is with the glyph description?
Edited by Precaution on 11/16/2010 3:45 PM PST
Reply Quote
100 Tauren Shaman
11960
This has always been true of talented/glyphed buffs/debuffs.

The debuff actually is getting you the extra crit, you just won't see the extra crit from the tooltip on the target's debuff. It's a tooltip error, just like the old tooltip errors with, say, improved SoE totem.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]