4.03 Number of clients launched restriction?

80 Tauren Druid
5585
I realize that this is probably going to get flamed really quick, but I have noticed that I can only launch one instance of WoW now with 4.03, while under 4.01 I could launch five (Multi-box). My setup is a standard installation into /Applications, and the other 4 copies using symlinks to the data folders, and copies of the WoW.app tucked into individual folders in /Users/Shared/. Has anyone else seen this issue, or found a way to resolve it, or has the TOS and EUlA changed to forbade multi-boxing?


Model Name: Mac Pro
Model Identifier: MacPro4,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.26 GHz
Number Of Processors: 2
Total Number Of Cores: 8
L2 Cache (per core): 256 KB
L3 Cache (per processor): 8 MB
Memory: 14 GB
Processor Interconnect Speed: 5.86 GT/s
Boot ROM Version: MP41.0081.B07
SMC Version (system): 1.39f5
SMC Version (processor tray): 1.39f5

System Software Overview:

System Version: Mac OS X 10.6.5 (10H574)
Kernel Version: Darwin 10.5.0
64-bit Kernel and Extensions: No
Time since boot: 4 days 11 minutes

Graphics/Displays:

ATI Radeon HD 5770:

Chipset Model: ATI Radeon HD 5770
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x68b8
Revision ID: 0x0000
ROM Revision: 113-C0160C-155
EFI Driver Version: 01.00.436
Displays:
LED Cinema Display:
Resolution: 1920 x 1200
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Connection Type: DisplayPort
Display Connector:
Status: No Display Connected
Display Connector:
Status: No Display Connected

ATI Radeon HD 5770:

Chipset Model: ATI Radeon HD 5770
Type: GPU
Bus: PCIe
Slot: Slot-2
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x68b8
Revision ID: 0x0000
ROM Revision: 113-C0160C-155
EFI Driver Version: 01.00.436
Displays:
LED Cinema Display:
Resolution: 1920 x 1200
Pixel Depth: 32-Bit Color (ARGB8888)
Mirror: Off
Online: Yes
Rotation: Supported
Connection Type: DisplayPort
Display Connector:
Status: No Display Connected
Display Connector:
Status: No Display Connected

I poked the Console and this was present: =========================================================
11/17/10 12:14:29 AM [0x0-0x37f37f].com.blizzard.worldofwarcraft[6751] Assertion Failed!
11/17/10 12:14:29 AM [0x0-0x37f37f].com.blizzard.worldofwarcraft[6751] App: /Users/Shared/Wow Copies/World of Warcraft/World of Warcraft.app
11/17/10 12:14:29 AM [0x0-0x37f37f].com.blizzard.worldofwarcraft[6751] File: (unknown)
11/17/10 12:14:29 AM [0x0-0x37f37f].com.blizzard.worldofwarcraft[6751] Line: 0
11/17/10 12:14:29 AM [0x0-0x37f37f].com.blizzard.worldofwarcraft[6751] Error Code: 0x85100086
11/17/10 12:14:29 AM [0x0-0x37f37f].com.blizzard.worldofwarcraft[6751] Time: 2010-11-17 00.14.29 PST
11/17/10 12:14:29 AM [0x0-0x37f37f].com.blizzard.worldofwarcraft[6751] Assertion: Failed to open archive Data/wow-update-oldworld-13154.MPQ. Missing or corrupted data.
11/17/10 12:14:29 AM [0x0-0x37f37f].com.blizzard.worldofwarcraft[6751] Debug Details:
11/17/10 12:14:29 AM [0x0-0x37f37f].com.blizzard.worldofwarcraft[6751] [0] err=4 text=Posix Open - Data/wow-update-oldworld-13154.MPQ.writeCacheBackup
11/17/10 12:14:29 AM [0x0-0x37f37f].com.blizzard.worldofwarcraft[6751] Storm Error Msg:
11/17/10 12:14:29 AM [0x0-0x37f37f].com.blizzard.worldofwarcraft[6751] Crashed Thread: 0x00000207
11/17/10 12:14:29 AM [0x0-0x37f37f].com.blizzard.worldofwarcraft[6751] ---------------------------------------------------------

Anyone got any thoughts?
Edited by Mayafox on 11/17/2010 12:25 AM PST
Reply Quote
90 Draenei Warrior
16395
Symlinking your data folder was safe to do before 4.0.x. Previously, the data folder was purely for reading. All writing operations went on in the WTF folder.

There's some writing going on in the data folder these days.

Moving forward, people are probably going to be required to keep complete, separate copies for each instance of the game for this reason. Data corruption and crashes are possible and maybe even likely otherwise.

If you were really meticulous, you could presumably symlink the read-only stuff on a file-by-file basis, but you'd have to know which files are only being read. Would be a bit of a pain, and probably not worth it given how much disk space most of us are running around with these days.
Edited by Phine on 11/17/2010 12:33 AM PST
Reply Quote
80 Tauren Druid
5585
Thanks, I'll poke my setup a bit more, and see what i can come up with as solution, and not have symlinked folders.
Reply Quote
- Technical Support
90 Human Warrior
18630
i just duplicate wow app only in same folder, then launch it from there, i never did anything else.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]