Mac Graphic Issue

100 Night Elf Priest
10540
Hello, here are my specs; hope someone can help me :)

Model Name: MacBook Pro
Model Identifier: MacBookPro5,3
Processor Name: Intel Core 2 Duo
Processor Speed: 2.66 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 3 MB
Memory: 4 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MBP53.00AC.B03
SMC Version (system): 1.48f2
Hardware UUID: 3715F050-7396-5731-BFC0-A166074571A5
Sudden Motion Sensor:
State: Enabled
Chipset Model: NVIDIA GeForce 9400M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0863
Revision ID: 0x00b1
ROM Revision: 3448
gMux Version: 1.8.8
Displays:
Display Connector:
Status: No Display Connected
Display Connector:
Status: No Display Connected
System Version: Mac OS X 10.6.5 (10H574)
Kernel Version: Darwin 10.5.0
Boot Volume: Macintosh HD
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: No
Time since boot: 4:30 Boot Mode: Normal

And my issue: I have the "red restriction bar" on my graphics choices. When 4.01 dropped, another mac user within my guild told me to add a line in the Config file...something along the lines of SETgxiOpen (or something similiar?) because I was having very choppy graphics (although they looked beautiful!) It fixed the choppiness, and since then I haven't been able to use the higher end graphics.

At any rate, I read on the forums a while back that this issue should be fixed when Mac updates their OS. So I've updated it a few times, and removed that line that was added; however, I still had choppy graphics, so I put it back in. And I've forgotten where to find this line since.

I've done searches, but I can't seem to find any information that targets my issue specifically (which probably just means I fail at searches...) but if anyone could be so kind to help me out, I'd really appreciate it. Can I have pretty, smooth graphics? Thanks a bunch.
Reply Quote
MVP - Technical Support
100 Draenei Mage
7215
Do you have a "SET gxApi="OpenGL" " line in your config.wtf ?


________________________________________________
Bringing you walls of text and cookies since 2005 :)
PM ME ON WOWINTERFACE.COM IF YOU NEED TO

Blue ! Red ! Now Green ! I'm like a traffic light. Here to Help :)
Reply Quote
100 Draenei Warrior
18825
Find your Config.wtf file (located in your WTF folder in your WoW folder):

http://img221.imageshack.us/img221/4536/screenshot20101120at223.png

Open the file in TextEdit, and find the line that says SET gxApi "OpenGL" and delete that line:

http://img217.imageshack.us/img217/701/screenshot20101120at224.png
Edited by Phine on 11/20/2010 2:27 AM PST
Reply Quote
Support Forum Agent
Yup, you will want to follow Bluspacecow/Phine's suggestion and remove that command, as having this command in your config.wtf file will make your graphics slider bar red, and you will not be able to slide the bar, no matter what OS X version you are on.
________________________________________________
Account and Technical Services || Mac Tech Support
Tue-Sat 9 AM - 5 PM CST
Can't find a resolution on the forums, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
Do you love Boomkins? Sure, we all do!
Wait I mean, take a moment to let me know how I am doing. http://www.surveymk.com/s/RF8K3KG
Reply Quote
100 Night Elf Priest
10540
I removed the line and put my graphic settings on the recommended values.

However, I'm not particularly pleased with the performance.

Texture: high
Filtering: x4 anisotropic
projected textures enabled

view distance: good
environment detail: good
ground clutter: good

Shadow quality: good
liquid detail: good
sun shafts: low
particle density: good

The framerate is really choppy; spikes and drops when I move, and it's pretty irritating. Am I stuck with turning all my graphics back down to rock bottom, or is there a simple fix for this?
Reply Quote
1 Troll Mage
0

liquid detail: good
sun shafts: low

Am I stuck with turning all my graphics back down to rock bottom, or is there a simple fix for this?
Try turning Sunsharfts to Disabled. Also play with Liquid Detail. Try Fair then Low.

With the same settings you have listed, I get around 20 FPS or less and other issues. with Sunshafts disabled and Liquid Detail to Low, I get about 120 FPS. With Liquid Detail at Fair, I get around 60 FPS. I'd say the code for Liquid Detail still needs work.
Reply Quote
100 Night Elf Priest
10540
Thanks, that seemed to help.

I didn't even really notice the sunshafts =/ It runs much, much better with liquid on low, but it's tolerable on fair.
Reply Quote
- Technical Support
100 Human Warrior
22100
i disable sunshafts even though they don't even lower my fps, just cause honestly unless you are looking at the sun from behind a tree, you really just don't benefit from the feature at all, and while my graphics can handle them ifne, it just annoys me ot waste clock cycles for no reason. :)
Reply Quote
84 Tauren Druid
1840
Chipset Model: NVIDIA GeForce 9400M

Model Name: MacBook Pro


Unless you have the 13 inch Macbook Pro, you should have your 9400GT on instead. Go to your energy saver prefs and turn on High Performance mode in the graphics settings. The 9400M is for regular non-gaming stuff.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]