F9-F12 not functioning on Macbook Pro

90 Tauren Druid
16940
The keys function outside of the game, but they do nothing in game. Even when I go into the keybinds menu and try to bind them to something, the game doesn't recognize the button press at all. This still happens even with all addons disabled.

Edit: I should also mention, I suppose, that these keybinds have worked fine for me for several years until recently, within the past week or two.
Edited by Morgano on 11/21/2010 9:32 AM PST
Reply Quote
- Technical Support
90 Human Warrior
18580
patch 4.0.3 change or bug, it no longer supresses system events in full screen mode

you can however work around this by going to system preferences, then keyboard, then enable "use all F1, F2, etc as standard function keys" option. this basically disables apples custom F key functions and lets applications like games use them as they were meant to be, as function keys. you can still access the apple functions with the Fn key held down then pressing the F keys.
Reply Quote
90 Tauren Druid
16940
I've always had that enabled. F1-F8 still worked fine. I discovered that disabling the expose/spaces binding to the F keys in question fixed the issue, although inconvenient.

Update: Downloading Mac OS software update seems to have fixed the issue.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]