Just letting you know that your old, and new website as well as the armory give an error in google chrome browsers: unsupported node - 4

cheers