BUG: Full Circle

83 Undead Warlock
1680
I'm stuck on this bug.
Reply Quote
85 Draenei Death Knight
2990
Shadow council as of 10:30 PM mtn time just worked for me! go try yours
Reply Quote
85 Orc Warrior
2415
This is super irritating.
Reply Quote
85 Undead Death Knight
4565
Bonechewer comfirmed aswell.
Reply Quote
90 Draenei Shaman
0
Stormscale as well.

Please fix.
Reply Quote
100 Tauren Warrior
15850
DId 4 times. Bugged. Fix please!
Reply Quote
Bugged on Khaz-Modan as well, I can't get credit for boarding the sub and also can't get credit for the ride. NPCs are also appearing and dissappearing every three or four seconds.

Was able to complete on my main last night before server reset w/o problems.
Edited by Gemix on 12/9/2010 9:58 PM PST
Reply Quote
90 Blood Elf Paladin
7035
Same Bug on Trollbane
Reply Quote
Just tried. Confirmed. The door would not open for me.
Reply Quote
85 Blood Elf Rogue
6105
Same bug on Frostwolf US-PVP.
Reply Quote
81 Worgen Druid
430
Yes it is irritating, but considering a lot of phased areas have been blinking in and out it's no surprise an event as heavily phased as this one wouldn't be working at all. Hopefully Blizz will actually fix it. And it will actually stay fixed.
Reply Quote
85 Blood Elf Paladin
3395
Im getting the same bug.....makes me sad... Im trying the whole abandon quest and retry trick
Reply Quote
90 Human Priest
4340
confirmed still on Proudmoore. I actually got inside the submarine by just swimming about in the middle of where it docks... it threw me inside the ship and then at one point I saw the captain and lieutenant phase in and back out. No Credit. No Blizz. No Nothing. How does everyone feel after paying $180 per year on top of $40 for a broken expansion, and not getting a single word about anything from the high and mighty blizzard staff. "here's a survey" *sticks middle finger in the air*

I SAY FLOOD THE FORUM WITH POSTS!
Reply Quote
93 Tauren Warrior
5460
bump, PLEASE FIX
Reply Quote
85 Human Warlock
8805
Still glitched here on US-Nathrezim.
Reply Quote
85 Undead Rogue
8410
Bugged on Wanderlust, even when I get into the cabin, goblins disappear and reappear. But can only get in once you get to the cavern, so can't get credit for either part of the quest. Hope it's not a chain. Double you Tea Eff?
Reply Quote
84 Blood Elf Warlock
2125
Glad I am not only one having issue I got so fed up I just went on to Mount Hygial and will return when that quest is fixed hopefully soon
Reply Quote
85 Troll Hunter
9080
got a ticket response (automated of course) saying they're working on it.

am able to go into the verne through the underwater door, but no NPCs were spawned and the quest didn't complete.
Reply Quote
95 Blood Elf Paladin
5230
US-Spirestone, glitched.
It's making me crazy!
I sat in the sub for seven rounds. : |
No credit.
I couldn't get in until it docked in the cavern. : (
Reply Quote
96 Draenei Hunter
9285
also been having the bug. tried dropping quest at least 5 times and didn't help. super annoying.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]