Full Circle, broken?

(Locked)

This quest is Broken on Sen'jin as well.
85 Worgen Rogue
2970
There seems to be a problem with the way the X2 and the crew just phases around.

bump
85 Gnome Death Knight
3810
This is really annoying. Same as others have mentioned. I've had one door open to find a second closed door onto the sub. If I manage to get inside, the crew appears for about three seconds, and that's all. No chance t do anything but ride around. I also get a Breath bar while on board.
85 Goblin Rogue
2810
I am also experiencing this on Shattered Hand.

Posting so that this can be noticed. I would like to continue in this area.
85 Worgen Priest
4795
Same thing on Dath'Remar. Not sure if i should skip it or wait for it to be fixed for the quest chain to continue.
82 Tauren Warrior
1805
Broken on Misha...
83 Night Elf Priest
2450
Broken on Drak'Tharon for alliance as well. I opened a ticket earlier this afternoon and still no fix. Hopefully customer support will come through for all of us and make it right!
85 Night Elf Druid
1925
I am having the same problem. Where do I start the Hyjal quest?
85 Night Elf Druid
2345
It's not just Cata quests, it's also BC quests too, one i'm trying to complete "the final code"
85 Night Elf Druid
1925
I just finished this quest and there is a bit of a trick to it. After the sub arrives you must quickly board and enter the hatch (vault like door) and make your way down and forward. At the bottom you will see a glass porthole (large one). Just stand there and the quest will complete. I dropped through the pool of water in the middle and swam back to the beach. Quest complete. Hope this helps.
85 Human Warlock
9930
^Just tried it this way on my druid and it worked. After previous attempts of not entering the sub.
87 Night Elf Druid
8275
this quest does work, enter the door of the sub and make your way down to the bottom of the sub and watch from where the wheel is. no doors have to be opened though it is a pain having to find the way at first.

If it glitches or you did not find the way down just go back to the boat Captain Taylor is on using the seahorse flight path and try again until you can turn in the quest.
90 Human Paladin
9050
This quest is really glitchy. The securing the cave part wouldn't complete for me. Then I couldn't reaquire the quest to try it again. Bliz need's to fix these quest.



The above does work but if you can't complete the quest you might have to drop the quest, relog back in to try it again.
Edited by Celez on 5/28/2011 12:05 PM PDT
This quest is still bugged, I'll try it again tomorrow. I walked through the door on sub and fell through the floor. Never even seen the insides of it. Just trying to get this quest to begin with I had to relog over and over as NPC to get it from keeps phasing in and out of game.
85 Blood Elf Mage
4570
I ended up breaking this quest just now, jumping off the sub before the quest completed.

I dropped the quest to restart only to find that the questgiver was still phased out.

I figured I could port to org then Hearth to Legion's Rest to see if I could de-phase myself and pick the quest up again - it worked.
Having the problem too. Where does the pincer go after you get off? And how do you do the securing the cove part?
85 Draenei Shaman
3930
finally took me a sixth try, I actually entered the entire sub, stood at the control panel with the captain and no.2, and it worked... jeeze
90 Goblin Warrior
10915
This quest still has issues, both Ally and Horde side. After trying for hours to complete it on this toon, I managed to get stuck in midair in the cavern unable to log out.

Finally contacted a GM who got me unstuck and told me they could auto-complete the quest for me due to the large number of people still having problems.

I took that route rather than tear out my stylish purple hair.
The submarine isn't even showing up for me in the first place. The boarding plank appears, and the goblin announces its arrival, but no sub. If I swim to the end destination, the sub will eventually show up and I can force my way in. That gives me credit for "Secure Tenebrous Cavern," but I still can't get credit for "Board the Verne once it arrives." I'm effectively stuck.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]