FAQ: Installing & Troubleshooting AddOns

(Sticky)

90 Draenei Shaman
13640
On my old laptop, running Windows XP 32-bit, I had all of my addons working just fine. But now, on my new Windows 7 64-bit desktop, one addon will not work and I do not have the Addons tab under my in-game Interface menu. I have an Addons button on the character select screen and all three of my addons are shown there as enabled. I even have "Load out-of-date addons" checked. But regardless of what I do, I cannot get this addon to even register as being installed in-game. My game isn't 100% downloaded, but it's well into the "green" with only 300MB remaning on download. Any advice is helpful

My full path for addons in C:\Program Files (x86)\World of Warcraft\Interface\AddOns.


This is because you've installed your AddOns (and WoW itself) to a protected location.

Move the entire WoW installation to C:\Users\Public\Games and the problem will be solved.
Reply Quote
Im having issues getting my addons to work, I have put the addon folder in the correct place, but when I log into wow the button on the bottom left hand screen of the character select screen isnt there, so I cant enable my addons, help please!!!
Reply Quote
90 Draenei Shaman
13640
03/12/2011 6:35 PMPosted by Priape
Im having issues getting my addons to work, I have put the addon folder in the correct place, but when I log into wow the button on the bottom left hand screen of the character select screen isnt there, so I cant enable my addons, help please!!!


This means you haven't got your AddOns installed correctly.

Either:
1. Your AddOns folder is not in the right place.
2. You've got too many layers of folders.
3. You've installed your AddOns in the wrong copy of WoW.

All three are well-covered in the original post.
Reply Quote
20 Dwarf Hunter
70
I am trying to install my first addon and the button will not show up. The folder is at this location: C:\Program Files\World of Warcraft\Interface\AddOns
I am not sure what I have done wrong.
Reply Quote
90 Draenei Shaman
13640
I am trying to install my first addon and the button will not show up. The folder is at this location: C:\Program Files\World of Warcraft\Interface\AddOns
I am not sure what I have done wrong.


Please read the first post in its entirety.

Usually people have made a mistake in the extracting portion of the process and have an extra folder layer.

Correctly installed, my example AddOn, Fane, looks like this:
- Windows XP
C: \Program Files\World of Warcraft\Interface\AddOns\Fane


So if we're using my example AddOn (and are installing on Windows XP) and the path does not look exactly like one quoted above, the AddOn button won't show because the AddOn won't load.

Correct: C:\Program Files\World of Warcraft\Interface\AddOns\Fane

Wrong: C:\Program Files\World of Warcraft\Interface\AddOns\Fane-1234567\Fane
Reply Quote
20 Night Elf Hunter
160
HELLLLLPPPPPPPPPP meeeeee pleeeaaaasssseeeee. I've lost sound. In center of screen(horizontaly), just above the item bars,a speaker figure has appeared. It is invisible until the mouse runs over it. I have no idea wot it meens, or does. I've tried diff things to get sound back, but nothing works. I know i can continue without sound, but it's not much fun. Can any one out there in wow land help me get my sound back? Please help me, i don't know wot 2 do.
Reply Quote
90 Draenei Shaman
13640
Killswift -

You want the technical support forum. Most likely though, you've muted your sound via the keyboard shortcut. I forget what it is, but you can look it up in the keybinding menu.

The other icon is probably from an AddOn (maybe SexyMap) but I have no way to be sure.
Reply Quote
13 Blood Elf Rogue
120
My AddOns are in the right place and the button is showing up when logged in, yet when I go in-game, nothing appears.

I also have fully downloaded the game, any advce?
Reply Quote
90 Draenei Shaman
13640
Segway -

At the character selection screen, when you click on the AddOns button, are the names of your AddOns listed in red as "Out of Date"?
  • If so, check the "Load Out of Date" check box at the top of the screen.

  • At the character selection screen, when you click on the AddOns button, do any of the AddOns say "Dependency Missing?"
  • If so, mousing over the AddOn's entry in the list should tell you what it is missing.

  • If you open the game menu, choose "Options" and is there an AddOns tab?
  • If not, this could mean that either the AddOn doesn't register its options, or that the AddOn isn't actually loaded.


  • Also, it's useful to list your AddOns when requesting help.
    Reply Quote
    trying to get Addons to work on my wife's computer. she running Windows 7, 64-bit version. Adds are in the right place. C:\user\public\games\World of Warcraft\Interface\AddOns. However, the Interface folder is hidden from view. There are no other versions of the game installed. Any thoughts?

    Reply Quote
    NVM. Had a head-slap moment when I was making coffee.
    Reply Quote
    i just recently reloaded wow back on to my computer. i have been trying to load addons and
    C:\Users\Public\Games\World of Warcraft\Interface\AddOns :for ex. i have reloaded all my addons and i have done the whole Interface-old and it still wont work.
    Reply Quote
    90 Draenei Shaman
    13640
    Murloccs - Please read the first post again.

    If you have no "AddOns" button on the character select screen you've either:

    1. Installed the AddOns to the wrong place.
    2. Improperly extracted the AddOns so you have them in a nested folder (or didn't extract them at all).
    Reply Quote
    85 Draenei Shaman
    2380
    I have tried to put addons on my pc I have windows XP Path is C:/worldofwarcraft/interface/addons/recount-v4.0.1e_release


    I used to have no problem putting addons on and now I just cant get them to work. I would love any suggestions.
    Reply Quote
    90 Draenei Shaman
    13640
    I have tried to put addons on my pc I have windows XP Path is C:/worldofwarcraft/interface/addons/recount-v4.0.1e_release


    You've got an extra folder layer. Please see the "- Extracting your AddOns" section in the first post again.
    Reply Quote
    85 Draenei Shaman
    2380
    Thank you very much Unkle you are awsome!!!!
    Reply Quote
    85 Human Warrior
    3925
    after patcih i am noticing that there must be a lot of errors running even after updating my addons because of random frame rate drops/choppy game play.
    my question is where does wow show these errors so i can disable the addon that is the culprit
    Reply Quote
    10 Human Paladin
    50
    I have a strange issue. My ui (blizzard) is not saving my settings for some reason, I upgraded from vista 64 to win 7 64 so i am assuming this caused something to go haywire. After the upgrade i had to double click each addon to get it to come up on the addon screen on the character load screen any ideas why the addon settings are not being saved? I hope i didn't miss something when I read these post.
    Reply Quote
    85 Night Elf Druid
    4745
    Hey on a mac here and never had issues with addons till this patch...i tried manually installing and using curse client but no matter what i do they still won't show up. Please help. path is:
    world of warcraft, interface, addons.
    Reply Quote

    Please report any Code of Conduct violations, including:

    Threats of violence. We take these seriously and will alert the proper authorities.

    Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

    Harassing or discriminatory language. This will not be tolerated.

    Forums Code of Conduct

    Report Post # written by

    Reason
    Explain (256 characters max)
    Submit Cancel

    Reported!

    [Close]