FAQ: Installing & Troubleshooting AddOns

(Sticky)

90 Blood Elf Paladin
9355
Hello. I'm on an old Imac that has never once given me major problems. Unfortunately now it looks like my luck has run out.

With new patches, My addOns have always gone haywire the first week or so only to straighten themselves out later. Normally, I get by using the trick of loading my old addOns. As I heavily rely on only three with most of the normal blizzard UI, problems barely arise.

With this new patch, 4.1 and the days later patch of 4.2 (preview); My addOns have once again gone crazy, but this time without a work around. I tried to load my out of date addOns only to have them freeze my comp in any type of instance or battleground.

Becoming frustrated, I began to load the updates of my three addOns. Going back into wow, they did not appear to work. I then deleted everything in the folder, and re-downloaded the addOns. Placing them in the addOn folder, sure they were going to work- please understand my surprise when I went back into wow only to find no addOn button in the bottom left hand corner.

The Path:
Macintosh HD/Applications/World of Warcraft/Interface/AddOns/Clique-1.

Im unsure of what I did wrong, and why I have no addons installed correctly at all.
Thank You for any help, It's much appreciated.
Reply Quote
90 Draenei Shaman
13640
after patcih i am noticing that there must be a lot of errors running even after updating my addons because of random frame rate drops/choppy game play.
my question is where does wow show these errors so i can disable the addon that is the culprit


In the Interface section of the Game Menu (ESC) there's a sub-section called "Help." Check the box for "Show Lua errors."
Reply Quote
90 Draenei Shaman
13640
04/28/2011 06:10 AMPosted by Lincolnlog
I have a strange issue. My ui (blizzard) is not saving my settings for some reason, I upgraded from vista 64 to win 7 64 so i am assuming this caused something to go haywire. After the upgrade i had to double click each addon to get it to come up on the addon screen on the character load screen any ideas why the addon settings are not being saved? I hope i didn't miss something when I read these post.


You've likely got your AddOn data saved in the Virtual User Store. I suspect that you have WoW installed in Program Files(x86) and it should be installed in Public\Games. Move WoW to the proper location and addons should begin to work normally (though you may need to update your settings).

You can get more information here: http://www.wowinterface.com/forums/showthread.php?t=14650
Reply Quote
90 Draenei Shaman
13640
Hey on a mac here and never had issues with addons till this patch...i tried manually installing and using curse client but no matter what i do they still won't show up. Please help. path is:
world of warcraft, interface, addons.


The Path:
Macintosh HD/Applications/World of Warcraft/Interface/AddOns/Clique-1.


You both need to read the first post again, especially the part about extracting your AddOns. You likely have an extra folder layer. The example below can be helpful.

WRONG.
[Macintosh Hard Drive]../World of Warcraft/Interface/AddOns/Fane.1234/Fane


RIGHT.
[Macintosh Hard Drive]../World of Warcraft/Interface/AddOns/Fane
Edited by Unkle on 5/2/2011 1:19 PM PDT
Reply Quote
I took a three month break from WoW and came back to new patch content so my addons were out of date. No biggie, just updated them, but they always show up as 'out of date' when i load them. Sure I could hit the 'load out of date' button, but if I do that, I lag as soon as I'm in combat, and the addons don't work anyway.

I've used addons quite a bit in the past and they've always went to the same place- which I know is right. So why are my shiny new addons not actually working?
Edited by Mariellous on 5/6/2011 5:18 AM PDT
Reply Quote
90 Draenei Shaman
13640
Out Of Date means that the "## Interface: XXXXX" line in the AddOn's .TOC file doesn't match the current game-client number. It doesn't mean the AddOn doesn't work. Many times this doesn't matter because what the AddOn does hasn't been affected by game-client changes.

The 4.1 patch made a significant change to the arguments for the COMBAT_LOG_UNFILTERED event that many, many, many AddOns use to get combat information. Unless the author of the AddOn updated to account for this change anything that gets information from the combat log (Boss mods, combat text displays, enemy cooldown timers, and much much more) tend to misbehave.

AddOns which are generating error messages should be updated or replaced if no updates are available.
Reply Quote
Okay, I read something to that effect some time after my post. Still strange tho, some people's Recounts working fine and mine not. Oh well :D
Reply Quote
I need help. Ever since I loaded Cata onto my computer the addon button doesn't show up on my character list. I have tried re-loading the addons, checked the paths of where they are, moved them in and out of the folder. Even tried deleting it and have it reload the other information and nothing has helped. I read what you said up above but nothing is working. Is there anything else I can do?

D:\World of Warcraft\Interface\AddOns

That is the path for one of my addon's and I believe it is in the right place.

Please, I need help!
Edited by Bohemith on 5/12/2011 9:29 PM PDT
Reply Quote
90 Draenei Shaman
13640
Pro tip: If you have no AddOns button on the character selection screen then your AddOns are not correctly installed.

First: Which Operating System do you use - Windows XP, Windows Vista, or Windows 7 - and which version are you using 32-bit or 64-bit? I assume from the path you posted that you're running some version of Windows, but it's important to know which version.

Second: I assume you're using a shortcut on your desktop to launch WoW. Select it, then right click it and choose "Properties" from the menu. On the "Shortcut" tab, look at the information from the "Target" box. This will tell us the directory from which you're really running WoW.

Third: Read the first post again. It's important that you've correctly extracted your AddOns and put the folders in the right spots. Usually people have made a mistake in the extracting portion of the process and have an extra folder layer.

Quoted from my original post.
Correctly installed, my example AddOn, Fane, looks like this:
- Windows XP
C:\Program Files\World of Warcraft\Interface\AddOns\Fane

So if we're using my example AddOn (and are installing on Windows XP) and the path does not look exactly like one quoted above, the AddOn button won't show because the AddOn won't load.

Correct: C:\Program Files\World of Warcraft\Interface\AddOns\Fane

Wrong: C:\Program Files\World of Warcraft\Interface\AddOns\Fane-1234567\Fane

Edited by Unkle on 5/13/2011 8:28 AM PDT
Reply Quote
I got my bartender back!

Thanks for every ones help!
Reply Quote
For the second time, I had to reinstall my wow client UI. The reason is not important, but for the second time I lost all my addon's settings. It takes a long time to reconfigure, because I play with 3 different chars, particurlarly bartender4. Would you know a way for me to recover my bartender4 settings after reinstalling the UI?
Reply Quote
90 Draenei Shaman
13640
05/15/2011 06:45 AMPosted by Mamushi
For the second time, I had to reinstall my wow client UI. The reason is not important, but for the second time I lost all my addon's settings. It takes a long time to reconfigure, because I play with 3 different chars, particurlarly bartender4. Would you know a way for me to recover my bartender4 settings after reinstalling the UI?


Unless you back up your WTF folder, there's no recovering old addon settings.
Reply Quote
I can't find interface under my World of Warcraft folder. All that's in it is Account Billing, Blizzard Technical support, Cataclysm - manual, World of Warcraft - Repair, World of Warcraft - Uninstall, and World of Warcraft. Where would I find interface?
Reply Quote
90 Human Paladin
5780
Hey,

Apparently, I'm unable to extract addons since the option for extracting doesn't appear.

And even worse, once I try to download ANYTHING, my computer goes nuts and I have to hardboot it just to stop it.

Any help on this?
Reply Quote
90 Draenei Shaman
13640
Hey,

Apparently, I'm unable to extract addons since the option for extracting doesn't appear.

And even worse, once I try to download ANYTHING, my computer goes nuts and I have to hardboot it just to stop it.

Any help on this?


This is not an AddOn problem. You have general issues/problems with your computer and probably want to check for spyware and other general computer technical problems.
Reply Quote
90 Human Paladin
5780
I've done it all twice.

Do you know how to make the extraction option appear without downloading things for it?
Reply Quote
85 Tauren Druid
3835
Hi, first off, I'll tell my first problem. I was on a 3 month break from WoW and came back yesterday. I made some new macros and started playing... everything was ok. Then when i logged out and logged back in, my macros vanished. Like they were never created. So i looked online and it told me that my WTF folder was gone and that my World of warcraft folder was in User\Public\blah blah... well i clicked user and i have my usual user EXCEPT public. Now the wierd thing is that when i right click on my WoW shortcut and click find location, it brings me to the wow folder and it shows that its within public. Tho when i try to go back to the public folder it says its empty. So what i did was re-install WoW back to my Program Files (x86) folder and all of my folders are back (clearly with nothing still saved). Now when i use curse client to put my addons in, it continues to save in the Public folder where WoW WAS! I tried changing the install path but this pops up:

The folder you selected "C:\Program Files (x86)\WorldofWarcraft\Interface\AddOns" does not appear to be a valid installation of World of Warcraft.

I already know i have to reset up my whole UI and that's a serious bummer, but the fact that i can't conveniently use curse client is driving me crazy. Please someone help me! :(
Reply Quote
90 Draenei Shaman
13640
Maorladum -

Seriously, the problem is that you have installed your WoW in C:\Program Files (x86)\WorldofWarcraft. This is bad. Don't do it.

Copy/paste the entire folder into C:\Users\Public\Games. Change your desktop icon to point to the new path.

The Program Files or Program Files(x86) folders are protected locations. This means applications are not allowed to write data into those folders without elevated permission (i.e., 'Run as Administrator') so all the settings or files they try to write get re-directed to the Virtual User Store (a hidden folder). This is problematic for WoW since it was written for the days when applications were allowed to do whatever they wanted, wherever they wanted - And to keep things tidy, WoW writes all of its settings and AddOn data to its own folder.

Again, make your life better - move WoW to C:\Users\Public\Games. Then your full path for AddOns will be C:\Users\Public\Games\World of Warcraft\Interface\AddOns.

Also the Curse Client will need to rescan for your game.
Edited by Unkle on 6/10/2011 9:20 AM PDT
Reply Quote
71 Night Elf Hunter
900
I went onto my computers files and turned off my addons a while back and now i don't know how to turn them back on. Any suggestions?
Reply Quote
39 Worgen Hunter
300
Recently came back from a couple month WoW break. Patched up and went to character login screen to find AddOn tab missing.

My addons are in C>Users>Public>Games>World of Warcraft>Interface>AddOns

I'm running Windows Vista.

There is no second copy of WoW on my PC. Not in Program Files or Program Files(x86), or anywhere else. My AddOn tab appeared perfectly fine before I took my break. Now it's gone!
Edited by Antivillain on 6/21/2011 8:16 PM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]