[Bug] Elementium Stormshield - Display

(Locked)

85 Human Paladin
9650
Bump. Very disappointing customer service. Next time you send me your mails to rate your service expect to see the truth.
100 Blood Elf Paladin
9935
If I was wearing a robe, this might be ok. But wearing pants and nothing on my back - outrageous! What kind of warrior of anything is seen carrying a 1h weapon and nothing else? Let mages pee on my grave forever and warriors always burst my bubble, but never leave me without a shield graphic - not ok!
I'm going to start preparing jugs of urine to send to their doorstep. Maybe, just maybe, I'll find a way to set them on fire too. Of course, I mean this in the most supportive way possible.
Edited by Gothling on 1/2/2011 11:43 PM PST
85 Blood Elf Paladin
7525
Fix it please? Or at least acknowledge that the bug is there? :(
90 Human Paladin
20615
Hey blues time to wake up, wipe the donut glaze crust off your mouth and get to work fixing this.
85 Dwarf Paladin
4610
I just bought mine, and the same thing. Cant see it.
85 Orc Shaman
4150
Got me walking around and people laughing at me.....
/sniff
90 Blood Elf Paladin
10515
Bump
85 Draenei Shaman
4795
bump
85 Orc Shaman
4150
maybe they think we lying? Post a pic of your toon with no shield:

http://i737.photobucket.com/albums/xx20/Leavaugh/WOW/noshield.jpg
90 Blood Elf Paladin
10515
Here ya go, with out anything else on, no addons, and even a nice profo in the character screen.

http://i51.tinypic.com/25gqfcy.jpg
85 Blood Elf Paladin
4310
01/03/2011 5:43 AMPosted by Damíen
Got me walking around and people laughing at me.....
/sniff


hahahhahahahahhahahaha, omg. laughed so hard
85 Human Paladin
2500
Here's mine as well:

http://i52.tinypic.com/cte9j.jpg

Pretty aggravated this hasn't been fixed yet. Seems like it should be simple.
85 Goblin Shaman
6490
Bump!
85 Orc Shaman
4150
bump
85 Blood Elf Paladin
4310
go blizz! read our problem! '-'
85 Human Paladin
9650
01/02/2011 11:38 PMPosted by Wilhelm
This bug may have been in the game from the start and people starting posting about it days later but to say they don't care or won't do anything is wrong, what so many people don't seem to notice is people that work for blizz have families too and should be able to see them during the biggest holiday of the year. This problem will be fixed and as several have said after sending in tickets it's a work in progress as they know about the bug. I may not be too happy about not being able to see it either but i'm not going to expect people to work every single day of the year to fix what really is a small bug compared to others, now please if you have nothing constructive to say other than bashing on blizz for not fixing every bug by the time a new expansion comes out don't post here.


Oh I am so sorry for being a concerned paying customer. I didn't know we play on free private server for me to care about who has families , life and what not.

Keep in mind that this thread was created on 12/21/10.
85 Goblin Shaman
5985
This bug may have been in the game from the start and people starting posting about it days later but to say they don't care or won't do anything is wrong, what so many people don't seem to notice is people that work for blizz have families too and should be able to see them during the biggest holiday of the year. This problem will be fixed and as several have said after sending in tickets it's a work in progress as they know about the bug. I may not be too happy about not being able to see it either but i'm not going to expect people to work every single day of the year to fix what really is a small bug compared to others, now please if you have nothing constructive to say other than bashing on blizz for not fixing every bug by the time a new expansion comes out don't post here.

i got this shield 2nd day cata came out still no blue response i understand its a cosmetic thing but you say they have families too well how come then all other cosmetic bugs have been fixed (least the ones that have been reported while we sit with our thumbs up our butt)
FIX IT sick of looking like a druid with my mace and nothing else half the time press z just to make sure its still there
85 Human Paladin
2500
I think this deserves to be fixed just as much as any other bug. The other week in heroic Halls of Origination, we were doing the I Hate That Song achievement on Anhuur. I offered to hold healing aggro on the snakes for one of the switches, and our tank informed me that this was not a good idea, because I didn't have a shield.

Now obviously I cleared up that little misunderstanding, but I can't run around proclaiming that I have a shield all the time, and I certainly don't feel like having to toggle 'z' constantly. However, I also don't want to run around looking like a total noob. This bug, graphical as it may be, detracts from my World of Warcraft gaming experience, not unlike any other kind of bug you might encounter. Please give it the attention it deserves.

Thank you.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]