Addon API bug

85 Draenei Shaman
2590
Trying use SetLootMethod and SetLootThreshold from the same function doesn't work right.

Example: In a raid it's set to Group Loot and Uncommon threshold. Typing in

/run SetLootMethod("master","player"); SetLootThreshold(4);

will cause it to set the method to Master Looter, set myself to the master looter, change the threshold to epic, then set the method back to Group Loot.

Reversing the calls like so

/run SetLootThreshold(4); SetLootMethod("master","player");

causes the method to be right but to revert the threshold back to what it was before the change.

I have tried this in both party and raid, and with methods and thresholds other than "master" and 4. Done with no addons loaded.
Edited by Aetherea on 2/5/2011 1:08 PM PST
Reply Quote
85 Night Elf Death Knight
5105
Getting the exact same behavior. I've been beating my head against my desk for a few hours now, thinking this was a PEBKAC problem.... Anyone know a workaround, or ETA to fix, or anything?
Reply Quote
85 Night Elf Death Knight
5105
UPDATE: Talked to a GM about this, and they've opened a QA ticket to have it addressed.

Cheers!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]