Programmable mouse buttons not working.

85 Dwarf Shaman
9330
Hey there, I use a Logitech Performance MX mouse and today when I logged in after the patch, my extra mouse buttons on the side did not work anymore.

My mouse isn't specifically a gaming mouse, but pre-4.0.6 I had the extra buttons keybound and working perfectly. Now, after the patch their keybinds are still on my bars but they no longer work. I tried binding them again, but when in the keybinding menu, their clicks don't even register. No it's not my mouse being broken as I tested these buttons outside of WoW and they still work. Also to be noted, I had this same problem during Cataclysm beta, where the extra buttons did nothing, but come release they went back to normal.

Anyone else experiencing issues like this?
Reply Quote
85 Dwarf Shaman
9330
bump.
Reply Quote
85 Human Paladin
8645
I am having the same problem. Running wow.exe as admin does not resolve the issue.

Windows 7 Pro 64bit
Logitech Performance Mouse MX
Setpoint x64 software v6.20.64 (latest currently available on the website, dated 11/17/2010)
Reply Quote
85 Troll Priest
2135
I've had this problem in the past, specifically after I launch from the Launcher instead of just running wow.exe.

Try running the game directly from that executable. Also make sure you're not tabbing out since there's sometimes an issue with the buttons messing up after tabbing out.

I also reprogrammed my buttons to key combinations like Shift-6 for '^'. Then when in the game you can press the button while in chat. If you see '^' show up then the button should work.

It's annoying that they sometimes stop working, but I normally have success when I exit the game and restart it and don't start it from the Launcher. Good luck.
Reply Quote
85 Human Paladin
8645
Update for clarification:

The "forward" and "back" side buttons are still working correctly. They are registering as mouse button #4 and #5. The buttons that are not working are the 3rd left thumb button (the one just below the forward and back buttons on the left thumb) and the lower-most mushy thumb button. I'm sure that makes absolutely no sense to those of you who do not use this mouse, but that's the best way I can explain it. I believe the Logitech software considers those buttons #6 and #9.

Button 6: http://i.imgur.com/3sbAx.jpg

Button 9: http://i.imgur.com/HXMt9.jpg
Edited by Kystyrael on 2/10/2011 11:19 AM PST
Reply Quote
85 Troll Priest
2135
Ah. I'm not sure then. I have the MX 1000 mouse (older). I only have the two "forward / back" buttons on the thumb side. Do you have those two buttons programmed to a key combination or something else? It's possible that WoW doesn't recognize the actual buttons anymore but could still recognize a key combination...

You *might* get better answers in the Technical Support forum but it's always iffy.
Reply Quote
85 Human Paladin
8645
I've had this problem in the past, specifically after I launch from the Launcher instead of just running wow.exe.

Try running the game directly from that executable.


Yeah, still have the problem running when launching wow.exe directly, including running as administrator.

02/10/2011 11:14 AMPosted by Someoneelse
Also make sure you're not tabbing out since there's sometimes an issue with the buttons messing up after tabbing out.


Just relaunched without tabbing out to verify. The problem still exists.

02/10/2011 11:14 AMPosted by Someoneelse
I also reprogrammed my buttons to key combinations like Shift-6 for '^'. Then when in the game you can press the button while in chat. If you see '^' show up then the button should work.


This worked.. sort of. In the Logitech software, I programmed mouse button 6 to ^ as you suggested, and it does put ^s in the chat edit box when pressed. This, however, has the unfortunate side effect of activating the ability I normally have bound to the shift-6 keybind. Haha. This is at least a usable workaround. Thank you very much for your suggestions.

For any support reps who may be interested, this still does not address the root issue of the game not recognizing actual Mouse #6 and #9 button presses.

Take care, and thanks again.


Reply Quote
85 Human Paladin
8645
02/10/2011 11:23 AMPosted by Someoneelse
You *might* get better answers in the Technical Support forum but it's always iffy.


Oh, haha. I didn't notice I was not in the tech support forums. I found this post via a forums search. :)
Reply Quote
100 Dwarf Paladin
14010
I have a similar logitech model

My 'extra' buttons are bound (via setpoint) to buttons that I'm unlikely to press during combat:
[
{
]
}
;
:
'
"

etc.

Due to some of my bindings being shifted versions of others ( [ vs { ) I have encountered funky-binding states by un-noticedly pressing CAPS lock
Also I once had a problem where if I "switched users" in win7 off someone elses account rather than logging them off, my bindings as a whole (via setpoint) did not work.

Not sure if any of those are what you're experiencing, but worth looking into.
Reply Quote
85 Troll Priest
2135
02/10/2011 11:29 AMPosted by Kystyrael
I programmed mouse button 6 to ^ as you suggested, and it does put ^s in the chat edit box when pressed. This, however, has the unfortunate side effect of activating the ability I normally have bound to the shift-6 keybind. Haha. This is at least a usable workaround.


I think this is the best solution to the problem, as I've found. Like Kellann suggested above, rebind the key in SetPoint to some key combination you're unlikely to press during combat. Then set one of your skill bar boxes to this same combination, drag the spell / ability you want to use to this box and it should work for you.

It's not optimal but at least you'll get the full use of the mouse buttons!
Reply Quote
90 Dwarf Shaman
9040
I had the same problem setting my mouse scroll button to a keybind.

I finally got it to set after about 15 tries.. no real "fix" but it just worked after yelling constant curse words at it and doing the same thing over and over.
Reply Quote
85 Human Paladin
8645
Yeah, I just set them to unused keybinds and called it a day. Thanks again everyone for the tips.
Reply Quote
85 Draenei Paladin
0
POSSIBLE FIX I bought a Logitech G700 a couple weeks ago and WoW was not able to detect most of these buttons - I figured it might not. The way I worked around this at first was to try Keyboard-style macros, but the Setpoint software is too slow for that...

Ultimately I set up a Game profile on the Mouse and bound each mouse G-Button to a NUM-Pad button: NUM1, NUM2, NUM3, etc.

You'll find that in your WoW keybindings, none of the NUM keys are really in much use. Ready to be bound to stuffs.

As far as the game is concerned when I click my G-button I am pressing a NUM-key which is bound to my bottom left action bar to cast Word of Glory and junk. Works great.

not so much a "fix" as a workaround.
Edited by Cheesebread on 2/10/2011 12:13 PM PST
Reply Quote
85 Undead Warrior
2535
I read this in another forum, cant remember which, works perfectly, close SetPoint, problems fixed for me
Reply Quote
85 Dwarf Shaman
3410
So i tried everything that was suggested on here and nothing seems to work. When i shut off setpoint only my front mouse button works and not the back one. Any other ideas?
Reply Quote
72 Night Elf Mage
580
I found a solution to the problem. I have a Marathon M705 Logitech mouse. It has the same side buttons. I couldn't get my back side button to work for an alt Priest I have. I when into the SetPoint Settings and turned off my game detection features and turned off retain OS settings as well. For some reason this made it work but I'm not sure if it will work on all of the different situations. Best of luck. Cheers.
Reply Quote
85 Orc Warrior
1790
Solution for the G700 Mouse.
In Logitec Setpoint, remove any profiles and just use the General profile.
I was then able to program button 6 and 7 to strife left and right by using CTRL+SHIFT+1 and CTRL+SHIFT+2

Took me 2 hours to figure this out.
Reply Quote
90 Blood Elf Rogue
2775
02/10/2011 12:13 PMPosted by Cheesebread
POSSIBLE FIX I bought a Logitech G700 a couple weeks


did the same thing and had the same initial problem on two seperate PCs. the first time it was the launcher issue, so I editted my shortcut to run WoW on the exe and made sure SetPoint was set to identify WoW.exe

had the same problem yesterday on a new computer. did the above. still nothing. i noticed that on the productivity section of SetPoint, it was bound to winword.exe and works.exe. i deleted those application detections and it worked fine. doesn't make sense why they would interfere, but i guess they did.
Reply Quote
90 Orc Shaman
10620
I had this problem (I have this same mouse) and fixed it. You have to go into the mouse software and change mouse buttons 4 and 5 from forward and back to unassigned.

Something in the mouse software was interfering with the way wow handles the buttons when they were set to forward and back.
Edited by Mogrigg on 3/14/2012 11:56 AM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]