There was a problem logging in...

(Locked)

85 Human Paladin
5435
"There was a problem logging in with this account. You may not have a World of Warcraft game attached to your account, or you may be logging into a region different from the one you created the account in. If you continue having trouble, please contact customer support."

So here I am. Old computer mobo fried about a month ago, built a new computer from scratch, reinstalled WoW and was greeted by this lovely message. Hralp please?

(Can obviously still log into my account on battle.net, as well as the mobile auction house on my iphone. Subscription never lapsed.)
85 Draenei Shaman
4595
Did you perhaps download the EU client? Make sure you're installing the NA client.
85 Dwarf Hunter
1470
Are the game files downloaded by the launcher incompatible between the two regions? I definitely downloaded the EU client by mistake, and now it wants to go through the entire, painstaking updating process again. :(
36 Gnome Rogue
370
03/29/2011 6:07 AMPosted by Mofuk
Are the game files downloaded by the launcher incompatible between the two regions? I definitely downloaded the EU client by mistake, and now it wants to go through the entire, painstaking updating process again. :(


Yes, they are two different things. If you have an NA account, you need the NA client.
85 Human Warlock
2040
"There was a problem logging in with this account. You may not have a World of Warcraft game attached to your account, or you may be logging into a region different from the one you created the account in. If you continue having trouble, please contact customer support."


but:

used exactly WoW-4.0.0-WOW-enUS-Installer.exe
updated my subscription about half hour ago (was frozen)

and yes, I payed for enUS, not enGB.
Account Status
Active
Region
Americas & Oceania (US)
Edited by Evilbloom on 4/25/2012 8:17 PM PDT
44 Blood Elf Warlock
4015
I am having this same issue... From what I can tell, I did download the NA client but it won't let me log in.
I am having the same problem myself.
80 Gnome Rogue
AnW
11270
Folks, this thread is from July last year. In future, if a thread is more than a few days old it is better to create a new one.

If you are getting an incorrect region error and you're certain that you've got the NA WoW client, try changing your password or, if you haven't done so already, creating a Battletag. I believe that has helped some folks out.
Yes, I realised this was an old thread after I replied.

I'm thinking this might fix the problems for the others who posted today too. When I was going through the WoW folder, there's a file called "BackgroundDownloader" which when I opened, started downloading the 4.3.3-4.3.4 patch. Might be a long shot but, it may fix this problem?
85 Human Warlock
2040
made battletag and changed password, got all fixed (o___O)

thanks for solution
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]