Official Camera Stutter, Part 2 (Mac)

- Technical Support
100 Human Warrior
19010
on my system at least i've never seen dbm go over 1-2% cpu with profiling enabled, and this is in pretty spammy fights. my system isn't exactly top of the line either.

however an out of date version is a different story, if being used iwth 4.1's combat log. recount isn't bad until you let it fill up lua memory then it can tank performance pretty significantly if you don't dump logs often enough. omen, it uses next to no cpu, unless like the other ones, isn't a version compatible with 4.1.

archy, if you run this in a bg/instance you're doing it wrong. this is what addon control panel and such are for.
Reply Quote
- Technical Support
90 Human Priest
6220
05/06/2011 02:15 PMPosted by Omegal
archy, if you run this in a bg/instance you're doing it wrong. this is what addon control panel and such are for


For Archy, all you really need to do is left click the minimap button one time before entering the instance. This disables its scanning functions. When you're done with the instance, click the button again and be on your merry way. That is, until you run into the "never ending window of growth" issue. Then you'll want Archy off.
Reply Quote
MVP - Technical Support
96 Draenei Mage
6555
Anyone tested this issue on the 4.2 PTR. If you do bear in mind you will need to commit to keeping it up to date as they don't release all of the patch at once rather then do an incremental build process.

Also Archy's gotten an semi-official update on Curse. Not the bugfix fan version. One which updates everything includign the never ending window of growth issue.
________________________________________________
Bringing you walls of text and cookies since 2005 :)

Mac Tech Support MVP (moonlights in other forums)
Here to Help :)
Reply Quote
85 Night Elf Druid
5045
Has anyone else noticed that this is camera stutter has gotten worse since the 4.1 patch? I've updated everything system and WoW-related, repaired all permissions, repaired WoW and the game is still night unplayable sometimes. It'll take me three or four login/logouts to get my wacky ass framerate issues to be somewhat stable.

This happens when I have ONLY WoW up. No iChat, no vent, no nothing. :(
Reply Quote
- Technical Support
100 Human Warrior
19010
yeah, i noticed it toward end of PTR. the fix in 4.1 they did fixes initial symptoms so it appears better at first, but then, longer app stays open, the worse it gets, and it seems to degrade even more so then it did in 4.0.6, so after having visited a few places, the stutter is even worse then it was in 4.0.6. especially if you visit some key zones, like twilight highlands, then deepholm, uldum, all within same session and totally fill up your texture buffer. heck icing on the cake after visiting those 3, visit zangarmarsh, ;)
Reply Quote
90 Human Paladin
9980
I'm sorry if this is off topic - tell me if it is! - but I've noticed that in areas like Tol Barad that even moving FORWARD causes the screen to "hiccup" for me. Reloading the UI resolves the issue. I deleted my cache, WTF, and interface folders, ran the game naked, and over time the game started doing it again. This wasn't happening before 4.1 and I'm a little disquieted that this happens now.
Reply Quote
- Technical Support
100 Human Warrior
19010
reloadui would not fix stutter, as it won't reclaim anything but lua memory, texture cache will still be filled until you fully exit and relaunch, if it helps resolve your issue then chances are your texture cache is being limited by addon memory. so you get a little more cache when you reload lua memory, if i had to guess, auctioneer, or another very large memory addon loaded, which is load on demand, so reloadui, you unload it for time being (til next time you visit AH or something). that could easily add 60M to application heap after a reload.
Reply Quote
90 Human Paladin
9980
Thanks, I'll move my query to another thread Omegal.
Reply Quote
85 Blood Elf Paladin
2735
Having similar issues. Brand new 21.5 inch i5 iMac with Radeon HD 6770M graphics card and 4GB of ram. Issue is really noticeable around Stormwind and Elwynn Forest when flying around. Have a solid 60 fps then it dips down to 20 fps (really noticeable when when turning).

Can someone explain in layman terms what is causing this issue and why its taking Blizzard so long to address this?
Reply Quote
05/12/2011 12:53 AMPosted by Bluspacecow
Anyone tested this issue on the 4.2 PTR. If you do bear in mind you will need to commit to keeping it up to date as they don't release all of the patch at once rather then do an incremental build process.


As of build 14133, 4.2 is still plagued with terrible stutter.

I'll say it again: bug fixes before major new features.

Edit: this was with the slider set to Fair and was apparent only in Orgrimmar. Stormwind was better, as was a flight from Stormwind to the Isle of Quel'Danas. With the slider at Good or higher, I could induce stutter (more within a city than without) by turning the camera in what were otherwise the same conditions.

Edit2: No significant difference in build 14179.
Edit3: No significant difference in build 14199.
Edit4: Same with 14241.
Edit5: Same with 14265.
Edit6: Same with 14288.
Edited by Shaker on 6/14/2011 10:45 AM PDT
Reply Quote
90 Orc Shaman
9115
Shaker, I'll be honest here. You haven't been coming off very well since you started posting.

You've been complaining about various bugs in other people's threads that weren't really even related to your problem without making your own thread for help first, and the way you say things just comes off as arrogant. Which isn't really even called for given you haven't followed the forum guidelines to begin with. I can't speak for others, but I haven't been able to take you seriously since your first post.

The Mac devs are doing all they can. It's not their call when Blizzard decides to put in new content.
Edited by Stormtides on 5/24/2011 10:41 AM PDT
Reply Quote
100 Human Paladin
12935
Still stuttering in clean PTR install build 14179. Stormwind is not improved at all.

Model Name: Mac Pro
Model Identifier: MacPro5,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.8 GHz
Number Of Processors: 1
Total Number Of Cores: 4
L2 Cache (per core): 256 KB
L3 Cache: 8 MB
Memory: 6 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: MP51.007F.B03
SMC Version (system): 1.39f11

Chipset Model: ATI Radeon HD 5870
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6898
Revision ID: 0x0000
ROM Revision: 113-C0780C-194
EFI Driver Version: 01.00.436
Reply Quote
- Technical Support
100 Human Warrior
19010
i'd say, considering that 4.2 no longer supports hardware acceleration on my machine sutter is about 10000x worse. Apparently i don't have a graphics card supported by wow anymore (ati 5870)
Reply Quote
Support Forum Agent
I've reported both feedbacks included here about the 5870 to S4d1k and Padim. Thanks. Keep up that good work on providing constructive feedback :)
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Tu-Sat 8:45 am - 5 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
What do you call heavy rains in Mulgore? A Taurential downpour....
Bah-ah-ah-ah-rains!!!
Reply Quote
- Technical Support
90 Human Priest
6220
05/27/2011 08:22 PMPosted by Omegal
i'd say, considering that 4.2 no longer supports hardware acceleration on my machine sutter is about 10000x worse. Apparently i don't have a graphics card supported by wow anymore (ati 5870)


Er...huh?

I'm slightly confused here - when no valid video hardware is detected WoW does one of two things: auto-quits, or crashes outright attempting to load the login screen. How do I know this? I attempted to load WoW when I initially got the card but before I had installed the Snow Leopard Graphics Update which was required for the new card to have any 3D acceleration/support (I did this just to see what would happen when the card was in raster mode only).

The hardware acceleration checkbox is, to the best of my knowledge, superfluous (as in a leftover UI component from the Windows client files) in OS X's client and does not have any affect as no Mac at all has any hardware acceleration for sound in its default configuration (thus the superfluous bit - the checkbox is cosmetic only and does not even function in OS X).

So if WoW truly had lost hardware acceleration on your 5870 (which I also have), it wouldn't even load at all. :)

I'm guessing something else got mucked up in 4.2's client, likely in an attempt to fix one bug only to create another, more vicious one. I can at least tolerate High view distance in 4.1, though TH/ZM are still royally craptastic, and the mouse lag bug is really angering me (mouse lags with Triple Buffering active).
Reply Quote
- Technical Support
100 Human Warrior
19010
eh, it's like running diablo 2 in software mode in 256 color mode, that's what wow looked like. the colors were way less vibrant, it looked like 256 color mode with almost no hardware acceleration, i have booted OS X before without video drivers and then say even drag a desktop window it redraws off CPU and you can watch it redraw the pixel lines. this is what wow was doing. it was maxing cpu and not using gpu for anything. it may have detect it but probalby detect it as a generic gpu with no acceleration instructions for it, or features for it so it disabled justa bout everything, and the game ran at about 7fps in stormwind with options on low. it was pretty bad heh. but alas a different issue and off topic so il'l keep that problem to this thread here

http://us.battle.net:80/wow/en/forum/topic/2592641178
Edited by Omegal on 5/29/2011 10:48 AM PDT
Reply Quote
100 Human Paladin
12935
05/27/2011 08:22 PMPosted by Omegal
i'd say, considering that 4.2 no longer supports hardware acceleration on my machine sutter is about 10000x worse. Apparently i don't have a graphics card supported by wow anymore (ati 5870)


After seeing this, I took another look at the graphics settings for PTR Build 14179. This build is NOT detecting my monitor, my OS version or my graphics card. Thus the "Not supported" messages on the graphics settings. I've posted a bug report in the PTR Bug Report forum linked here:

http://us.battle.net/wow/en/forum/topic/2593042496

Reply Quote
Support Forum Agent
Bugs that are Mac for PTR like this should be reported here like Padim/S4d1K suggested since it's easier to handle Mac related stuff here. I've included a link that S4d1k stated.

http://us.battle.net/wow/en/forum/topic/2416117439?page=5#94
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Tu-Sat 8:45 am - 5 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
What do you call heavy rains in Mulgore? A Taurential downpour....
Bah-ah-ah-ah-rains!!!
Reply Quote
85 Tauren Druid
730
Similar problem, I drop from aout 40FPS down to about 10-20 during turns. What should I provide that is helpful?

Are blizz devs able to reproduce this I assume?
Reply Quote
Support Forum Agent
I believe we have all the data we need. If we need anything else, I'll post back. Thanks!
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Tu-Sat 8:45 am - 5 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
What do you call heavy rains in Mulgore? A Taurential downpour....
Bah-ah-ah-ah-rains!!!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]