HUGE Framerate problems after 4.1

90 Human Rogue
0
Is there a formal route to submit hardware info as well as the frame rate issues that we're seeing to the devs?

I'm a bit concerned that:

A) Devs hasn't updated the known issues thread with this... I'm guessing probably because they're having a hard time nailing down the issue and filtering through the noise. There are people with addon issues and data caching issues, which is clearly different than consistent frame rate issues that I've been experiencing.

B) There are a lot of posts that just doesn't give enough information and data. People coming to say that they're seeing problem A or problem B is good. However, we need for people to post their hardware configuration along with that, MacOS version.. etc... that way we can actually correlate which problem might be related to what hardware profile.
Reply Quote
85 Human Warrior
6470
Check this thread-

http://us.battle.net/wow/en/forum/topic/2416158662
Reply Quote
85 Dwarf Shaman
6540
I had framerate issue after updating to 4.1 with my iMac, just like you guys. Since I ran lots of addon, I did what blue post suggested. Confirming permission is not the issue and clearing all cache. Turn out one of the many addons I had was causing the framerate issue. Which one? Recount. Without Recount active, framerate is back to norm. If it is on and my toon flies to some "special" location, such as the area around SW warrior trainers, framerate will drop to 0 or 1. Don't know why, it just does. Hope this message helps you guys.

PS. Since I have a crappy iMac, I have been setting my Graphics to "Low" with projected textures "enable."


I confirm, Recount was my problem too. Have a very good Mac. Framerate went nuts after the patch, disabled Recount and it solved the problem. Thx bud
Reply Quote
62 Blood Elf Hunter
710
Yes mine has been horrible recently, i've been trying to level this dude but it's horrible. When i was walking outta org i did aspect of the hawk randomly and i heard the sound after already leaving the blockade spot, then finally the picture like 1 whole minute later lol, i can hardly even turn too.
Reply Quote
90 Night Elf Druid
10575
Hi i posted yesterday about the problem i am facing on the macbook air late 2010 model, best i can do is about avg 20 fps with low settings, view distance is at fair. Even after all the cache deleting, wtf and interface moving, smc/pram resetting. Is this normal for the macbook air? Don't know what post patch was like as i only bought it on patch day, also.. no adds on. Help please.
Edited by Jaggy on 4/28/2011 9:41 PM PDT
Reply Quote
85 Troll Shaman
4235
I had several buggy addons killing my frame rate, but the biggest culprit was PowerAuras. After updating that addon, I went from 20FPS to 65FPS in Org. I'm still a bit shocked at how big a difference it made.
Reply Quote
90 Night Elf Druid
10575
Hi all, turns out the gpu in the macbook air 2010 13 inch base model was not working as intended, a quick reinstall of mac os bought it back up and am doing 30fps with default good settings now. thanks.
Reply Quote
90 Blood Elf Death Knight
4685
I am having exactly the same framerate issues. The game is basically a slide show. I have no Addons running. I have tried clearing Cache and WTF folder etc.

My system is MacPro 8GB memory with ATI Radeon 4870 card with 512MB

I must admit that I am kind of tired of the game being unplayable for weeks after each major patch. It seems that only the bare minimum of Mac testing gets done. I am fed up with that - we pay just as much as a PC owner and I expect my game to run. If anything, bearing in mind the limited configurations and options for a Mac, Blizz should be able to ace this every damn time. Absurd!

So, I will look for some kind if update or additional advice in a day or so, but if nothing changes I will just drop WoW. It has been a great few years, but I just do not want to go through this hassle every time there is a major patch. It is ridiculous.
Reply Quote
On a 2008 MacBook Pro. Graphics set according to the Mac Graphics Guide. Mostly middle settings except water and sunshafts off.

Disabling recount gave me a noticeable improvement. I have my frame rate limited to 45 and I get exactly 45 fps while flying through Org at full speed and while fighting combat dummies.

Try disabling recount before going nuts on all your folders.
Reply Quote
90 Orc Hunter
10200
All I had to do was turn shadow quality to low and fps jumped back up to normal...
Reply Quote
40 Dwarf Warrior
320
I was having lousy display on ThinkPad R61 Win7x32+SP1 after the WoW 4.1 patch. :-(

The symptom is the display appears jerkey. It is most pronounced when walking about in game. I observe fluid display with a jump in display every 1 to 2 seconds. It looks a bit like blinking as a mage :-)

Anyway, I found that disabling all addon's did improve a small amount but not much. Then I found that removing Interface and WTF then restarting did improve a small amount but not much.

The thing I found made most appreciable difference is tweaking the [Max Foreground FPS] slider in the Options / Advanced area. I now have reasonable play experience when the slider is limited to 15 fps. What I mean by this is I no longer observe the psudo-blink display. I can make it re-appear by sliding the slider back to max.

My guess is the FPS resource scheduler may be thrashing about and causing graphic pipeline flood / starvation situations the result on my computer is a psudo-blink type display. By throttling the required frame rate below the threshold where the FPS resource scheduler comes into effect I seem to resolve the issue on my computer. Although I personally would like a bit more than 15FPS I am used to 25-30 out of my little ThinkPadR61. I hope this provides a clue to where the problem lay. If you made it this far... thanks for reading.
Reply Quote
85 Undead Rogue
3420
i've got a macbook pro 2.4ghz

deleted the cache, WTF & interface folders and still hasn't changed so it's obviously not the addons for me. Please we need a fix for this, it's so frustrating.
Reply Quote
85 Human Mage
4140
my was due it recount
Reply Quote
90 Blood Elf Death Knight
4685
Has there been any update on this? Game is still unplayable for me since the patch. Very frustrating.
Reply Quote
85 Dwarf Warrior
6680
I fixed my fps issues, i tried removing all addons and it had no effect. Dropped all settings to low and it still was low, but i finally decided to turn off sunshafts, instantly fps tripled back to normal. I am able to put all the other settings back to good/high and maintain the fps, and have all my addons running. Hope this helps.
Reply Quote
Support Forum Agent
Sunshafts is a FPS tanker on some machines. Try what Splertiki tried and disable that to see if it helps.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment|| Tu-Sat 8:45 am - 5 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
Why did the Shadow Priest's account expire? Too lazy to drop Shadowform to Renew.
Bah-ah-ah-ah-rains!!!
Reply Quote
85 Goblin Mage
2375
I disable all add-ons and I have frame-rate issues still. My frame-rate has 1/2ed what it use to be. Does anyone know what I can do to determine why my frame-rate w/o add-ons is still in the toilet when previously it was fantastic.
Reply Quote
85 Orc Death Knight
4615
in 6 years everytime i talked to a GM that something was wrong with the game their automatic response is to blame addons. sometimes its addons usually its not.
Reply Quote
Support Forum Agent
It's not saying blame. But it's a first step in troubleshooting many issues.

Also disabling isn't the same as removing the Interface folder for testing. Did you mean removed or just disabled?
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment|| Tu-Sat 8:45 am - 5 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
Why did the Shadow Priest's account expire? Too lazy to drop Shadowform to Renew.
Bah-ah-ah-ah-rains!!!
Reply Quote
- Technical Support
90 Human Warrior
18870
95% of the problems with 4.1 in regard to combat lag/fps issues, were addons

that box that says "load out of date addons" doesn't magically fix them. there is a reason it's off by default after a new patch. if you don't properly maintain addons they will cause problems
and guess what, 4.2 is changing combat log again. so when that patch launches, if you don't update EVERY SINGLE MOD you use before login, you will have same problems all over again. If you press "load out of date" addons and think that's a solution, get ready for major game performance problems. if you disable "show lua errors" expect lots of problems.

honestly i think tony should advocate for the removal of "show lua errors" having an option at all to be turned off. load out of date, has its uses when used properly, as long as errors are never turned off, yu can trouble shoot/use "out of date" mods that weren't broken by patch. but errors under any cercomstance should never be turned off, allowing user to do that is what causes 90% of these threads. Addons are broken and you don't know it cause you turned the errors off. that's like taking the bulb out of your check engine light cause the light bothers you. that doesn't fix your engine.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]