World IPv6 Day

(Locked)

86 Worgen Druid
9580
I meant how do we know if our internet provider gives Ipv6?


Still on http://us.blizzard.com/support/article.xml?locale=en_US&tag=ipv6day :
Q: How do I enable IPv6 on my operating system?
A: Steps to utilize IPv6 are different for each Operating System.
Windows XP Steps
Windows Vista & 7 Steps
Mac OS X 10.6 Steps

Q: How do I check if I have a valid IPv6 address?
A: Any addresses starting with "::", "fc", "fd", or "fe" are unable to work with the public IPv6 internet.

For additional information, you can test your IPv6 connectivity here: http://test-ipv6.com/

Q: My computer doesn't have an IPv6 address, even though it's enabled on my operating system. What should I do?
A: This probably means that your ISP doesn't support IPv6 yet. Some providers are offering experimental IPv6 connectivity for customers who ask for it. Please contact your ISP for more details about the availability of IPv6. Alternatively, you may use an IPv6 tunnel broker in order to obtain an IPv6 address.


You probably want to 1) enable IPv6 on your computer following steps in the first Q/A, 2) just go on http://test-ipv6.com/ and see if you have an IPv6 address, and 3) if you don't, ask your ISP directly.


Says I have a Ipv6 address but no connection
0/10 for your IPv6 stability and readiness, when publishers are forced to go IPv6 only
booo D:



Edit:Yes my computer and router has Ipv6 enabled.
Edited by Darknessclaw on 6/7/2011 6:32 PM PDT
30 Troll Druid
440
U don't have public ipv6 address. Check to see what you internet ip is most likely using ipv4. Ask your isp for ipv6 or using hurricane electric ipv6 tunnelbrooker.

I get 9/10 for ipv6 stability and readiness with Hurricane electric tunnel since comcast don't offer ivp6 over here yet for testing.
30 Troll Druid
440
I wish I could take part in IPv6 Day, as my realm is on the list. That realm being Garrosh, except my ISP is not compatible with IPv6 at this time.

I do hope my ISP will enable IPv6 in the future though, as I would love to test this new feature out. For now though, I'm stuck using IPv4 for the time being.

Glad to see Blizzard is going to test this on the realms though. Even though it is select realms. =P


Use hurricane electric ipv6 tunnel seems to work with WoW as it is 6in4.
I have a v6 address on test-ipv6.com...
"Your IPv6 address on the public Internet appears to be 2002:d8e7..."
but I only pass 7 of 10 tests... says my DNS doesn't support v6. Called my ISP and they said they aren't sure if they are participating or not.

I enabled what was mentioned in the .wtf file and when I log into game, the IPv6 checkbox is grey. =(

http://ipv6.whatismyipv6.net.ipv4.sixxs.org/ see's my IP as well. Curiously my v6 IP changes if I refresh the page occasionally. Must be something to do with the 4to6 tunnel. (I don't honestly understand all of the aspects of v6 yet.)
86 Dwarf Death Knight
2155
I'm on a MAC (10.6.7) here. I've had a tunnel from he.net for years and everything checks out with connectivity to other IPv6 sites. Even after setting SET UnlockIPv6 "1" the option is still grey in network settings in WoW :-(


100 Worgen Rogue
13995
Dang. I wish I could participate. Been using native IPv6 for months.
44 Worgen Hunter
310
If your modem supports bridging then it doesnt need to support IPv6. You can instead set up a PPPoE connection directly to the ISP from the computer, bypassing your router entirely.

If you want to try it, use the "new connection wizard" in windows, and choose Broadband (PPPoE). If it works, chances are that you're now using IPv6. try visiting http://ipv6.google.com
100 Draenei Mage
10830
So, I decided to take part in world IPv6 day. At the moment, I am using a tunnel broker (HE.net) to get IPv6, but it's tunneled on my router, so my desktop has no clue it's not a native IPv6 connection. I've found my config.wtf file in the wow installation/wtf folder and added the SET unlockIPv6 "1" line to the bottom of it. Starting wow up still has a greyed out IPv6 checkbox. I double-checked the list and Winterhoof is on the list, so I should be able to test out IPv6 connectivity.

I have both a static IPv4 address, and a static IPv6 address (2001:470...), as well as DNS that works with IPv6. Running Windows 7 Enterprise (x64). The http://test-ipv6.com/ test site gives me 10/10 for both IPv4 and IPv6, yet WoW still can't sem to find a valid IPv6 address.

Any thoughts on how to make this work? I'd like to do my part and chip in to test, but it's difficult to do when the software won't let me.

More details (specific addresses/configs) can be furnished upon request.
85 Undead Warrior
7175
We could stick with IPv4 if we just put everyone outside the US on NAT XD
90 Dwarf Shaman
13945
The config.wtf modification enabled the IPv6 checkbox, however when attempting to log on to any of the realms listed I wait at "Logging in to game server..." for several seconds and then return to the realm selection without ever accessing the character selection screen. Login to any other server is instant.
Edited by Quirk on 6/8/2011 9:03 AM PDT
Support Forum Agent
Good morning, and thank you for participating in IPv6 day!

The World of Warcraft client tries to detect a valid IPv6 address on your local computer, so if only your modem has it, it very probably won’t work. In order to help us troubleshooting, could you follow these steps on the computer you’re using, and give us the result back?

Under Windows, go to the start menu, run, type “cmd” then enter. In the MS-Dos command prompt, type the command “ipconfig”

Under MacOS, go to the spotlight, enter “terminal”, and execute that software. In the opened terminal, type the command “ifconfig”

For privacy reasons, you may not want to fully copy/paste the IP addresses, but that’d be very helpful for troubleshooting. An IPv6 address looks like the following:
2a01:e0b:1:64:abcd:1234:5678:abcd

What we really need is the first four numbers; in that example, that would be 2a01:e0b:1:64. So you can remove safely the second half.

________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html
How's my driving? https://www.surveymk.com/s/R5D3LCF

Check your G-diffuser system!
30 Troll Druid
440
What going to happen in US is most user going to nated to net and slower internet due one box many users issues will arise instead giving them ipv6 equipment (cheaper for ISP).
100 Draenei Mage
10830
JonD,

Here's the info you requested. I've blocked out the trailing portions of my IP's for security reasons. If you need the whole address, I can provide it via other methods (e-mail, support tickets, etc).

Please note that the 'Intel' configuration is my primary net connection. The 'Realtek 1' card is for a private work network that is only used locally. Also, since I'm using a tunnel broker, the first four portions of my IPv6 address would be enough to uniquely ID my connection. As such, I've included the first three. Again, if you need more, I can provide it via less public methods. Doing a 'ping ipv6.google.com' (and for today only ping www.google.com) gives me a valid IPv6 ping result as do various other test sites. So I'm relatively certain that IPv6 is enabled and working. The WoW client just likes to show the IPv6 support box as greyed out, even when the config.wtf file parameter is present.

Windows IP Configuration


Ethernet adapter Intel:

Connection-specific DNS Suffix . :
IPv6 Address. . . . . . . . . . . : 2001:470:8:...
Link-local IPv6 Address . . . . . : fe80::...
IPv4 Address. . . . . . . . . . . : 10.0.0.10
Subnet Mask . . . . . . . . . . . : 255.255.255.0
IPv4 Address. . . . . . . . . . . : 96.10.X.X
Subnet Mask . . . . . . . . . . . : 255.255.255.240
Default Gateway . . . . . . . . . : 2001:470:8:...
96.10.X.X

Ethernet adapter Realtek 1:

Connection-specific DNS Suffix . :
IPv4 Address. . . . . . . . . . . : 10.116.113.67
Subnet Mask . . . . . . . . . . . : 255.255.255.240
Default Gateway . . . . . . . . . : 10.116.113.65

Ethernet adapter Realtek 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter isatap.{B164BE5A-ECF8-412F-93C6-E9329B79F0CA}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter isatap.cisco.com:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 9:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :


Thanks for the help!
Support Forum Agent
Vulphara,

You can actually bypass WoW's check for IPv6 by adding the following in config.wtf:
SET enableIPv6 "1"

Could you give that a try to force the setting? Even though your setup seems quite common, you might have a case we haven't properly implemented in the IPv6 detection code.
________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html
How's my driving? https://www.surveymk.com/s/R5D3LCF

Check your G-diffuser system!
81 Worgen Rogue
850
Yay! My server is part of the IPv6 test!

Kinda slightly sucks that I gotta work late today. I wanna play around in IPv6. =C
Edited by Cestus on 6/8/2011 12:13 PM PDT
90 Gnome Mage
7825
I cant go on any realm
6 Tauren Druid
0
Works fine for me. No problems so far.
100 Draenei Mage
10830
Hey JonD,

Thanks again for the reply. I tried adding SET enableIPv6 "1" to my config.wtf file, and it doesn't seem to be having any effect. Connecting to Winterhoof doesn't give an indication that there is an IPv6 connection (there is no IPv6 or protocols section in the game info tip), and the IPv6 checkbox in the network section is still greyed out. At first I avoided looking at the checkbox in case it would interfere with the setting from the WTF, but it doesn't seem to make a difference.

On a hunch, I disabled my other two network adapters (the Realtek 1 and Realtek 2 provided previously) so that I only had one adapter. This made the wow client much happier. Apparently the problem arises when you have more than one network adapter installed/enabled (even if it has no link). I tried enabling/disabling combinations of adapters, but only when all enabled adapters had an IPv6 address would it work. After checking the box the config.wtf file contained SET useIPv6 "1" in it (slightly different than your previous post. Maybe a typo? Or are both needed?). Now, after renabling both adapters, I can use IPv6, even though the client still indicates the option as not available (greyed out, but checked none-the-less). The useIPv6 setting seems to make it work, even though the detection scheme is broken.

If you need me to submit a formal bug report for the multi-adapter IPv6 issue I will be happy to. Otherwise, thanks for pointing me in the right direction and helping me test out IPv6 readiness!
10 Tauren Warrior
0
I have a v6 address on test-ipv6.com...
"Your IPv6 address on the public Internet appears to be 2002:d8e7..."
but I only pass 7 of 10 tests... says my DNS doesn't support v6. Called my ISP and they said they aren't sure if they are participating or not.

I enabled what was mentioned in the .wtf file and when I log into game, the IPv6 checkbox is grey. =(

http://ipv6.whatismyipv6.net.ipv4.sixxs.org/ see's my IP as well. Curiously my v6 IP changes if I refresh the page occasionally. Must be something to do with the 4to6 tunnel. (I don't honestly understand all of the aspects of v6 yet.)


Try using OpenDNS' IPv6 DNS servers.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]