Equipset Macro not working in combat

(Locked)

85 Worgen Warrior
8755
Having a macro that uses a equipset can't be used in combat. It does work out of combat just not in combat. Here is an example of an equipset macro:

#showtooltip Shield Wall
/equipset 1HPvP
/cast Shield Wall

Was this intended or not?
85 Night Elf Druid
10970
In combat, changing gear causes a GCD, therefore any use of an Equipset macro, with EQS before the spell, will require two presses.
85 Worgen Warrior
8755
06/29/2011 01:27 AMPosted by Konungr
In combat, changing gear causes a GCD, therefore any use of an Equipset macro, with EQS before the spell, will require two presses.


Yes I'm aware that it takes 2 key presses for it to work but when you press it like 20 times it should of worked XD. Also I have had this macro for a long time so I know it worked before in combat.
Edited by Ixbillyxi on 6/29/2011 1:32 AM PDT
90 Orc Death Knight
8615
bump for this issue, macro I had for equipset worked fine before 4.2. Now it can't be used in combat, works just fine outside of combat.

/equipset [nomod] pvp
/equipset [mod:alt] pvpshield

As if it wasn't hard enough to kill mages before.....
90 Gnome Mage
4840
Blizzard changed it so that addons cannot change your gear when in combat using the equipment manager. iirc, they forgot to add /equipset to the secure list of commands and when you use it now it taints your UI and fails. I would think that this would be in the next hotfix.
85 Night Elf Hunter
1285
06/29/2011 07:20 AMPosted by Tseerah
I would think that this would be in the next hotfix.
I believe anything related to the UI requires an actual patch. Don't quote me on it, though.

___________________________

<<It doesn't work the way I want it to, so it must be bugged.>>
www.wowpedia.org/User:Egingell
wow.curse.com/members/egingell.aspx
90 Draenei Shaman
11650
This is a major problem on my fury warrior. I have weapon swaps macroed into my stances.

Using /equipslot 16 & 17 lines: if I switch to Defensive for shield/1h then back to Berserker for dual-wield it only equips one of my dps weapons - in the mainhand, leaves my shield in the offhand. I'm guessing this is because my dps weapons are two of the same item. If they have different names its not a problem.

With two identical weapons I have to use an /equipset line instead. Until yesterday this worked perfectly (aside from the annoying "cha-ching" noise). Now it only works if I'm out of combat.

Edit: Just tested it with my one and only addon turned off - it works fine with the Blizzard UI, but not with Bartender4.
Edited by Zarana on 6/29/2011 2:48 PM PDT
85 Gnome Warrior
2805
/bump same issue here.
85 Blood Elf Paladin
0
It's still an insecure slash command in build 14333. :(
90 Gnome Warrior
12315
While Blizzard visits this issue, it would be a good time to allow /equip and /equipslot to handle two weapons of the same name. Give priority to weapons found in containers instead of inventory/worn, lock container slots already in the process of an equip, skip locked container slots, voila.

With addons unable to participate in weapon swaps in combat, we really need Blizzard to fix this long-standing bug.
85 Gnome Warrior
1590
bump
85 Worgen Warrior
4580
Yah.. it sucks, but at least you can work around it by using /equip or /equipslot like:
/equip Vicious Gladiator's Slicer
/equip Vicious Gladiator's Shield
It's odd because you can change weapons in combat using the equipment manager, just not the /equipset macro.... boggle
85 Worgen Warrior
8755
Bump
90 Goblin Shaman
12945
im to lazy to go back to equipslot macros, hope this gets fixed soon
85 Worgen Warrior
8755
Bump
90 Goblin Warrior
14405
Really annoying for fury warriors that use 2 of the same name weapon.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]