Razer Naga Issues Post Patch 4.2

85 Tauren Warrior
3730
I've been using a wired Razer Naga to play WoW for the past few months, and have had no problems whatsoever until now. I've been using three of the numpad buttons on the Naga as my ctrl, alt, and shift modifier keys (configured using the Naga's software), and it's been working great. However, after yesterday's patch WoW has stopped accepting those buttons as modifiers for hotkeys. As in, Ctrl+G doesn't activate my Ctrl+G hotkey, but simply G. Oddly, WoW still seems to recognize them as modifiers in relation to the mouse itself, as I can shift+click on things using my Naga-bound modifiers. I'm wondering if anyone else has been having this issue, and if anyone has found/knows of a solution?

For reference, I'm playing on a Macbook (one of the old 13 inchers), and have all the latest Razer drivers (2.01) and Mac software upgrades. I've also emptied my WTF, Cache, and Interface folders for WoW, on the off chance that was the problem. I've also deactivated all my add-ons.
Reply Quote
85 Dwarf Priest
5395
I use a Razer Naga Epic in wired mode. After 4.2 came out it became so frustrating to use I went back to a non-Razer mouse (Logitech). The issue I had was if I clicked on a mount icon or water or whatever, then clicked outside my action bar, the icon would be pulled off my action bar. I also had to seem to click multiple times to get things to work, and the mouse was nearly unusable on clicking stuff in my bags. Essentially my Razer has been useless post-patch where pre-patch it was awesome.

I don't know the solution, just searching around.
Reply Quote
My problem with the razer naga since the 4.2 patch was I can't use the naga add on that razer made. I got used to it so much and playing without it has really messed me up.
Reply Quote
85 Blood Elf Priest
3330
I am having the same issues here with the modifier keys on my Razer Naga mouse. I have the same 1-3 buttons on the mouse bound to shift, option, control respectively, and they are not working. I also have the latest drivers for the mouse.



07/04/2011 12:21 AMPosted by Broxtön
My problem with the razer naga since the 4.2 patch was I can't use the naga add on that razer made. I got used to it so much and playing without it has really messed me up.


If you go to the addon menu on the character select screen, you can select "Load out of date Addons" and it should load just fine. It did for me once I selected this option.

So, has anyone found a way to get these modifier keys to work?
Reply Quote
^
Holy crap bro!

thanks a lot!
Reply Quote
Support Forum Agent
Thanks for the reports. So just to get this right:

You guys have on your Naga set up where the keys on the side are actual modifiers, like 1=Alt, 2=Cntrl, etc; and when you use those, it doesn't recognize them as the modifier pressed like if you did 1(Alt)+9, correct?

This was working fine in 4.1 you say and not 4.2? I'm just trying to gather more info. Thanks.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Tu-Sat 8:45 am - 5 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
Pfft! Secret doors, who needs 'em? What do I care about secret doors?... and the unparalleled delights they keep hidden from the world!
Reply Quote
85 Tauren Warrior
3730
Yep! That's exactly my setup. Worked perfectly in 4.1, stopped functioning abruptly when I logged in on patch day.
Edited by Delged on 7/5/2011 12:12 PM PDT
Reply Quote
85 Blood Elf Priest
3330
Thanks for the reports. So just to get this right:

You guys have on your Naga set up where the keys on the side are actual modifiers, like 1=Alt, 2=Cntrl, etc; and when you use those, it doesn't recognize them as the modifier pressed like if you did 1(Alt)+9, correct?

This was working fine in 4.1 you say and not 4.2? I'm just trying to gather more info. Thanks.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Tu-Sat 8:45 am - 5 pm CST
If you can't find it here, contact a rep direct :[url]http://us.blizzard.com/en-us/company/about/contact.html[/url]
[url]http://www.surveymk.com/s/RF8K3KG[/url] ---- Rate my Baaaaalue Posts. Haala at your sheep!
Pfft! Secret doors, who needs 'em? What do I care about secret doors?... and the unparalleled delights they keep hidden from the world!


Yes exactly. I cannot get them to work, it functions on the keyboard but not on the mouse. The buttons are extremely difficult for me to reach on the keyboard, so all my bindings revolve around being able to use the modifiers on my mouse!

Also, I tried it with another gaming mouse I had and found the problem to still exist. So I doubt the modifier issue is just involved with the Naga.
Edited by Avathari on 7/5/2011 3:54 PM PDT
Reply Quote
85 Undead Mage
2320
More information for this problem:

It exists on my logitech M570 mouse too, it appears to be a problem with any software/driver level remapping of the shift/ctrl/(maybe other) keys. I have a game controller which does hardware level remapping, and that still works fine. This is not a problem that exists only when using the shift key as a modifier either - if you hold shift and type in chat it will not capitalize letters. In fact, the problem is present from the moment the game is launched, as if you do the same test (hold mouse remapped shift) in the email area of the log in screen, shift doesn't have an effect there either.

Also, I'm nearly positive that the problem did not come with the initial 4.2 release, as I have played normally since the Firelands was released. I think that the problem happened this week, possibly Tuesday.
Reply Quote
85 Tauren Shaman
4130
i'm also having a similar issue, but with no remapping. using shift and ctrl as a modifier for the normal number keys also seems to be functioning improperly.

at least this is the case for me.

to be more specific, pressing Shift + N1(on the mouse) doesn't seem to apply the shift modifier, as it just casts what i've got bound to the N1 button.
Reply Quote
Similar issue on Logitech MX8. Shift and alt binds not working on the mouse. Tried a number of things and I haven't found a reliable fix.

However, I've been having the problem since the 4.0 release, more or less. Only affects me on the Mac, when I take the mouse over to my wife's PC it works fine.
Reply Quote
85 Blood Elf Priest
3330
Is this still being looked into? The modifier issue is extremely frustrating to work around, I'd love to be able to fully use my new naga!
Reply Quote
MVP - Technical Support
90 Draenei Mage
6490
07/20/2011 04:37 PMPosted by Avathari
Is this still being looked into? The modifier issue is extremely frustrating to work around, I'd love to be able to fully use my new naga!


AFAIK Yes.
Reply Quote
Support Forum Agent
Yes. Sorry for the lack of updates.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Tu-Sat 8:45 am - 5 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
Small talk. Small talk... Flies. Peanuts. Dimes. Oh, and sweaters. They get muy, muy small in the wash.
Reply Quote
90 Gnome Warlock
7440
My issue is a bit different, however from reading on the forums on wowcurse others have the same issue too. On my rogue when i shadow dance or now stealth too the buttons wont switch so i have to click them on another grid. did that make sense? basically my stealth abilities are not replacing my regular abilities when in stealth or shadowdance. really killing me.
Reply Quote
90 Gnome Warlock
7440
This is for windows by the way, sorry I saw the thread and did not notice it was mac.
Reply Quote
85 Troll Shaman
2295
Just bought the mouse and downloaded latest Drivers and Addons and having the same problem. The primary key map works fine Keys 1-12 but the Modifier maps don't work. They display as S-1, S-2 etc. but when the Shift-1 key is pressed it just acts like no Shift key was pressed.
Reply Quote
86 Dwarf Hunter
7740
Was the problem with the Razer Naga and using 123 as shift,alt,ctrl modifiers ever fixed?
Edited by Johnnyhood on 9/23/2011 6:38 AM PDT
Reply Quote
Support Forum Agent
We are still working to address this issue.
________________________________________________
Klint P
Mac Tech Support for Blizzard Entertainment || Mon - Fri 1:45pm - 10:45pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
https://www.surveymk.com/s/TKL88F8 <---- Rate my Blue post here...
If there is a problem Yo I'll solve it, now check out my hook while the DJ revolves it...Mac Mac Baby!
Reply Quote
85 Undead Mage
8765
I just bought a MAC because it displays as well as performs so much better then any PC I have ever had. I finally decided to switch WoW over to my new MAC since I started having vid-card problems with my Qosmio only to find that my naga won't work properly. Is there any update on this issue?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]