Razer Naga Issues Post Patch 4.2

85 Night Elf Druid
8700
04/16/2012 08:48 PMPosted by Bankotsu
How do I do this Terminal now? I'm not sure what that is or what to do.

Open Terminal from Applications > Utilities > Terminal. You can also open Terminal by using Spotlight.

http://us.battle.net/wow/en/forum/topic/2743696123?page=3#49
Reply Quote
90 Blood Elf Rogue
6835
04/16/2012 03:21 PMPosted by Omegal
Did you do the terminal command when wow was CLOSED? if it was open the command would not have worked nor saved, it would have been overwriten and not taken effect as soon as you exited.


Yes. It did not work.
Reply Quote
Blizzard Employee
04/16/2012 02:15 PMPosted by Punkcess
Cannot get this to work; terminal fix did not work. Any idea when this will be repaired? I see posts in this thread from nearly a year ago when this issue started; is there honestly no fix yet?

This isn't something that is a bug we are able to address directly. This is relating to conflicts of the OS, the game and possibly the drivers. I can ping the team again to take a look and see what else they may be able to do. I may need to review the terminal fix again and see how to properly do this if others are experiencing issues.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

I'm not big on boasting, but you might have to take a victory lap.
Reply Quote
90 Blood Elf Rogue
6835
Thanks

04/17/2012 04:38 PMPosted by Machkhan
Cannot get this to work; terminal fix did not work. Any idea when this will be repaired? I see posts in this thread from nearly a year ago when this issue started; is there honestly no fix yet?

This isn't something that is a bug we are able to address directly. This is relating to conflicts of the OS, the game and possibly the drivers. I can ping the team again to take a look and see what else they may be able to do. I may need to review the terminal fix again and see how to properly do this if others are experiencing issues.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

I'm not big on boasting, but you might have to take a victory lap.
Reply Quote
100 Blood Elf Warrior
11135
Terminal, didn't work for me either, Thanks for looking more into it, Hope there is a fix soon.
Reply Quote
I can say that this fix resolved the problem for me. I am so happy, I can now actually attempt to heal a dungeon on the MoP beta. I would never even attempt it without the ability to cast the way I am used to (with Healbot). Now I can use the Raid UI with mouseover macros and still use my mouse buttons to heal. So, so happy I found this fix.
Reply Quote
Well, stupid me. I queued for a Heroic on Beta now that the mouse problem is fixed and I got myself permanently stuck on the loading screen. Sigh.
Reply Quote
55 Worgen Rogue
0
f*** my mum just bought me a Razer Naga, it was $100 and was working fine. But now the patch came along and my mouse is useless FML
Reply Quote
Blizzard Employee
07/17/2012 04:09 AMPosted by Decsmaster
f*** my mum just bought me a Razer Naga, it was $100 and was working fine. But now the patch came along and my mouse is useless FML

Did you try the terminal workaround?

http://us.battle.net/wow/en/forum/topic/2743696123?page=3#49
Reply Quote
90 Orc Warrior
16030
Wow. Bought a new Naga and didnt try it on my laptop.

Thought it broke already, thanks for the fix.

also, it worked while wow was open.
Edited by Parrish on 7/31/2012 7:25 PM PDT
Reply Quote
85 Night Elf Druid
7905
Hey guys, I am pasting com.blizzard.worldofwarcraft disable-expose-fix -bool YES into terminal and I am getting a "command not found"

WoW is also closed, am I doing something wrong?
Reply Quote
85 Night Elf Druid
7905
I wish I never messed around with this.

Now I can't get "ALT" to show up while binding modifier keys.

I adjusted the modifier setting in the preferences of mac osx and it did not fix anything.

The best option right now is just click the use command as control option in the mac settings in WoW.

Healbot still doesn't recognize ctrl, command, or alt either on my new mac.

Everything works perfect on my old mac on 10.6.8.

Big bummer.
Reply Quote
77 Night Elf Priest
3105
This has been driving me nuts for a while too. Firts it was the middle mouse button and then that started working all of a sudden, then buttons 4 and 5 - but the middle worked. First I restored default controls and that worked until my next login, and the same problem all over. Then I tried the User Account Control workaround and that worked for a day and 3-4 logins than back to the same issue. FInally I saw some of these replies in page 2 of this thread and bypassed the launcher and now my buttons work again. (for now..??) By the way -> Logitech M510 Mouse / PC / G15 Logitech Keyboard.

Workarounds can wind up creating other issues down the road that build up sometimes.

A word to Blizzard moderators for this forum - even if this problem is still being worked on at least someone reply to this thread (and all the other similar threads ) and saying so would be nice.
Reply Quote
90 Human Paladin
15905
Hey everyone.
Just finished reading through most of the thread and wanted to clarify a known issue with the Naga Epic Mouse that I'm having as a PC user.

This issue I believe was mentioned by 1 or 2 people thus far so hopefully this clears things up.

Before i bought my Naga i had 12 abilities bound to 3 Mouse buttons via 3 In-game macros.
These macros allow me to hold Shift, Ctrl, OR Alt to turn 1 Ability into 3 different abilities depending on which key is being held down, allowing me to simply click the mouse button to activate the ability that is showing.

Now, Naga in hand, I tried assigning 3 of the 12 side buttons to my previous mouse button setup (using the Num Pad Configuration). After doing so i found that while HOLDING DOWN the shift key my abilities would not go off when pushing my assigned side buttons.

Oddly it appears that while the Shift key is being held, the Naga mouse enters a state where all its Num Pad side buttons become unusable. I also noticed that during this state, Num Pad 4 acts as a left arrow, 6 a right arrow, 2 a down arrow, and 8 an up arrow, even when not playing WoW.

To me this hints as not a WoW error but a Naga overriding default. I tried downloading the latest Naga drivers hoping to find some kind of option to change it but no luck.

Hopefully this helps clear up any confusion on a problem that may be fixable. Any ideas or known fixes for this problem would be great. Apologies for such a long post. Thanks everyone!

P.S. I tried the 123 setting and it made 2 of the 4 keys unusable so no go there either.
Edited by Audaciousme on 8/23/2012 7:33 AM PDT
Reply Quote
1 Dwarf Paladin
0
I have a slightly different problem, but also related to the recent upgrade of the firmware and drivers:

The mouse no longer works for panning view. Rather, it moves violently and erratically with any movement. I've played around with it, and it seems to be looking only at the pointer position, not the direction of movement. (E.g., if the pointer is to the right, the pan will go only to the right; if up, the pan goes only up. Any x/y combination yields the position-relative movement, not the scrolling direction.)

Changing sensitivity or acceleration has no effect, and removing the updates did not solve the problem - leading me to believe the firmware update is bogus. Do NOT upgrade your Naga Epic drivers!
Reply Quote
Just wanted to say the terminal line worked for me as far as the shift, alt, and control modifiers.

Thank you Blizz
Reply Quote
85 Tauren Druid
5745
Terminal command code posted totally works. Did it with WoW open and it fixed the issue. i have an original razer naga. Thank you so very much.
Reply Quote
90 Human Mage
14930
I just bought a mac mini and I use a logitech g500. This fix allowed my modifiers to work in wow as well. Just posting for those logitech users who face this . I cant lose all those keybinds!!! This particular mouse is not supported by logitechs control center for mac. This is logitechs lack, not blizzard or apple.
Reply Quote
95 Gnome Warrior
10500
So, and update of sorts.

As mentioned earlier, we've implemented a terminal command that you can use to disable the expose/Spaces fix that was implemented in 4.2. (you can copy/paste this in Terminal)

  • defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES
  • This is somewhat working, as after some testing with a naga here, the [Shift] key was able to be mapped to button 1, and used, but this was tested here. Are y'all able to test this out for constructive feedback? The [Cntrl] and [Option/Alt] keys were still not recognized, and that is something we're still investigating.

    I want to ensure you that we're still working & looking at this, as well as working on a variety of other things at the same time. I'm making this a sticky for the time being, so we can have some visibility on this. Thanks!
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
    [url]http://www.surveymk.com/s/RF8K3KG[/url] ---- Rate my Baaaaalue Posts. How's this sheep doing?
    Dedicated to making your Mac/Blizzard Experience an awesome one!
    Knowing others is intelligence; knowing yourself is true wisdom.-- Lao Tzu
    this totally worked for me, I'm quite happy again. thanks for the research :D
    Edited by Dingzor on 2/15/2013 2:50 PM PST
    Reply Quote
    90 Undead Rogue
    13780
    If you go into your search options and look for terminal, you will find it. From there just copy/paste the code from above and it should work. Just did this for mine because my laptop just crashed on me and everything checks out and working well with my mac.
    Reply Quote

    Please report any Code of Conduct violations, including:

    Threats of violence. We take these seriously and will alert the proper authorities.

    Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

    Harassing or discriminatory language. This will not be tolerated.

    Forums Code of Conduct

    Report Post # written by

    Reason
    Explain (256 characters max)

    Reported!

    [Close]