Addons breaking for 4.3?

90 Undead Rogue
13185
Disabled FishingBuddy and Recount for myself - and the game seems to load fine (if after a few mins. of load time, but it still loads).

Though I've always had issues with Load Times ever since 4.0.1. Had a thread about it that Blizzard Blues were helping me with at one time, but have never gotten resolution on. :(
Reply Quote
90 Undead Rogue
13185
Also ingame, auctioneer looks to be really buggy so I'm going to disable it as well...
Reply Quote
85 Worgen Death Knight
11140
Mounted is also one of the crashers.
Reply Quote
90 Blood Elf Paladin
18240
Thanks to the folks who suggested disabling FishingAce. I disabled it and now WoW loads fine. Thank you.
Reply Quote
90 Night Elf Druid
10425
Had a similar hang with Broker_location.
Reply Quote
90 Human Paladin
9680
My only problem was FishingBuddy, and recount seems fine for me so far.

A ticket with the author of FishingBuddy was already submitted by someone else, but so far no update is available.

P.S. The only other addon issue I found was with Atlas, which on curse was not in a complete package as in the past. Instead, I had to separately download the main addon along with each of the components individually (e.g., OutdoorRaids, Transportation, DungeonLocs, Battlegrounds, etc.).
Edited by Gordonbuchat on 11/29/2011 3:05 PM PST
Reply Quote
90 Tauren Druid
16515
Any way to figure out what's broken with Fishing Buddy/FishingAce? Since it keeps WoW from loading at all, I don't know how to try to help the addon author figure out the problem. Just trying to help out.

Though, TomQuest2 did the same thing. I should see if they have any libraries in common, I guess!

ETA: Apparently it's Lib-Tourist that's breaking the Fishing mods. Updating it to this one fixes it: http://www.wowace.com/addons/libtourist-3-0/files/122-wow-4-3-beta1/
Edited by Ruana on 11/29/2011 3:18 PM PST
Reply Quote
90 Human Mage
11570
Any way to figure out what's broken with Fishing Buddy/FishingAce? Since it keeps WoW from loading at all, I don't know how to try to help the addon author figure out the problem. Just trying to help out.

Though, TomQuest2 did the same thing. I should see if they have any libraries in common, I guess!


The addon author needs to update his copy of libtourist. This applies both to FishingBuddy and TomQuest2.
Edited by Raimondas on 11/29/2011 3:09 PM PST
Reply Quote
Any way to figure out what's broken with Fishing Buddy/FishingAce? Since it keeps WoW from loading at all, I don't know how to try to help the addon author figure out the problem. Just trying to help out.

Though, TomQuest2 did the same thing. I should see if they have any libraries in common, I guess!


The addon author needs to update his copy of libtourist. This applies both to FishingBuddy and TomQuest2.
Downloading LibTourist's 4.3 beta from WowAce and installing it as a stand-alone AddOn may fix it.

http://www.wowace.com/addons/libtourist-3-0/files/122-wow-4-3-beta1/

If that doesn't work, you could try putting an exclamation mark at the front of the folder and .toc file's names (LibTourist-3.0 becomes !LibTourist-3.0). That should force it to load earlier and (hopefully) prevent the older copies of it (packaged with FishingBuddy and TomQuest2) from dividing by zero and crashing the game.
Edited by Choonster on 11/29/2011 3:24 PM PST
Reply Quote
90 Troll Priest
11775
I was hanging on login due to both of the following mods:

Cromulent
FuBar - GuildFu

In both cases, it was an old version of LibTourist-3.0 causing the issue.
Reply Quote
Was locking up at load screen as well and had to manually kill. First I disabled old addons so I could successfully load. Then I enabled old addons and unchecked FishingBuddy, Recount and Mapster. Was then successfully able log.
Reply Quote
90 Night Elf Druid
16735
If you're having issues with Recount, get Skada. It's working just fine.
Reply Quote
85 Gnome Priest
12230
I believe Bagnon (NOOOOOOO) is also fried.
Reply Quote
90 Human Warrior
11335
Cromulent addon was the culprit for me. Hope this helps someone else.
Reply Quote
90 Orc Warrior
12780
TravelAgent was causing the hanging on loading screen issue for me.
Reply Quote
MVP - Technical Support
90 Blood Elf Hunter
17040
11/29/2011 12:39 PMPosted by Ryoxo
Some minor trouble with Chinchilla due to the LFD functions but three lines commented out of two files brought it back mostly functional.


Ran into a similar problem myself with SUI. Rename LFDSearchStatus to LFGSearchStatus and you should be good to go.
________________________________________________
The wise speak only of what they know. - J.R.R. Tolkien
CORE I7 3.8GHz | 12GB RAM | ATI 5970+5870 | F120 SSD
Live Support: irc://chat.freenode.net/wowtech
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]