4.3 Fails to load after character selected

84 Tauren Warrior
3050
Out of all my addons, only Mounted was preventing me logging in. It doesn't look like it's getting updates any time soon. LiteMount seems to work pretty good, supports the newer mounts (and druid/shammy forms, etc), and says it automatically supports future ones.

http://www.curse.com/addons/wow/litemount
Reply Quote
90 Undead Warlock
4885
So far, it looks as though TomQuest2 and TravelAgent are both culprits
Reply Quote
90 Blood Elf Paladin
5660
Fishing Buddy solved it for me too - thanks for the suggestion Kalaan.
Reply Quote
85 Blood Elf Rogue
1470
*****************************
SILVER DRAGON DOES NOT WORK
*****************************
Reply Quote
85 Worgen Hunter
12935
same problem, disabling all addons allowed me to log on.
Reply Quote
90 Human Mage
11025
11/29/2011 11:39 AMPosted by Kalaan
I found the error, for me it was FishingBuddy.


Thank you! It was FishingBuddy that was hanging me up.
Reply Quote
So it seems like i'm having the same issue, but it's not an AddOn problem, i even tried renaming my Interface folder just to try logging in without ANY AddOns, same with WTF, but it just won't log in, the bar fills up to 85/90% and that's it, couldn't log in any characters, any help will be appreciated since i have a raid in 2 and a half hour.
Reply Quote
90 Undead Warlock
4885
11/29/2011 02:26 PMPosted by Beldox
So it seems like i'm having the same issue, but it's not an AddOn problem, i even tried renaming my Interface folder just to try logging in without ANY AddOns, same with WTF, but it just won't log in, the bar fills up to 85/90% and that's it, couldn't log in any characters, any help will be appreciated since i have a raid in 2 and a half hour.


Beldox, have you tried deleting your WoW cache folder and running the World of Warcraft Repair tool?
Reply Quote
Yes, and i could log in an lv 1 character on a random realm, but when i tried to log in my main character on the repective realm, the bar freezed at 100% just like it did before on 85/90%.

EDIT: IDK what happened the time when it went to 100% but it's back to 85/90% just like before.
Edited by Beldox on 11/29/2011 2:41 PM PST
Reply Quote
85 Troll Druid
Bad
13620
I can't even log in with FuBar plugins running and not the addon itself (to try and use them on Docking Station et al).

Anyone know of replacement addons? I don't want to have to go without Guild/Durability/Bag/Latency Fu :(
Reply Quote
89 Undead Mage
6110
11/29/2011 01:54 PMPosted by Zephyyra
Some experimentation with lib updates seems to point at an older version of LibTourist being the cause for those two addons. I found a beta version of LibTourist at the WoWAce dev site and replacing its folder in the lib directories of those two addons has solved the lockup problem. I had updated ACE3 and Babble libs previously, but the problem persisted until LibTourist was replaced.

I can't thank you enough for posting this - it does indeed seem to be a problem with LibTourist. I did a search of my AddOns folder for LibTourist, disabled only those AddOns using it ... and was finally able to log in with all of my other AddOns running.

Thanks!

EDIT: Updating to the latest LibTourist library fixed the AddOns DevNull, FishingBuddy, and FuBar_QuestsFu ... it did not fix MapsterEnhanced, which still causes the load bar to hang (I'll be watching for an update).
Edited by Spytte on 11/29/2011 3:01 PM PST
Reply Quote
90 Undead Warlock
4885
Thank you Zephyyra for pinpointing LibTourist.

I replaced the LibTourist folder in TomQuest2 and TravelAgent with the latest beta from WowAce and both addons now load and appear to work correctly.

The beta LibTourist can be downloaded here:

http://www.wowace.com/addons/libtourist-3-0/files/122-wow-4-3-beta1/
Reply Quote
90 Blood Elf Mage
12610
turning off Fishing Buddy got me in too
Reply Quote
85 Blood Elf Paladin
6430
Fishing buddy for me as well.
Reply Quote
90 Draenei Shaman
18200
Glad to hear the LibTourist fix seems to be working. Sorry about not posting the direct link to the file.
Reply Quote
67 Human Death Knight
1710
I get the same thing with my game.
Reply Quote
68 Draenei Mage
745
Have the same issue. I enter the realm and it would crash before my char would appear. Looks like QH is giving the problem for me at least. I dont use it much so disabled it is.
Reply Quote
85 Troll Druid
6350
Fishing Buddy and Broker_Location for me
Reply Quote
90 Draenei Priest
7505
Thank you, Joker! Disabled Silver Dragon and everything is running smooth. :D
Reply Quote
90 Undead Warlock
6605
For me it was Fishing Buddy and Broker_Location
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]