Cities In Dust: Quest not complete

14 Human Hunter
50
Okay so, I need help if anyone knows anything I can do to resolve this...
The quest goes fine until Lady Sylvannas is shot and Cromush yells "Godfrey what have you done" and he yells "join your mistress in death"...then nothing happens...she is never resurrected by the sacrifice of her val'kyr.
I can't attack Godfrey and the others to avenge the queen and Cromush and the val'kyr just stand there.
After trying everything I could think of.. I finally just walked off defeated. When I turned back they were all gone and now I cant find them.
I'm lost in quest limbo without a quest line and the Cities in Dust quest I have is incomplete. Please help. I've Googled, talked to others and opened a ticket. I just don't know what else to do. I would be forever grateful of any help I receive.
Reply Quote
100 Human Mage
13085
This quest phases out a good half of Silverpine Forest.

I would recommend you abandon the quest, return to The Sepulcher, log out at the inn there, log back in, then return back to the Forsaken Front. You should be able to reacquire the quest from Sylvanas there. This time, stick around for the rest of the event. If it gives you a problem again, stay where you are and open a ticket in-game.
Reply Quote
38 Undead Warlock
1600
I am having the same problem. Has anyone found a way to resolve this?

It happened to me pretty much the same way, except when nothing happened, I thought to venture forth into Gilneas. The Val'kyr follow me and we are attacked by lvl13 elite worgens. Then, I return to The Forsaken Front and only Godfrey is there and the val'kyr disappear. Now, I am able to target him. He is an elite with a skull, but I attack him anyway. I figure, what the hell? Why not?

I actually almost kill him and dialog starts with him saying something about retreating to Gilneas, and I begin missing him with all my hits. He then disappears, and I am left with an incomplete quest line and no idea what to do.

Please help.
Reply Quote
38 Undead Warlock
1600
I abandoned and reaquired...how do I open an in game ticket. Made a ticket out of game...don't know if it'll help. Any ideas?
Reply Quote
100 Human Mage
14975
File an in-game ticket by clicking the icon on the bottom of the screen that looks like a red question mark. The screen that pops up will have an option on the left for submitting a ticket.
Reply Quote
29 Blood Elf Hunter
1015
For the record, I just had the same problem. Filed a ticket and the GM followed me through. The problem I had was actually just that I was still mounted from the ride to the wall. Once I dismounted, the fight began.
Reply Quote
71 Blood Elf Warlock
0
I tried this quest and it did the same to me and I've tried everything. Is the quest messed up or am I doing something wrong?
Reply Quote
50 Troll Druid
2650
Follow Elfelfalelf's advice: the quest looks the same at Graymane Wall, but if you dismount during the discussions, before the shooting, you will be able to join in the fight when it starts, and see the proper conclusion, after which you can complete the quest. (Painfully learned, after logging in and out and watching the fight 3 times).
Reply Quote
52 Blood Elf Mage
665
My problem is that everybody disappears as we run across the field. There is never anyone at the wall or the quest mark. I have abandoned more than once and even logged out. They disappear at the same spot everytime, and are no where to be found. Also I have no mount so that is not a problem.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]