World of Warcraft *4.3.4* 64 bit client

(Locked)

100 Tauren Druid
14175
GREAT fix, This fixed my stutter issue with moving my camera around and my fps is more steady at 60 plus I can toon hop really fast now
90 Tauren Druid
13400
Would really like to get my Steel Series mouse working with the 64-bit version. The mouse bindings don't work with the new version. If anyone could help, that'd be helpful. Thanks in advance.
85 Blood Elf Mage
3180
STEAM OVERLAY NO LONGER WORKS, when 64 bit wow is launched through the steam client.

It may have been said in an earlier post but I’m not reading through 12 pages of bull!@#$ to check :P

Not sure it's up to blizz or steam to fix that, neither of them are affiliated with each other so I hope they just fix it to support the gamers. It’s probably in Steams best interest to get it working or there’ll be a lot less wow players buying/using steam games.


hmmm that stinks :(

Try this solution that worked for TOR for me and use the wow 64 bit:

http://disdaingaming.com/swtor/how-use-the-steam-overlay-with-the-old-republic




Yes that is the problem, the new Wow-64.exe & launcher.exe is not recognised by steam as the same program so its not linking the overlay to the wow client.

I just changed my steam shortcut to the wow.exe instead of launcher and it works :) That link you provided shows method you can also use to link them together.
Edited by Codmage on 2/1/2012 6:04 PM PST
87 Tauren Druid
0
I now its mentioned for MAC, but, I am having a problem with my G15 KB in Windows 7 Ultimate x64. LCD Screen works fine, but the G macro keys won't send anything to the game. I didn't notice if this is a reported bug yet or not as I know MAC G15 issues were LCD based..
90 Blood Elf Hunter
8230
Well a fresh reinstall helped me. I do have a question for those that are ahead of me and playing now. Should I move the files from (x86) to normal program files before I add the 64-bit files? How is the 64-bit working so far? I copied my WTF, cache and interface files before I uninstalled so will it be possible to add those back for my addon settings after this is done.
85 Blood Elf Priest
10925
02/01/2012 05:38 PMPosted by Crazyalbo
curious as to where people are seeing fps increases? i only seemed to notice it once which was on the black phase of zonozz


I get 60 FPS on ultra video settings in the Valley of Strength, whereas I only got about 45 there before.
87 Tauren Druid
0
02/01/2012 06:03 PMPosted by Todasjager
Well a fresh reinstall helped me. I do have a question for those that are ahead of me and playing now. Should I move the files from (x86) to normal program files before I add the 64-bit files? How is the 64-bit working so far? I copied my WTF, cache and interface files before I uninstalled so will it be possible to add those back for my addon settings after this is done.


You would be better off to install it to Program Files by the installer when you re-installed.. Just moving it will cause problems with Registery Keys as some have reported the moving process borked the game..

Besides, won't do anything if you leave it in program files (x86)..
Edited by Abraga on 2/1/2012 6:12 PM PST
90 Blood Elf Hunter
8230
02/01/2012 06:11 PMPosted by Abraga
Well a fresh reinstall helped me. I do have a question for those that are ahead of me and playing now. Should I move the files from (x86) to normal program files before I add the 64-bit files? How is the 64-bit working so far? I copied my WTF, cache and interface files before I uninstalled so will it be possible to add those back for my addon settings after this is done.


You would be better off to install it to Program Files by the installer when you re-installed.. Just moving it will cause problems with Registery Keys as some have reported the moving process borked the game..

Besides, won't do anything if you leave it in program files (x86)..
Ok thanks, I just wanted to make sure it would be fine in (x86) as 64-bit. Im not sure why some were saying it was better out of (x86). any idea about my other files I had copied, will that work?
90 Blood Elf Hunter
8230
(╯°□°)╯︵ ┻━┻
87 Tauren Druid
0
02/01/2012 06:24 PMPosted by Todasjager


You would be better off to install it to Program Files by the installer when you re-installed.. Just moving it will cause problems with Registery Keys as some have reported the moving process borked the game..

Besides, won't do anything if you leave it in program files (x86)..
Ok thanks, I just wanted to make sure it would be fine in (x86) as 64-bit. Im not sure why some were saying it was better out of (x86). any idea about my other files I had copied, will that work?


You can put those back..
100 Night Elf Death Knight
7270
I just did DS and there was still lower fps, but better and less lag. Running on phenomII x4 955 3.2, 8 gb ram, evga GTS 450. fps was 23-60, way better than the 12 fps i have been getting in DS fights. Still lag on Yor'sajh and Hagara for some reason

Edit: When i turn off Carbonite my fps goes up to 60-85 in the world, 40 to 80 in SW. Carb is dropping framerate down to 30 or less. TomTom and WoW-Pro do not affect it.
Edited by Ezmaralda on 2/4/2012 10:50 AM PST
Using the 32 bit client I have 15 fps in the middle of SW, with the 64 bit client I have 10. Whats going on with that?
90 Tauren Druid
8120
02/01/2012 06:57 PMPosted by Zf
Using the 32 bit client I have 15 fps in the middle of SW, with the 64 bit client I have 10. Whats going on with that?


even 15 is garbage, time for some upgrades
02/01/2012 07:00 PMPosted by Commack
Using the 32 bit client I have 15 fps in the middle of SW, with the 64 bit client I have 10. Whats going on with that?


even 15 is garbage, time for some upgrades


I am on a laptop. If I had my desktop up and working It would run the 32 bit client on ultra at max fps like it did before I started having problems with it.
90 Blood Elf Paladin
7910
so, it works comparably to the 32-bit client so far. haven't raided yet but will try that later and update the post.

i ran the client directly from the wow directory, as regular user. keybinds are working, and screen resolution and settings are as they should be, however, the graphics settings show up as "good"/custom, with 800x600 resolution. i'm pretty sure that the other graphics settings were still as i'd had them before.

core i7 3.4ghz, 8gb, gtx 275, wired
100 Blood Elf Death Knight
17410
It's worse then the 32 bit for me :l
87 Human Warrior
9620
Its rocking the 8th core on my i7 constantly at around 80%, making CPU fans spin up, 32bit didn't load my CPU the same.
85 Blood Elf Paladin
9440
My overall FPS decreased by about 15 but it still feels smoother than the 32 bit did. My screen isn't like skipping randomly anymore. My FPS is places like crowded BGs (Did AV) is far better. It used to drop by like 20. It drops by maybe 3 now. There's not really a huge change going between high - ultra in FPS even though the graphics get better though. Loading screens don't take forever now too.

About to go do 25 man normal Madness so I guess I'll see how that goes.

Laptop- 8 gb, i7 @ 2.2 ghz
90 Draenei Shaman
7705
Playing on a Xeon E5620 @ 2.4ghz with 16gig's of ram and a nvidia 550.
solid 149fps - and less cpu usage. overall, feels good!
85 Goblin Priest
2975
I have a 64 bit operating system, but when i click on game preferences and try to "untick" launch 32 bit version, it doesnt allow me, how do i fix this?
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]