Launcher broken, cant add real id, many other

100 Human Hunter
18345
Hi team,

Ever since about 4.2 i've had problems getting the launcher to work. While the launcher itself does open (and during patches downloads them), the launcher never goes through to the game itself.

I have deleted cache, wtf, interface as suggested.

With no add ons:

I've run the launcher as admin as suggested.

I ran the repair tool "no problems detected"

No luck.

Also around 4.2 time, I got hacked. After said hacking, I lost all my real ID friends, and have never been able to add a new one "Player not found"....people send me invites that I never seem to get.

For a point of cudos, you all did an absolutely brilliant job in restoring all of my said items and were very helpfull in the process despite what I got the impression the hacking was all my fault....hmmm...ok I'll let that one slide....

So frankly I kinda gave up on the problem and figured you'd fix it all in 4.3. Clearly that's not the case.

So, today after having a free day, I decided to once again try deteting cache, wtf, interface, running the repair tool, and still no luck.

Uninstall time - go to uninstall the game, it tells me it can't: "The folder "C:\Program Files (x86)\World of Warcraft\Data\enUS" could not be deleted. (UninstallFolder::Prepare/not empty)"

However it does delete that file anyways so there appear to be no remnants of the game what-soever.

Reboot.

Go to account and download game again, 1st piece 8 hours, 2nd piece 4 hours, so 12 hours later, yay! oh wat? launcher fails again:

Description
A problem caused this program to stop interacting with Windows.
Faulting Application Path: C:\Program Files (x86)\World of Warcraft\Launcher.exe

Problem signature
Problem Event Name: AppHangB1
Application Name: Launcher.exe
Application Version: 4.2.1.2685
Application Timestamp: 4f28a04d
Hang Signature: e2bd
Hang Type: 6144
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 3081
Additional Hang Signature 1: e2bd55e4d832d20bbc1fff6e65ad940d
Additional Hang Signature 2: 4ccd
Additional Hang Signature 3: 4ccd2577d40083c9e953272185ce30e1
Additional Hang Signature 4: e2bd
Additional Hang Signature 5: e2bd55e4d832d20bbc1fff6e65ad940d
Additional Hang Signature 6: 4ccd
Additional Hang Signature 7: 4ccd2577d40083c9e953272185ce30e1

So i skip the derp launcher and run from wow.exe, it runs, but I still cannot add a real ID friend.

Pre reinstall process, UI issue abound, I had to reload UI about 20 times a day to see pets (dont get me started on hunter pets dang you lot - winks), see the map, see focus targets, see achievements, etc...

Any ideas, I've done all the usual tricks and even started fresh, clearly the ball is in your court now, please help.
Reply Quote
Support Forum Agent
Purplestar,

I looked into your account and I see that Real ID had been disabled in your account controls. It's likely this was done during the compromise. I've switched it back on for you.


The launcher crash and you're recent compromise sound like they may be virus related. Have you scanned your system recently? Lets do a thorough scan if not.

1. Download the following programs:
Rkill: http://www.bleepingcomputer.com/download/anti-virus/rkill
FixTDSS: http://www.symantec.com/security_response/writeup.jsp?docid=2010-090608-3309-99

2. Reboot into safe mode.
Here's a link that shows you how to get into safemode:
http://us.blizzard.com/support/article/21148

3. Run Rkill, then run FixTDSS.
When FixTDSS finds the rootkit, it'll need to restart to remove it. You can let it restart normally.

4. Download & install malwarebytes.
Here's a link where you can download Malwarebytes: http://www.malwarebytes.org
*Be sure to completely update it before running any scans.*
Do a full scan - it'll take over an hour, but its required to remove the rest of the keylogger bits.

Once all that is finished.....

Please run this online scan. Make sure you accomplish the recommended fixes the scan may find.
http://secunia.com/vulnerability_scanning/online/
________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html

Check your G-diffuser system!
Reply Quote
86 Troll Druid
5860
Purplestar,

I looked into your account and I see that Real ID had been disabled in your account controls. It's likely this was done during the compromise. I've switched it back on for you.


The launcher crash and you're recent compromise sound like they may be virus related. Have you scanned your system recently? Lets do a thorough scan if not.

1. Download the following programs:
Rkill: http://www.bleepingcomputer.com/download/anti-virus/rkill
FixTDSS: http://www.symantec.com/security_response/writeup.jsp?docid=2010-090608-3309-99

2. Reboot into safe mode.
Here's a link that shows you how to get into safemode:
http://us.blizzard.com/support/article/21148

3. Run Rkill, then run FixTDSS.
When FixTDSS finds the rootkit, it'll need to restart to remove it. You can let it restart normally.

4. Download & install malwarebytes.
Here's a link where you can download Malwarebytes: http://www.malwarebytes.org
*Be sure to completely update it before running any scans.*
Do a full scan - it'll take over an hour, but its required to remove the rest of the keylogger bits.

Once all that is finished.....

Please run this online scan. Make sure you accomplish the recommended fixes the scan may find.
http://secunia.com/vulnerability_scanning/online/
________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html

Check your G-diffuser system!



With all due respect, I really wish you guys would get away from the "Well, it's your virus scanner" fix. It doesn't work, and it's not the problem.

I have to start Task Manager, end the Launcher process, go into the WTF folder, delete the LAUNCHER.WTF file, make sure I run as Admin, and click play.

If I am lucky, the game starts. More often than not, I will go through this, click play.....and nothing. I have to repeat the above mentioned steps.

I know that a Blue had stated that they could not replicate this problem. However, and you can check this through search, there have been many, many people experiencing this exact problem.

It's not a virus and it's not a virus scanner problem.

Having vented that, while it may take several attempts, the above mentioned steps do work.
Reply Quote
100 Human Hunter
18345
Hi team,

1 - Thanks for resetting the real id, clearly i was unaware of that. Is it possible to change the message when attempting to add a real id to "Real ID is turned off - please see your account management tools" rather than "Player not found"? Surely would help the confusion here.

2 - So purportedly I have a rootkit...., and by your indications, potentially a specific one called tidserv(TDSS).....hmm...did some reading on this.

Firstly – what would be the indications for you to suggest that it would be that specific one? Has the launcher had problems only with this TDSS or is there another indication to you that that particular one is the problem (maybe you saw something in my log files or activity during the initial compromise)?

In safemode:
* Tried rkill - it scrolled by very fast but I did notice it said about 8 times "access denied" very quickly before the DOS window closed. I couldn’t see anything else as it closed too fast. Then it gave a windows error message "installation failed".

* Tried the Norton TDSS removal tool - "Pre-boot failed" and it closed without allowing me to run it. However after another reboot, it did run and said “Suspicious use of kernel callback but MBR appears intact. Repair not done, no infections found”.

So ran Malwarebytes anyways (full scan), it completed with “The scan completed successfully. No malicious items were found”.

I've gone further to try the Microsoft Standalone System Sweeper tool – however that stops as well saying it can’t put the bootup files on a USB.

I get that these programs not running might be symptomatic of the kit trying to stop it being detected, if indeed I purportedly have said kit.

Just of note - at the time of my original compromise, I was running Norton full suite up to date - have since swapped to Microsoft Security Essentials. Everyone said Norton was a joke. How ironic that it’s a Norton tool to remove a kit that Norton let through and still won’t work...meh I’m getting off track.

So I either have a kit and it can’t be detected/removed and frankly I have to give up as I don’t know what else to try, or, I have no problems and the launcher itself is still not behaving.

At this point, I’m happy to run the game from the wow.exe directly, just annoying.

For the larger issue of whether or not I have a said kit, the computer industry as a whole has a lot to answer for, surely they have more data and tools, and understanding of the issue than a typical home user, particularly someone who has used a computer for many years and has a fairly good understanding of the tricks and traps – and one who has ALWAYS kept security/virus/windows update – up to date. I find it a bit rich that its always “my problem, or my fault”, and I’m clearly not saying it’s the games fault, but the industry as a whole has to do more, the industry is failing us.

3 – for the UI issues, I presume these are not related to the launcher. Any ideas on why achieves keep bugging out and not showing in the achievement status window (reload ui), focus frames go missing randomly (reload ui or reapply focus), pets go missing (reload ui, call pet – I know there are other hunter pet issues still that were supposed to be fixed), maps keep disappearing (reload ui), v plates going on and off at random, quirky behaviour with targeting?

As an example, I never bothered to log a ticket but I was wanting to tame a rare pet, found one yay, dismissed pet, started taming (with free slot in my local stables), and lo and behold my pet called itself and killed the dang thing…..hahahaha…I figured I’d never be able to get a ticket on that resolved, but that’s the sorta stuff that drives us crazy!

So technically I’m up and running as i have been since the launcher problems showed up in the first place, thanks for real id, the launcher – meh – I can still play, and please keep improving UI issues they are all over the place.

Keep up the good work, and keep making the game better folks!

=)
Reply Quote
85 Orc Rogue
0
* Tried rkill - it scrolled by very fast but I did notice it said about 8 times "access denied" very quickly before the DOS window closed. I couldn’t see anything else as it closed too fast. Then it gave a windows error message "installation failed".


That is a telltale sign you HAVE the kit. Just keep hitting rkill over and over again until it starts to run, ensure that you are running rkill by right-clicking and hitting "Run as Administrator" . Once it runs SUCCESSFULLY, it will display a notepad prompt with a list of actions it took. Rkill will shut down the rootkit and that will enable the other programs to detect and kill it piece by piece.

There are alternately named versions of rkill at that link, I would suggest trying one of them as well.

__________________________________________________________________________________
SUPPORT for Connection/Latency/Lag Related Issues
Click here: http://us.battle.net/wow/en/forum/topic/1020824261
Unofficial WoW Tech Support Pages
http://www.wowpedia.org/Portal:Technical_support
Reply Quote
100 Human Hunter
18345
I finally did get rkill to run, it said:

"Terminating known malware processes, please be patient."

Then the notpad prompt with a list of actions said:

"Processes terminated by rkill or while it was running:"

/blank /nothing /nada...

"Rkill completed on x date at x time"

Re ran tdss - as above same message - "Suspicious use of kernel callback but MBR appears intact. Repair not done, no infections found"

Re ran malwarebytes - all clean.

So I'm still not convinced I have a kit.

This kit thing is worse than a rogue....but I might be able to get it with a monkey stun, scatter and trap. =P Now we just need a kit be gone talent.

Reply Quote
90 Blood Elf Priest
12335
I was hacked on Wednesday and now my Real ID has disappeared in-game, and I can't figure out how to fix it either.

*I just sent in a ticket and a GM explained:

Go into your battle.net account>Settings>Communication Preferences>Privacy>Enable Real ID
Edited by Iily on 2/26/2012 1:28 AM PST
Reply Quote
Ok, so try a few things here. In windows, Click start button>Run.
Type MRT click ok. Should get a box that asks run program. Click yes.
Click next. Choose Full scan and run it. It will take a while.
(MRT, Activates windows malicious tool remover)

Another thing for registry http://download.cnet.com/Free-Registry-Cleaner/3000-18512_4-10752457.html
Edited by Whithund on 2/26/2012 3:32 AM PST
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]